LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-02-2005, 10:11 PM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Rep: Reputation: 83
changing openoffice menu font


How can i change OpenOffice's font?

The one I have changes '' and so on for different characters (squares ).
 
Old 10-04-2005, 07:55 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
To change the fonts in the OO menus go to:
Tools-->Options-->Fonts
check the "Apply Replacement Table" and write in the left drop-down menu "Andale Sans UI" (because it does not exist in the menu!!). Then from the right drop-down select the font you want, click on the green "V" and check both "Always" and "Screen".
If you want to change the font in the text boxes (as in the spellchecker) then select the "Interface User" font from the left drop-down and replace it with the one you like from the right.
 
Old 11-02-2005, 02:30 PM   #3
105659
LQ Newbie
 
Registered: Nov 2005
Location: BC, Canada
Posts: 26

Rep: Reputation: 15
Much of my gui shows only garbled, unreadable "characters" although the main pull-down menu is ok. Everything below Customize or Options is completely unreadable. I'm stuck because I'd actually have to be able to *read* the items in my menus to change the ui font to something legible. What can I change (i.e., in some text file with an editor) to set the menu fonts? (I'd like to attach a screenshot here but it seems not to be possible.)

Fedora 4, OO -2.0.0-3, installed font rpms:
fonts-xorg-100dpi-6.8.2-1
fonts-xorg-ISO8859-15-100dpi-6.8.2-1
fonts-xorg-truetype-6.8.2-1
fonts-xorg-ISO8859-14-100dpi-6.8.2-1
fonts-xorg-ISO8859-2-100dpi-6.8.2-1
fonts-xorg-75dpi-6.8.2-1
fonts-xorg-ISO8859-9-75dpi-6.8.2-1
fonts-xorg-cyrillic-6.8.2-1
fonts-xorg-ISO8859-14-75dpi-6.8.2-1
fonts-xorg-ISO8859-2-75dpi-6.8.2-1
fonts-xorg-ISO8859-9-100dpi-6.8.2-1
fonts-xorg-syriac-6.8.2-1
fonts-xorg-base-6.8.2-1
fonts-xorg-ISO8859-15-75dpi-6.8.2-1

any ideas?
 
Old 11-03-2005, 05:33 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Trying to help you, I replace my "Andale Sans UI" font with "Arial Black" in OO 2.0 and searching my ~/.openoffice.org2 I found that the change is written to the file: ~/.openoffice.org2/user/registry/data/org/openoffice/Office/Common.xcu which is an xml file. The affected section is as follows:
Code:
 <node oor:name="Font">
  <node oor:name="Substitution">
   <prop oor:name="Replacement" oor:type="xs:boolean">
    <value>true</value>
   </prop>
   <node oor:name="FontPairs">
    <node oor:name="_0" oor:op="replace">
     <prop oor:name="Always" oor:type="xs:boolean">
      <value>true</value>
     </prop>
     <prop oor:name="OnScreenOnly" oor:type="xs:boolean">
      <value>true</value>
     </prop>
     <prop oor:name="ReplaceFont" oor:type="xs:string">
      <value>Andale Sans UI</value>
     </prop>
     <prop oor:name="SubstituteFont" oor:type="xs:string">
      <value>Arial Black</value>
     </prop>
    </node>
   </node>
  </node>
 </node>
Take a backup of this file and make the changes you want to see if your menu becomes readable.

NOTE: is infact a ":" followed by "o"

Last edited by bathory; 11-03-2005 at 05:37 AM.
 
Old 11-03-2005, 08:39 AM   #5
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Well.... I want to tell you something I noticed roght after I installed the nVidia drivers for my GeForce2 Go card. Fonts started looking the way they should... at least in firefox... I will look in openoffice to make sure.

That makes me think it was a setting in the nv dribver configuration that had to be tweaked to make it look right. It could be the physical size of the screen, I guess.
 
Old 11-04-2005, 02:35 PM   #6
105659
LQ Newbie
 
Registered: Nov 2005
Location: BC, Canada
Posts: 26

Rep: Reputation: 15
OO 2 ui font fix worked

Bathory, thank you very much for finding the change I needed to make in ~/.openoffice.org2/user/registry/data/org/openoffice/Office/Common.xcu . It has solved my ui font problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice-font question satimis Linux - Software 0 04-01-2005 08:33 PM
changing the kde menu font size and background colours minm Linux - Newbie 1 02-25-2005 07:51 PM
OpenOffice font setting unixfreak Linux - Software 0 07-23-2004 02:03 PM
openoffice menu font size in Redhat 8.0 mezger Linux - Software 6 10-15-2003 01:02 PM
OpenOffice font probs Salchabasil Linux - Software 0 12-07-2002 01:51 PM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration