LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-20-2012, 03:59 AM   #1
cssidhu
LQ Newbie
 
Registered: Nov 2012
Posts: 2

Rep: Reputation: Disabled
change Xorg display from :0 to :1


this is my system information, currently installed Centos 6.3 :

uname -a

Linux mylocalhost 2.6.32-279.el6.x86_64 #1 SMP Fri Jun 22 12:19:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

----------------------------------------------------------------------------------------------------------------------------------------

Issue:

Now on my present centos 6.3 install my /usr/bin/Xorg:0 is process is running on display :0 on tty1 as seen below :

ps -ef | grep Xorg

root 2174 1 0 11:54 tty7 00:00:01 Xorg vt7 -query remotehostname :1.0
root 2220 2218 0 11:54 tty1 00:00:11 /usr/bin/Xorg :0 -nr -verbose -audit 4 -auth /var/run/gdm/auth-for-gdm-WnUXzz/database vt1
root 3321 2810 0 13:48 pts/0 00:00:00 grep Xorg

Before I migrated from Centos 6.2 to Centos 6.3, /usr/bin/Xorg:1 was running on display :1 on tty7 as seen below :

root 2219 2217 0 11:05 tty7 00:00:07 /usr/bin/Xorg :1 -br -verbose -auth /var/run/gdm/auth-for-gdm-iaSbcA/database -nolisten tcp

-----------------------------------------------------------------------------------------------------------------------------------------

Question

Now is there a way I can have the process "root 2220 2218 0 11:54 tty1 00:00:11 /usr/bin/Xorg :0 -nr -verbose -audit 4 -auth /var/run/gdm/auth-for-gdm-WnUXzz/database vt1" changed to "root 2219 2217 0 11:05 tty7 00:00:07 /usr/bin/Xorg :1 -br -verbose -auth /var/run/gdm/auth-for-gdm-iaSbcA/database -nolisten tcp".

I am unable to find the file where i can make this specific change to fix this issue and I've been trying to work gdm custom.conf in centos 6.3 but it doesn't have any impact.

If their is anyone who can put me in the right direction i'll be very grateful, i hope i've made my question clear.
 
Old 11-21-2012, 01:58 PM   #2
steelneck
Member
 
Registered: Nov 2005
Distribution: Slackware, Arch
Posts: 43

Rep: Reputation: 8
I might have misunderstood your question, so take this with a grain of salt.

I think you should take a look in /etc/initab, that is the usual place that defines on what tty you end up in.
 
Old 11-22-2012, 04:01 AM   #3
cssidhu
LQ Newbie
 
Registered: Nov 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Mate tty is all good I can change it without any problems.

My main issue is how to change default Xorg :0 display to Xorg :1 .

The reason behind all this is that I am trying to run an Xsession independently which executes A okay on display ":1" but there are certain applications which won't run on display ":1" and will only run on display ":0".

So I am hoping if there is anyway to change default display of Xorg :0 to Xorg:1

I hope this make sense and I'd really appreciate some help cause i haven't had any success with the amount of googling I've done for past 3 days.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no display after exiting out of xorg - slackware 13.37 marneson Slackware 2 11-05-2011 04:42 PM
Display/Xorg problems Micro420 Suse/Novell 1 09-17-2005 09:08 PM
Altering xorg.conf to change mice doesn't work or disables display alex_denner Linux - Laptop and Netbook 3 02-06-2005 08:10 PM
XOrg: shared display kaon Linux - Software 5 01-16-2005 05:18 PM
stretch xorg display? shanenin Linux - Software 5 11-02-2004 03:12 PM


All times are GMT -5. The time now is 08:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration