LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Change X refresh rate on Geforce 4MX/32MB with Compaq S710 crt monitor (http://www.linuxquestions.org/questions/linux-software-2/change-x-refresh-rate-on-geforce-4mx-32mb-with-compaq-s710-crt-monitor-263896/)

Xolo 12-08-2004 02:06 AM

Change X refresh rate on Geforce 4MX/32MB with Compaq S710 crt monitor
 
Good day,


I have a server running Mandrake 9.0, and apart from some minor unconfigured stuff I have
one slightly cosmetic problem: the default refresh rate for my monitor was chosen to be 85hz
which is throwing off the image on my monitor, it doesn't like to be set 1024x768 @ 85hz.
So I need it changed to 75hz, so the image doesn't shrink and jump to the right on screen.

I have tried editing the XF86Config files without positive results. I might have also botched up
those files' permissions in the same process, although I tried to correct that.

steps I took:

service dm stop
edit XF86Config / XF86Config-4 to contain an (what I thought to be) apppropriate modeline
for the Compaq S710 color monitor, set at 1024x768 @ 75hz refresh rate
save file, exit
service dm start, and I get tossed into the login manager and start X
image still shrunk and shifted
rebooted, image still shrunk and shifted.

I've obviously missed something here, I thought the settings would either reside in XF86Config
or XF86Config-4 (probably the latter) but I couldn't get it to change, so there's something missing.


Any thoughts?


Thanks in advance and have a nice day.

carl0ski 12-08-2004 02:37 AM

um i have mandrake 10 so :S

is there
KDE>configuration>KDE>hardware>DISPLAY & RESOLUTION.
use these settings (i dont like using monitor from list)
select custom monitor
Quote:

Model: S710
Max Resolution: 1280 x 1024
Sync Type: Seperate
H Freq/ V Freq: 30-70 / 50-160

If there isnt anything similar in 9
Make sure you arent running X if you edit XF86config file

it doesnt seem to change it when i use X to edit it

run it from init 3
#vi /etc/X11/XF86config-4



I found my monitor on the list but it doesnt work as well as it does just using plain generic or CUSTOM



*note if you run "KDE>configuration>KDE>hardware>DISPLAY & RESOLUTION."
it adds a program to the dock which right click and you can change the refresh rate
:)

Xolo 12-08-2004 03:45 AM

I'll try the custom monitor settings, however I remember I messed up X that way
when I did the first install on this machine.. there's no monitor refresh rate
setting you can access from X anywhere in 9.0 like you can in 10.x where you
have that nice applet and can just click on it.

Thanks for finding the monitor sync specs, I had a hard time locating those.
Finally, how do I make sure X isn't running? at install I didn't set X to start
at boot so I assume it isn't running when the machine is booted, and I edited
the config files without X yet nothing changed.
Can I pass init 3 to the (boot) prompt?

carl0ski 12-08-2004 04:01 AM

Just boot normal and if x (KDE, gnome whatever you use) load your probably at INIT 5
(runlevel 5)

just use a console ctrl+ALT+F1

login and type
init 3

#you are now at runlevel 3
edit your XF86config-4 file

Quote:

Section "Monitor"
Identifier "monitor1"
HorizSync 30-70
VertRefresh 50-160
EndSection
edit your file so this section sorta looks sorta like this in th XF86config file



Remember too if in the extreme case you end up with a resolution that put scramble jargon on the screeen
CTRL+ALT+ (+ on numpad)
will cycle through resolutions

carl0ski 12-08-2004 04:06 AM

This actually might be the easiest solution

do you have the mandrake install cds still?
well the first one

reboot your computer
boot the cd to install it

choose "update to Mandrake 9.2"
follow the prompts
it won't ask to format or anything you wont lose files
it rebuilds you hardware settings and lets you choose your hardware as you did when you first installed linux.



If you get stuck and cant get into KDE remember
lynx
is available from command line

Xolo 12-09-2004 12:13 PM

Thanks for the many replies.

Yes, I have the official cd's, but i'm not going to risk breaking my server install right now.
My server doesn't have X at boot, i'm left with a login prompt as this is more resource friendly,
if I want X I usually start it later when i'm logged in by using startx.
I've tried altering the monitor section of XF86Config-4 with the monitor sync specifications you
found but this doesn't change anything at all, in fact, these are similar values like XFree inserted
when I selected the monitor from the list. If I define a custom monitor, I still do not have the option
to choose a refresh rate, instead it again asks for the sync specifications and chooses to use
85Hz as the default refresh rate, with predictable results.
(I simply do not see how I can force it to use 75Hz in the config file right now)
I really need to force Xfree to _not_ default to 85Hz, it has to be 75Hz when the screen is set to
1024x768 pixels.

Xolo 06-28-2005 01:48 AM

Problem solved, I now have an LCD Flatpanel. (Bit drastic, but hey it works ;) )


All times are GMT -5. The time now is 05:48 PM.