LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Change Op5 web interface directory (http://www.linuxquestions.org/questions/linux-software-2/change-op5-web-interface-directory-916580/)

ScorchPipe 12-01-2011 11:05 AM

Change Op5 web interface directory
 
Hi

I installed Op5 Beta (free) on my CentOS-machine yesterday. This machine is the only one it will monitor for the time being (stupid I know but Im doing it just for fun)


After the installation was done I couldnt reach my regular website running on this server anymore. I figured it might have something to do with Op5s default webpage so I moved everything placed in /var/www/html by the Op5 installation to a subdirectory.
Still nothing.

I can't find anyone having this issue and Op5s support is only open to paying customers.

What I reallt want to do is to reach the Op5 web interface by entering mywebsite.com/op5. But now I cant even reach the usual one.

Any ideas how to fix this?

hvulin 12-01-2011 11:32 AM

You probably just broke your apache configuration. I don't use centos but I think it shouldn't matter. My debian apache2 has it's config in: /etc/apache2/ directory. Look under sites-enabled/ directory for what is enabled (debian default has 000-default file) or if it doesn't exist look directly in /etc/apache2/httpd.conf or /etc/apache2/apache2.conf.
Line you are looking for is DocumentRoot /var/www (or probably something else now) - it points to web root directory under which you should put your web site. Op5 probably changed this to its own directory so your original website is note showing any more.

If your op5 website is under /usr/op5/www (I don't know the real directory) you could just link it to the real directory (without copying):
ln -s /usr/op5/www /var/www/op5

ScorchPipe 12-01-2011 11:41 AM

Quote:

Originally Posted by hvulin (Post 4539295)
You probably just broke your apache configuration. I don't use centos but I think it shouldn't matter. My debian apache2 has it's config in: /etc/apache2/ directory. Look under sites-enabled/ directory for what is enabled (debian default has 000-default file) or if it doesn't exist look directly in /etc/apache2/httpd.conf or /etc/apache2/apache2.conf.
Line you are looking for is DocumentRoot /var/www (or probably something else now) - it points to web root directory under which you should put your web site. Op5 probably changed this to its own directory so your original website is note showing any more.

If your op5 website is under /usr/op5/www (I don't know the real directory) you could just link it to the real directory (without copying):
ln -s /usr/op5/www /var/www/op5

That doesn't seem to be the problem. Documentroot in httpd.conf is /var/www/html just as it should be.
The problem is that neither of them is working. Not op5s site and not mine

ScorchPipe 12-01-2011 02:09 PM

Ok I'm on to something here


If I remove all of Op5s conf-files in /etc/httpd/conf.d my own website starts working again. If I then enter the Op5 subdirectory (mywebsite.com/op5) I get the Op5 front page.

However I cant get anywhere from that point. If I click on the "Monitor"-button which usually leads to the login-page, I get 404 and so on. So I figured all the paths must be wrong now since I moved all the op5 items to a subdirectory.

So I restored the conf-files that was in /etc/httpd/conf.d and edited all of the paths in them to match the new path. When I restarted httpd though, nothing worked (same as before)

Also tried editing the Op5 index.php without any success


All times are GMT -5. The time now is 01:22 PM.