LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-24-2004, 07:07 PM   #1
sordomudo11
LQ Newbie
 
Registered: Feb 2004
Posts: 13

Rep: Reputation: 0
Certain fonts too large on Mandrake 10


Hey all,

I just scrapped my Mandrake 9.2 and 2.4 kernel for the new 10.0 Community w/ the 2.6 kernel and KDE 3.2. My pain right now is fonts. I'm running at 1920x1200 resolution on my Dell Inspiron 8600. I've spent a good deal of time tweaking my XF86Config-4 to be where it is right now, and for some reason the fonts are just huge. So I went into KDE and was sure to reduce every possible font, including "all fonts" down to something small (6). That fixed the problem in many places, including the start menu and taskbar. But, many, many applications still have plain HUGE fonts in the File,Edit,etc. dropdown menus and other places. Firefox, GAIM, and Thunderird, for example, are huge. I went to the Font settings for each of those apps and set them as small as I could but w/ no luck.

Do I maybe need to add some lines to my XF86Config-4 that point to where the fonts are on my machine? I've seen that before. Any other reason why certain fonts would just be gigantic? I'll attach my XF86Config below in case anyone has any ideas or sees other flaws in it. I installed the nVidia driver using the kernel source and nVidia installer, so that's what everything is set to.

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
#Load "GLcore"
#Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Modes"
# 1920x1200 @ 75.00 Hz (GTF) hsync: 93.97 kHz; pclk: 246.59 MHz
Modeline "1920x1200" 246.59 1920 2064 2272 2624 1200 1201 1204 1253 +hsync +vsync

# 1920x1200 @ 85.00 Hz (GTF) hsync: 107.10 kHz; pclk: 282.74 MHz
Modeline "1920x1200" 282.74 1920 2072 2280 2640 1200 1201 1204 1260 +hsync +vsync

# 1920x1200 @ 100.00 Hz (GTF) hsync: 127.10 kHz; pclk: 337.58 MHz
Modeline "1920x1200" 337.58 1920 2072 2288 2656 1200 1201 1204 1271 +hsync +vsync
Modeline "1280x800" 107.21 1280 1360 1496 1712 800 801 804 835
Modeline "1280x800" 123.38 1280 1368 1504 1728 800 801 804 840
Modeline "1280x800" 147.89 1280 1376 1512 1744 800 801 804 848
Modeline "1680x1050" 147.14 1680 174 1968 2256 1050 1051 1054 1087
Modeline "1680x1050" 188.07 1680 1800 1984 2288 1050 1051 1054 1096
Modeline "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054 1103
Modeline "1680x1050" 256.20 1680 1800 1992 2304 1050 1051 1054 1112
Identifier "16:10"
EndSection

Section "Monitor"
Identifier "monitor1"
HorizSync 31.5 -100.0
VertRefresh 30.0 - 90.0
EndSection

Section "Device"
Identifier "device1"
VendorName "nvidia"
BoardName "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VideoRam 65536
EndSection

Section "Device"
Identifier "device2"
Driver "nv"
EndSection

Section "Device"
Identifier "device0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1900 1200
EndSubsection

Subsection "Display"
Depth 15
Virtual 1900 1200
EndSubsection

Subsection "Display"
Depth 16
Virtual 1900 1200
EndSubsection

Subsection "Display"
Depth 24
Virtual 1900 1200
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection


Thanks!!
 
Old 03-24-2004, 07:36 PM   #2
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
Have you tried setting the DPI through KDE? I'm not sure if you can do it in KDE, but you can in GNOME so I'm thinking it's possible in KDE as well.

Also, The message saying that Mandrake is using another font server might mean trouble. Use something like this instead.

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/truetype/"
# FontPath "/usr/X11R6/lib/X11/fonts/freefont/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/corefonts"
EndSection

If none of those ideas fix the problem, I'm still here.
 
Old 03-24-2004, 10:15 PM   #3
sordomudo11
LQ Newbie
 
Registered: Feb 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Fonts too big still

K, you said you were still there... I tried putting that section into XF86Config-4, commenting out those lines of directories I don't have. No luck. I've noticed that in KDE-native apps, the fonts are fine per the changes I made in KDE settings. But in all other programs (GAIM, Firefox, etc) everything's still HUGE.
 
Old 03-25-2004, 06:18 AM   #4
matze
Member
 
Registered: Oct 2003
Posts: 50

Rep: Reputation: 15
Have you tried setting the fonts for the GNOME-apps via the gnome-control-center and letting the gnome-settings-daemon running in the background in kde? The progs you named are gtk2 apps and I got the same problem until I configured the fonts in GNOME and started the gnome-settings-daemon in my favorite window-manager.

Cheers,
matze
 
Old 03-25-2004, 08:38 AM   #5
sordomudo11
LQ Newbie
 
Registered: Feb 2004
Posts: 13

Original Poster
Rep: Reputation: 0
Got it

K, I think I pretty much got it. I looked around and found an old post/reply about a similar problem. I appended "-dpi 75" to the end of the firs line (:0 local /usr/X11R6/bin/X) in my /etc/X11/xdsm/Xservers file, and all of a sudden things seemed pretty normal. Where I had set the fonts to 6, they were extremely small as they should be, and other fonts were normal size. So I resized the size 6 fonts to a more normal 12 and all seems pretty good.

One last question, though. What's a normal dpi setting? I picked 75 b/c it appeared to be somewhat standard. I have a 15.4" UXGA Dell screen running at 1900x1200 pixels and color depth 24. Is 75 pretty normal or would a higher number be more standard? Thanks...
 
Old 03-28-2004, 08:40 AM   #6
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHAS, Kubuntu, Solaris, TRU64
Posts: 381

Rep: Reputation: 31
YES. It did worked for me too.

As sordomudo11 suggested, I appended "-dpi 96" to the end of the first line (:0 local /usr/X11R6/bin/X) in my /etc/X11/xdm/Xservers file (it was running at 75 dpi and that made my fonts extremely small --> the opposite case) and now fonts are OK.

Last edited by pablob; 04-05-2004 at 07:18 AM.
 
Old 04-08-2004, 03:43 AM   #7
Lomaxfairchild
LQ Newbie
 
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
I'm suffering from the same problem - the line in my /etc/X11/xdm/Xservers is

:0 local /usr/X11R6/bin/X -deferglyphs 16

where would I put the '-dpi75' ? I've tried it at the end and it makes no difference

(using Mandrake 10 KDE 3.2)
 
Old 04-08-2004, 04:36 AM   #8
Lomaxfairchild
LQ Newbie
 
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
ok - I've sorted it. I removed the line from '-' onwards and replaced it wiith the - dpi75

Cheers for the advice. My font resolution had changed 'overnight' - I just switched on the computer and all my fonts had gone massive. Very odd - the last bit of software I installed was GIMP 2 - maybe that had something to do with it.
 
Old 04-08-2004, 05:54 AM   #9
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHAS, Kubuntu, Solaris, TRU64
Posts: 381

Rep: Reputation: 31
Once you change the X -dpi line, you have to reset your fonts to normal sizes (10-11).
My line ( /etc/X11/xdm/Xservers) is:

:0 local /usr/X11R6/bin/X -deferglyphs 16 -dpi 96
 
Old 04-14-2004, 04:24 PM   #10
LSA
Member
 
Registered: Dec 2003
Distribution: Slackware 10
Posts: 45

Rep: Reputation: 15
Quote:
Originally posted by pablob
Once you change the X -dpi line, you have to reset your fonts to normal sizes (10-11).
My line ( /etc/X11/xdm/Xservers) is:

:0 local /usr/X11R6/bin/X -deferglyphs 16 -dpi 96
What do you put if you aren't using xdm? I'm just typing in startx, I tried adding that and it didn't work.

I've been trying to solve this problem for a long time now.

Slackware 9.1
 
Old 04-15-2004, 03:02 AM   #11
Lomaxfairchild
LQ Newbie
 
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
LSA

try 'startx -- -dpi 75'
 
Old 04-15-2004, 07:36 AM   #12
LSA
Member
 
Registered: Dec 2003
Distribution: Slackware 10
Posts: 45

Rep: Reputation: 15
I'll try that when I get home.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fluxbox fonts too large big ahh_dee Ubuntu 2 10-27-2005 10:50 AM
Firefox fonts very large Eerath Linux - Software 2 09-03-2005 08:41 AM
Certain fonts too large on Mandrake 10 sordomudo11 Linux - Laptop and Netbook 2 12-05-2004 04:31 PM
Certain fonts too large on Mandrake 10 sordomudo11 Linux - General 3 03-24-2004 07:27 PM
RH 7.1 Print large fonts Iknowit101 Linux - Distributions 2 09-29-2001 10:58 AM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration