LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-25-2004, 10:37 PM   #1
jeffkjo
LQ Newbie
 
Registered: Jul 2003
Distribution: Suse 8.2
Posts: 17

Rep: Reputation: 0
Question cdrecord as user


Hello, I've been attempting to burn a CD as user for the past 4 hours and I just cant get it to work at all. I've used both k3b and xcdroast, but both spit out the same cdrecord error:

TOC Type: 1 = CD-ROM
/usr/bin/cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
/usr/bin/cdrecord: No such file or directory. Cannot open SCSI driver.
/usr/bin/cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
/usr/bin/cdrecord: For possible transport specifiers try 'cdrecord dev=help'.


CD burning DOES work if I am root, and I've used k3bsetup to change my cdrecord permissions (I also temporarily chmoded cdrecord as 7777, although I still got the same error.)

I've burned as user before, although not in this current install of SuSE 9.
I have a burning group (which my login is linked to), and it is associated with cdrecord, cdrdao, and readcd.



What am I still missing?

Jeff
 
Old 02-26-2004, 02:23 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Check the permissions on the device(s),
presumably
ls -l /dev/scd0
and
ls -l /dev/sg0


Cheers,
Tink
 
Old 02-26-2004, 11:57 AM   #3
jeffkjo
LQ Newbie
 
Registered: Jul 2003
Distribution: Suse 8.2
Posts: 17

Original Poster
Rep: Reputation: 0
The permissions are listed below:

scd0
brw-rw-rw- 1 root disk 11, 0 2003-09-23 17:59 /dev/scd0

sg0
crw-rw-rw- 1 root disk 21, 0 2003-09-23 17:59 /dev/sg0
 
Old 02-26-2004, 12:54 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
do a
chmod a+x /dev/sg0
and try again ...


Cheers,
Tink
 
Old 02-26-2004, 02:16 PM   #5
jeffkjo
LQ Newbie
 
Registered: Jul 2003
Distribution: Suse 8.2
Posts: 17

Original Poster
Rep: Reputation: 0
arrr.

I did it, and I still get the same error:

/usr/bin/cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
/usr/bin/cdrecord: No such file or directory. Cannot open SCSI driver.
/usr/bin/cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
/usr/bin/cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
 
Old 02-26-2004, 05:00 PM   #6
aigartua
Member
 
Registered: Dec 2002
Location: Xalapa, Ver. México
Distribution: Red Hat
Posts: 108

Rep: Reputation: 15
try this like root:

chmod +s /usr/bin/cdrecord

after this try to burn you cd as normal user
 
Old 02-26-2004, 06:23 PM   #7
jeffkjo
LQ Newbie
 
Registered: Jul 2003
Distribution: Suse 8.2
Posts: 17

Original Poster
Rep: Reputation: 0
^Tried it, still getting the same very annoying error.

/usr/bin/cdrecord: Warning: not running as root user, fs= option ignored.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
/usr/bin/cdrecord: No such file or directory. Cannot open SCSI driver.
/usr/bin/cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
/usr/bin/cdrecord: For possible transport specifiers try 'cdrecord dev=help'.


Are there any other files that are used that could have the wrong privileges specified one way or another?
 
Old 02-27-2004, 03:46 PM   #8
jeffkjo
LQ Newbie
 
Registered: Jul 2003
Distribution: Suse 8.2
Posts: 17

Original Poster
Rep: Reputation: 0
To serve everyone

Well, I figured it out, and so that no one else ever has to endure this, here is the solution.

1. This ONLY happens in SuSE 9, and hopefully this will be the only distro it ever happens in.

Ok, here goes.

SuSE's goofy version of cdrecord requires something called 'resmgr' to be running for regular users in order to burn cd's as a non-root user. However, resmgr is not setup this way by default! On top of this, there is no documentation that explains this!

So... heres how to fix it.

One:

Open a terminal window su to root
Type:

resmgr login <username> :0

Use the login you wish to burn cds on, as your already root.

CD's should burn!

Of course, now you want this to run all the time.
This information is stored in the pam damon.

Navigate to
/etc/pam.d and open 'login'
Add the line
'session optional pam_resmgr.so grant=desktop '

This will load the resmgr correctly.

If you have a 'kde' file in the pam directory, add the line to it as well.


But, there is a better way.

Go to www.rpmseek.com and find a different rpm version of cdrecord. I simply installed a redhat 9 version of cdrecord.

This removes all of suses goofy proprietary code from cdrecord and allows it to work the way it should!

If you want to compile cdrecord yourself, you can do this as well, although compiling cdrecord is not exactly fun.


Goodluck!
 
Old 02-28-2004, 03:09 AM   #9
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
I was just thinking about this when I saw this thread. I'm also using SuSE 9 and couldn't understand why I needed to be root to burn...but I solved it by doing "sudo gcombust"
 
Old 03-26-2004, 12:31 PM   #10
infodoc
LQ Newbie
 
Registered: Nov 2003
Location: Chapel Hill, NC
Distribution: Libranet 2.8.1
Posts: 4

Rep: Reputation: 0
I had similar problem using Libranet 2.8.1; k3b 0.10.3

knew it had to be a permissions problem, as root could run k3b without problem.

i set up a group burning that includes me, and set cdrecord group to burning. that is pretty standard. also made cdrecord executable by group, also pretty standard.

but, it still wasn't working for me.

here is the catch, I think .... cdrecord is a shell script. i made it readable by group as well (in addition to executable). don't know if my reasoning was correct, but all is now working perfectly as regular user.

Regards,

RDC
 
Old 03-26-2004, 12:35 PM   #11
shanenin
Member
 
Registered: Aug 2003
Location: Rochester, MN, U.S.A
Distribution: Gentoo
Posts: 987

Rep: Reputation: 30
have run k3bsetup ? That should change the needed settings so you can run as regular user.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrecord works for root, but not non-priviledged user mpdegroat Linux - Software 3 05-24-2004 12:15 PM
CDrecord rund for root, not other user(s) ewto Linux - General 3 01-12-2004 07:20 AM
cdrecord help shanenin Linux - Software 1 11-23-2003 09:51 PM
cdrecord for normal user? GT_Onizuka Linux - Newbie 1 09-11-2003 01:03 AM
Help with cdrecord dddttt Linux - Software 4 06-19-2003 11:17 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration