LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-22-2003, 02:41 PM   #1
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Rep: Reputation: 0
Angry CD installs but will not play


I have installed Caldera Linus 2.4 on an intel 586 motherboard with a CD. The sound board works fine though the controls and the CD installs with OS fine. But you cannot use the CD from the Desktop or play a CD.

Does anyone know how to fix this link problem?
 
Old 03-22-2003, 03:09 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
Insert a data cd to your cd drive, open a terminal and type
mount /mnt/cdrom
The CD content should be in /mnt/cdrom. To be able to remove the cd use
umount /mnt/cdrom

Test if it works (I've never used Caldera, so it may be done differently than I think it should).
 
Old 03-23-2003, 07:45 AM   #3
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you for the reply.

mount /mnt/cdrom does not work.


Strangely, the CDROM does appear to be "reading" as the light comes on regularly and the player is moving forward in time but there is not sound.

The CD-rom icon on the desktop does not work, however.
 
Old 03-23-2003, 08:42 AM   #4
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Original Poster
Rep: Reputation: 0
It is a strange bug.

With headphones and the CD player you can hear a CD; however, it will not play through the system.

This is despite the fact that the link to the CD or the floppy on the desktop do not work nor does the "mount /mnt/cdrom" command at a terminal or an "init 1" command

The sound tests work fine.
 
Old 03-23-2003, 08:45 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
i very much doubt it is a "bug" in the slightest. do you have an entry in /etc/fstab set up correctly ? does /mnt/cdrom exist? have you tried mounting it with the /dev/hdX entry directly?
 
Old 03-23-2003, 09:19 AM   #6
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Original Poster
Rep: Reputation: 0
No the mnt/cdrom does not exist, but auto-sh will load cds and the CD player plays, but only through the headphones.

How do I mount directly from the terminal with a

"/dev/hdX entry directly" ???

Last edited by RICronkhite; 03-23-2003 at 09:40 AM.
 
Old 03-23-2003, 09:41 AM   #7
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Original Poster
Rep: Reputation: 0
How can I check the /etc/fstab file?

No the mnt/cdrom does not exist, but auto-sh will load cds and the CD player plays, but only through the headphones.

How do I mount directly from the terminal with a

"/dev/hdX entry directly" ???
 
Old 03-23-2003, 10:03 AM   #8
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Original Poster
Rep: Reputation: 0
I have been able to get the CD to play. I simply rebooted after placing an autorun in the tray. I have tried that in the past and it did not work.

It is a quirky OS on my 586, probably due to a slow drive speed.

Thanks.

Last edited by RICronkhite; 03-24-2003 at 06:34 AM.
 
Old 03-23-2003, 10:09 AM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,570

Rep: Reputation: 171Reputation: 171
Do you know if your cdrom is primary master/primary slave etc? If you don't, enter your BIOS and see (first or second option in most BIOSes). In most systems, cdrom is secondary master (hdc). If that's true in your system, insert a data cd in your cd drive and run:
mkdir /mnt/cdrom <- to create /mnt/cdrom directory
mount -t iso9660 /dev/hdc /mnt/cdrom <- to mount cd

/etc/fstab is a normal text file. Look into it and see if there's your cdrom device mentioned (in my example: hdc). If not, you need to add an entry:
/dev/hdc /mnt/cdrom iso9660 defaults 0 0
(just a new line at the end of the file). Then
'mount /dev/hdc' should work (not only 'mount -t iso9660 /dev/hdc /mnt/cdrom').
 
Old 03-23-2003, 05:22 PM   #10
RonRussell
Member
 
Registered: May 2001
Location: Pangaea
Distribution: SimplyMepis2004
Posts: 78

Rep: Reputation: 15
Lightbulb

Make sure that the volume on the sound mixer is turned up for the CD. This is a separate control from the CD player. I had exactly the same experience as you, the light on the CD drive would come on, the CD player display on the desktop would show which track was playing and how far along it was, but no sound. Turning up the volume on the sound mixer fixed everything.

Ron
 
Old 03-23-2003, 08:26 PM   #11
RICronkhite
LQ Newbie
 
Registered: Mar 2003
Location: Eastern U.S.
Posts: 8

Original Poster
Rep: Reputation: 0
I did look at BIOS earlier. It only offers A and C, not the CD.


Somehow I have fixed the problem. I enabled autoplay and I rebooted the system and all of a sudden it worked.


This was the only quirk I had with installation. I must recommend CALDERA! It was almost an uneventful installation of a complex system with a Lizard process that took a total of about 4 hours.

The modem is configuring perfectly, etc.

The CD glitch was somewhat disturbing, but I've seen worse with Windows ME.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kaffeine, won't play a DVD but will play individual VOB files? GameGuru Linux - Newbie 12 07-08-2005 12:33 AM
Is this ok with dpkg installs? acker Debian 7 12-10-2004 04:55 PM
installs jon_206 Linux - Newbie 5 09-06-2004 07:47 PM
nothing installs SBarretDolph Mandriva 0 01-23-2004 02:04 AM
Where do the installs go???????? VoyagerDL Linux - Newbie 7 03-20-2003 01:25 PM


All times are GMT -5. The time now is 03:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration