LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-29-2004, 05:49 PM   #1
Zhenya
Member
 
Registered: Sep 2004
Location: Maryland, USA
Distribution: Suse 9.3 Pro
Posts: 92

Rep: Reputation: 15
CD autoplay in Suse 9.1


Does anyone know how to disable (change) autoplay feature in Suse 9.1? Every time I insert a disc in CD-ROM drive, Suse launches Konqueror and opens the disc. How do I stop this annoying (although sometimes useful) behavior?
 
Old 01-22-2005, 06:06 PM   #2
Big Money
LQ Newbie
 
Registered: Apr 2004
Distribution: Suse 9.2
Posts: 10

Rep: Reputation: 0
Angry Turning off autoplay in 9.2

Same problem, but in Suse 9.2. No, this isn't in KDE's Control Center. No, this isn't in Yast. And no, kscd is not installed.
 
Old 01-22-2005, 07:09 PM   #3
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
If you open up konqueror as root user and select View / Show Hidden Files..
Then go to /home/Username/.kde/Autostart

## Note: just move this file until you know if you can live without it.
Move the Autorun.desktop to another location like /home

If you don't want kscd to autorun, there is an option for that under kscd
Extras / Configure KsCD ....
or you can go directly to that users /home/Username/.kde/share/config/kscdrc
AUTOPLAY=false

## Note: I haven't tried this myself yet.
If that doesn't help, you may have success by moving the /usr/bin/autorun to another location.
 
Old 01-23-2005, 10:53 AM   #4
Zhenya
Member
 
Registered: Sep 2004
Location: Maryland, USA
Distribution: Suse 9.3 Pro
Posts: 92

Original Poster
Rep: Reputation: 15
I found that Suse has a Hardware Tool to configure this. Just right-click on the Hardware Tool icon (the one in the kicker) and choose 'configure', and you will see all the autorun options.

By the way, my $HOME/.kde/Autostart directory has (and had) no Autorun.desktop files.
 
Old 01-24-2005, 08:53 PM   #5
Big Money
LQ Newbie
 
Registered: Apr 2004
Distribution: Suse 9.2
Posts: 10

Rep: Reputation: 0
Old School Method

*smacks self* Good call with the kicker! I don't usually have the system tray turned on, so I didn't even think of that. Unfortunately for me, I didn't read your post before I found the actual config files. For Suse users, they're in /opt/kde3/share/config... I think... I actually don't remember, but the files in there look like they were the ones. (I used to use Mandrake, but for my experiences with that, you can search for my other posts... :)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome won't autoplay DVD. What gives? cheesekeeper Linux - Software 2 05-31-2005 11:50 AM
to play midi and autoplay on cd in Nau Mandriva 2 04-23-2005 06:49 AM
stop cd autoplay apocolpse Linux - Newbie 3 02-04-2005 05:36 PM
How to turn off Autoplay at bootup? jeffman12 Fedora 1 06-21-2004 07:59 PM
Autoplay for DVD Mojojo Linux - Software 0 05-31-2004 04:12 PM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration