LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   CD autoplay in Suse 9.1 (http://www.linuxquestions.org/questions/linux-software-2/cd-autoplay-in-suse-9-1-a-236813/)

Zhenya 09-29-2004 04:49 PM

CD autoplay in Suse 9.1
 
Does anyone know how to disable (change) autoplay feature in Suse 9.1? Every time I insert a disc in CD-ROM drive, Suse launches Konqueror and opens the disc. How do I stop this annoying (although sometimes useful) behavior?

Big Money 01-22-2005 05:06 PM

Turning off autoplay in 9.2
 
Same problem, but in Suse 9.2. No, this isn't in KDE's Control Center. No, this isn't in Yast. And no, kscd is not installed.

homey 01-22-2005 06:09 PM

If you open up konqueror as root user and select View / Show Hidden Files..
Then go to /home/Username/.kde/Autostart

## Note: just move this file until you know if you can live without it.
Move the Autorun.desktop to another location like /home

If you don't want kscd to autorun, there is an option for that under kscd
Extras / Configure KsCD ....
or you can go directly to that users /home/Username/.kde/share/config/kscdrc
AUTOPLAY=false

## Note: I haven't tried this myself yet.
If that doesn't help, you may have success by moving the /usr/bin/autorun to another location.

Zhenya 01-23-2005 09:53 AM

I found that Suse has a Hardware Tool to configure this. Just right-click on the Hardware Tool icon (the one in the kicker) and choose 'configure', and you will see all the autorun options.

By the way, my $HOME/.kde/Autostart directory has (and had) no Autorun.desktop files.

Big Money 01-24-2005 07:53 PM

Old School Method
 
*smacks self* Good call with the kicker! I don't usually have the system tray turned on, so I didn't even think of that. Unfortunately for me, I didn't read your post before I found the actual config files. For Suse users, they're in /opt/kde3/share/config... I think... I actually don't remember, but the files in there look like they were the ones. (I used to use Mandrake, but for my experiences with that, you can search for my other posts... :)


All times are GMT -5. The time now is 05:15 PM.