LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-27-2002, 11:59 AM   #1
sfingerh
LQ Newbie
 
Registered: Jul 2002
Location: CHILE
Distribution: Red Hat 8.0
Posts: 8

Rep: Reputation: 0
cc/gcc not installed...and how to install


Hi,
Like I message ffew days ago, I can't use ./configure.

checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable cc found in $PATH

I checked if gcc or cc is installed and it sin't.
I downloaded and tried rpm -i gcc-2.96-110.i386.rpm but I got the message

error: failed dependencies:
binutils >= 2.11.93.0.2-6 is needed by gcc-2.96-110
cpp = 2.96-110 is needed by gcc-2.96-110
glibc-devel is needed by gcc-2.96-110

I don't know how to get through

Thanks

Seba
 
Old 07-27-2002, 12:20 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Gcc depends on different packages. You need to install them first. They're listed in your errir message:
binutils, gcc-cpp and glibc-devel
They're on your installation cd. Install them in the same way you tried with gcc. It's possible that you can get similar error messages. Don't worry, find the packages missing and install them, too. They're all on your install cd.
 
Old 07-27-2002, 12:26 PM   #3
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
that's what it says you need binutils version 2.11.93.0.2-6 or later, you need also cpp version 2.96-110 and glibc-devel, now go to http://www.rpmfind.net and get the dependencies, note it is not guaranteed that you will not face even more dependencies failures. A side note: don't get 2.96 version of gcc - it is buggy to say the least - you can go for gcc-3.x.x, and I would suggest getting older version 2.95 or 2.91. You would also need gcc-common, gcc-libs, glibc, glibc-devel, libstdc++, and some more. Be patient, and try to get everything you need in source RPM's (package-version.release.src.rpm)
 
Old 07-27-2002, 06:56 PM   #4
rverlander
Member
 
Registered: May 2002
Distribution: A few
Posts: 488

Rep: Reputation: 30
DO NOT USE GCC 2.96 IT IS VERY BUGGY AND DOES NOT COMPILE ANYTHING RIGHT
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get GCC installed Skaan Linux - Newbie 2 05-26-2005 10:21 AM
Installed GCC, but not working rangalo Linux - Software 2 02-02-2005 01:21 PM
gcc wont install, 'failed dependencies: glibc-devel is needed by gcc-3.3.3-41' TdlSnare Suse/Novell 3 11-29-2004 02:13 PM
What gcc do I have installed? Thaidog Linux - Newbie 2 09-27-2004 08:11 PM
cannot use gcc even though it's installed. levicc00123 Debian 2 09-07-2004 08:48 PM


All times are GMT -5. The time now is 07:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration