LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Cat on the keyboard - now keyboard is dead (http://www.linuxquestions.org/questions/linux-software-2/cat-on-the-keyboard-now-keyboard-is-dead-637657/)

pwabrahams 04-24-2008 09:04 PM

Cat on the keyboard - now keyboard is dead
 
Earlier today I installed the new Kubuntu H on my laptop and had it working (except for wireless). In particular, I had no trouble typing anything in.

Then I left the room for a few minutes and returned to find my cat sitting on the keyboard. I recovered the system as best I could, but the keyboard was dead -- but only in Kubuntu. It works fine in Windows and also when I boot up in choosing the boot kernel. But in Kubuntu, when I type anything in, say, a console, it isn't echoed and produces no visible response. I've tried powering down and powering up again, but that is of no help.

So what might have happened? And how can I get my keyboard back?

bigrigdriver 04-24-2008 11:44 PM

Some combination of key presses caused the problem. I've seen odd aftereffects as the result of cats strolling across the keyboard before. In this case, it seems that the keyboard is effectively turn off.

If you are using KDE, try deleting your home .kde folder. If you are using gnome, then delete .gnome and .gnome2. That may get rid of the trapped condition.

If not, you may have to re-install (re-format to be certain the trapped condition doesn't survive the re-install).

If you were logged in as root then delete the named files from /root; is logged in as user, then delete from users home folder.

jailbait 04-24-2008 11:46 PM

You could try this: Start the control center (kcontrol). Click on Peripherials -> Keyboard -> Defaults -> Apply.

If that doesn't work try control center -> Regional & Accessibility -> Keyboard Layout -> Defaults -> Apply.

If that doesn't work try control center -> Regional & Accessibility -> Keyboard Shortcuts -> Defaults -> Apply.

Those three default settings should put your keyboard setup back to the way it was when KDE was installed.

---------------------
Steve Stites

P.S. Deleting /home/user/.kde like bigrigdriver says should have the same effect except that it will put all of your KDE settings back to the default, not just the keyboard settings.

bigrigdriver 04-25-2008 12:15 AM

Oops! My bad. The most obvious solutions were hidded in plain sight, and I missed them.

jailbait 04-25-2008 12:19 AM

Quote:

Originally Posted by bigrigdriver (Post 3132211)
Oops! My bad. The most obvious solutions were hidded in plain sight, and I missed them.

I didn't think of your solution as being bad, I was thinking in terms of "and if none of those three ideas work then hit it with bigrigdriver's hammer"

--------------
Steve Stites

brianL 04-25-2008 04:13 AM

Somebody else with a similar problem:

http://icanhascheezburger.files.word...del-kitten.jpg

I can only suggest either buying your cat its own laptop, or at least teaching it to type.
:)

elliott678 04-25-2008 04:19 AM

Is there a Linux equivalent to this yet?
http://www.bitboost.com/pawsense/

pwabrahams 04-25-2008 08:25 AM

Quote:

Originally Posted by elliott678 (Post 3132357)
Is there a Linux equivalent to this yet?
http://www.bitboost.com/pawsense/

If there isn't, there ought to be. I expect that Linuxers tend to be ailurophiles and my problem isn't all that rare.

pwabrahams 04-25-2008 08:38 AM

Quote:

Originally Posted by jailbait (Post 3132194)
You could try this: Start the control center (kcontrol). Click on Peripherials -> Keyboard -> Defaults -> Apply.

If that doesn't work try control center -> Regional & Accessibility -> Keyboard Layout -> Defaults -> Apply.

If that doesn't work try control center -> Regional & Accessibility -> Keyboard Shortcuts -> Defaults -> Apply.

Unfortunately I didn't have an icon for kcontrol that I could click on. But from the K menu I got to System Settings and then explored the Accessibility settings. Turned out that something called Use Slow Keys was turned on. I turned it off and the problem was solved.

My kitty may think it's disabled, but it certainly isn't.


All times are GMT -5. The time now is 08:18 PM.