LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-16-2003, 06:09 PM   #1
maxor
LQ Newbie
 
Registered: Aug 2003
Location: Arizona, Usa
Distribution: Slackware 9.0
Posts: 2

Rep: Reputation: 0
Question Capturing packets in ethereal as non-root user?


I have installed ethereal on my slackware machine. If I login as root and issue this command

Code:
# ethereal
The graphical ethereal is launched and I can capture packets and everything works fine. Since I don't want to always be logged in as root I have another account.

When I log in as a normal user and try to issue the same

Code:
# ethereal
command I get the graphical ethereal but I am unable to capture packets. I get an error message that says either I didn't not specify the correct interface or I don't have permission to capture packets.

I specify eth0 as the interface when using the program as root, and it works. If I specify eth0 as a non-root user it does not work.

I have tried to su to root and then run the program, but ethereal won't even launch. If I

Code:
# sudo ethereal
I get an error, after entering my password, that I (the user I am logged in as) is not in the sudoers file. Then I get another shell prompt and the program never starts.

Is there a way to change the permissions of some ethereal file so that I can use the program as a non-root user? Or do I have to add myself to the sudoers file and always use the sudo command?

Thanks in advance.

-Clayton

Oh BTW...
 
Old 08-16-2003, 07:19 PM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
don't know why su'ing into root won't run ethereal. it's working here for me. AFIK, ethereal will only run in root. if you want, you could try setting the setuid bit in the permissions on the ethereal executable.
 
Old 08-16-2003, 08:56 PM   #3
maxor
LQ Newbie
 
Registered: Aug 2003
Location: Arizona, Usa
Distribution: Slackware 9.0
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by megaspaz
don't know why su'ing into root won't run ethereal. it's working here for me. AFIK, ethereal will only run in root. if you want, you could try setting the setuid bit in the permissions on the ethereal executable.
When I try and run ethereal after 'su root' it gives me the same error as when you type say "the98wsjalkjf9shdsshakhs" (i.e. not a real command) into the command line. Something like "ethereal command not found). I'll try when I get home tonight.

Thanks.
 
Old 08-27-2003, 08:26 AM   #4
[ARM]Dante
LQ Newbie
 
Registered: Aug 2003
Location: NY
Distribution: RH8
Posts: 1

Rep: Reputation: 0
I have the same problem myself. I thought I'd be able to find /dev/eth0 but I was wrong. I know the idea is to give my non root user access to read eth0 but I cannot find eth0 itself just config files. Does anyone know where I can find eth0 if possible?
 
Old 08-27-2003, 02:10 PM   #5
deepsix
Member
 
Registered: Apr 2003
Distribution: ANY
Posts: 336

Rep: Reputation: 31
Quote:
Originally posted by [ARM]Dante
I have the same problem myself. I thought I'd be able to find /dev/eth0 but I was wrong. I know the idea is to give my non root user access to read eth0 but I cannot find eth0 itself just config files. Does anyone know where I can find eth0 if possible?

In order to do what I think you want to do you will have to add non-priveleged user umpitysquat to the group network....wich I HIGHLY RECOMMEND YOU NOT DO! .......big security no-no.....
 
Old 08-27-2003, 02:19 PM   #6
deepsix
Member
 
Registered: Apr 2003
Distribution: ANY
Posts: 336

Rep: Reputation: 31
Quote:
Originally posted by [ARM]Dante
I have the same problem myself. I thought I'd be able to find /dev/eth0 but I was wrong. I know the idea is to give my non root user access to read eth0 but I cannot find eth0 itself just config files. Does anyone know where I can find eth0 if possible?

In order to do what I think you want to do you will have to add non-priveleged user umpitysquat to the group network....wich I HIGHLY RECOMMEND YOU NOT DO! .......big security no-no.....

do what megaspaz said....if you want to play with permissions....
 
Old 08-27-2003, 03:05 PM   #7
Khabi
Member
 
Registered: Aug 2003
Location: Arizona
Distribution: Gentoo
Posts: 142

Rep: Reputation: 15
Quote:
Originally posted by maxor
When I try and run ethereal after 'su root' it gives me the same error as when you type say "the98wsjalkjf9shdsshakhs" (i.e. not a real command) into the command line. Something like "ethereal command not found). I'll try when I get home tonight.

Thanks.
I would say try doing "su root" then running the full path to ethereal. See if that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Capturing packets from my WAN/Router {O_o} Linux - Security 4 10-12-2005 04:56 PM
What is the best way to view data captured in packets with Ethereal? abefroman Linux - Security 4 05-07-2005 01:30 PM
VoIP Packets capturing in linux fastian Linux - Networking 1 03-25-2005 11:34 AM
Test the performance and functionality of packets on ethereal Jyo Linux - Networking 0 09-21-2004 12:56 AM
capturing ethernet packets shrike_912 Programming 5 08-02-2004 01:46 PM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration