LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't update dbus-qt on Fedora Core 4 (http://www.linuxquestions.org/questions/linux-software-2/cant-update-dbus-qt-on-fedora-core-4-a-382819/)

tron_thomas 11-13-2005 05:28 PM

Can't update dbus-qt on Fedora Core 4
 
I am running Fedora Core 4 (32-bit Intel). I am trying to update my system using the YUM Extender. When I run YUM Extender I have the option to update a package named dbus-qt. When I select the package for update I get the following error:

Missing Dependency: dbug-qt = 0.33-3.1.fc4.kde is needed by package dbug-devel

Check output page for more info.

The output page provides:

Installed: kernel.i686 0:2.6.14-1.1637_FC4 kernel-devel.i686 0:2.6.14-1.1637_FC4
Dependency Installed: dhcdbd.i386 0:1.9-1.FC4
Updated: NetworkManager.i386 0:0.5.1-1.FC4.4 NetworkManager-gnome.i386 0:0.5.1-1.FC4.4 SDL_mixer.i386 0:1.2.6-2.fc4 audit.i386 0:1.0.12-2.fc4 audit-libs.i386 0:1.0.12-2.fc4 chkconfig.i386 0:1.3.23-0.4 freeciv.i386 0:2.0.7-2.fc4 gaim.i386 1:1.5.0-9.fc4 hwdata.noarch 0:0.158.3-1 k3b.i386 0:0.12.7-1.0.fc4.kde kdebase.i386 6:3.4.3-1.1.fc4.kde kdebase-devel.i386 6:3.4.3-1.1.fc4.kde kudzu.i386 0:1.1.116.3-1 kudzu-devel.i386 0:1.1.116.3-1 livna-release.noarch 0:4-0.lvn.7.4 lm_sensors.i386 0:2.9.1-3.FC4.2 mDNSResponder.i386 0:107.1-0.0.fc4 net-tools.i386 0:1.60-52.fc4.1 ntsysv.i386 0:1.3.23-0.4 openldap.i386 0:2.2.29-1.FC4 openldap-clients.i386 0:2.2.29-1.FC4 openldap-devel.i386 0:2.2.29-1.FC4 spamassassin.i386 0:3.0.4-2.fc4 sysreport.noarch 0:1.4.1-5 tar.i386 0:1.15.1-11.FC4 wireless-tools.i386 1:28-0.pre10.4
Setting up Update Process
['Missing Dependency: dbus-qt = 0.33-3.1.fc4.kde is needed by package dbus-devel']


I don't find this output to be helpful. What needs to be done to resolve this dependency problem and update the package?

spooon 11-14-2005 05:49 PM

"dbug-qt" is available from the KDE-RedHat repository; you can add it to your Yum repos. It doesn't make any sense since the "dbus-devel" package that comes with Fedora Core doesn't depend on "dbus-qt". Maybe you mistyped the name or it's from somewhere else? You can try removing it and see what happens.

tron_thomas 11-15-2005 10:43 PM

My YUM Extender repository has two entries:
kde-redhat-stable
kde-redhat-stable-all

Both refer to the same repository:
/etc/yum.repos.d/kde-redhat.repo

The package fails to update even when both repositories are selected. I don't see how I could have mis-typed anything as YUM Extender provides all the information without me have to use the keyboard.

KTheorem 11-21-2005 09:31 AM

Solution
 
The problem is that either YUM Extender or YUM itself is not marking dbus-qt-devel to be upgraded. You will have to tell Yum Extender to install it manually. To do so, go to the install tab and use "dbus-qt" as the filter (without the quotes). Then check both dbus-qt and dbus-qt-devel. and then hit install. That should fix your problem.


Note:
on my system hal-devel 0.5.2-2 was dependant upon the version of dbus-qt-devel that you are having trouble updating automatically. I decided to remove it but YMMV.

tron_thomas 11-21-2005 10:40 PM

I think that did the trick. dbus-qt no longer shows up in the update list.
Thanks.


All times are GMT -5. The time now is 09:21 PM.