LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't install Perl Modules/Bugzilla (http://www.linuxquestions.org/questions/linux-software-2/cant-install-perl-modules-bugzilla-206430/)

Delsphynx 07-17-2004 09:12 PM

Can't install Perl Modules/Bugzilla
 
Well, I setup my first Linux system yesterday (Mandrake 10) and am trying to get Bugzilla up and running, and since I'm not very knowledgeable at all, I'm trying to follow the instructions on their site step-by-step for installation. I am currently at the part for installing the Template Toolkit and DBD::mysql.

When I am trying to install these modules, using perl -MCPAN the installation fails, as shown (sorry for the amount of code, but I figured someone can understand this better than I can...)

Code:

make[1]: Entering directory `/root/.cpan/build/Template-Toolkit-2.13/xs'
gcc -c  -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -
D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -fomit-frame-pointer -
pipe -march=i586 -mcpu=pentiumpro  -DVERSION=\"2.13\" -
DXS_VERSION=\"2.13\" -fPIC "-I/usr/lib/perl5/5.8.3/i386-linux-thread-
multi/CORE"  Stash.c
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
Running Mkbootstrap for Template::Stash::XS ()
chmod 644 XS.bs
rm -f ../blib/arch/auto/Template/Stash/XS/XS.so
LD_RUN_PATH="" gcc  -shared -L/usr/local/lib Stash.o  -o ../blib/arch/auto/Template/Stash/XS/XS.so
/usr/bin/ld: unrecognized option '--as-needed'
/usr/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make[1]: *** [../blib/arch/auto/Template/Stash/XS/XS.so] Error 1
make[1]: Leaving directory `/root/.cpan/build/Template-Toolkit-2.13/xs'
make: *** [subdirs] Error 2

Any ideas? I literally don't have any idea about what it is doing, where it is getting --as needed, how to tell it to not be, etc. etc. etc.

The code above is for Template Toolkit, and the same failure also occurs on DBD::mysql. All other packages I needed seemed to work great...

I am truly at a loss...:confused:


All times are GMT -5. The time now is 02:56 PM.