LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't install kernel-devel for older kernel (http://www.linuxquestions.org/questions/linux-software-2/cant-install-kernel-devel-for-older-kernel-640093/)

cletcher 05-05-2008 12:51 PM

Can't install kernel-devel for older kernel
 
I'm trying to install the kernel headers for an older kernel on my system but it just keeps installing the ones for the newest kernel on the system when I use:
# yum install kernel-devel

Here is some info.

# uname -r
#2.6.24.4-64.fc8

# rpm -qa |grep kernel
# kernel-2.6.24.4-64.fc8
# kernel-headers-2.6.24.5-85.fc8
# kernel-devel-2.6.24.5-85.fc8
# kernel-2.6.24.5-85.fc8

I'm not sure how to tell yum to specifically install the devel package for the older kernel.

Thanks

reddazz 05-05-2008 01:03 PM

Unfortunately the Fedora repos don't seem to keep the old kernel-devel packages. One option is to search on google for kernel-devel-2.6.24.5-85.fc8 and you maybe lucky to find a mirror with the rpm you need.


All times are GMT -5. The time now is 05:33 PM.