LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can't get Xinerama to work with dual head... (http://www.linuxquestions.org/questions/linux-software-2/cant-get-xinerama-to-work-with-dual-head-188680/)

Erik Plaggenmar 06-01-2004 10:43 PM

Can't get Xinerama to work with dual head...
 
Hi all!!
I'm havind trouble with Xinerama, after a brand new XF86Config i get the error of no screens found.... but i don't know what the problem is.... because when i delete 1 screen and 1 output on my graphic card, everything works except the dual headed display off course.......

I really don't know anymore what to do :S i tried editing XF86Config using some howto, didn't work, using fglrxconfig, no effect......

Does anybody know the solution to my problem?? (or some good howto for a ATI 9000)

Some information about my system ;)
Graphics: ATI 9000 pro
Processor: AMD1800+
Memory: 512MB
Box: testing Debian (Sarge)
well think that that's the all you should know...

Thanks in advance :):)

cav 06-02-2004 12:36 AM

I've struggled with dual-head for a very long time. The best way I can suggest is to first use the command 'X -configure', which will create the file XF86Config.new in your home directory based upon the settings that XFree86 detects. Edit this file to fine tune it, setting the default color depths and resolutions that you want, and also look up the refresh rates for your monitors and enter those in as well. There are a TON of threads in these forums dealing with dual-head, I started a bunch myself. Heres my config file for some reference:

Code:

Section "ServerLayout"
        Identifier    "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option "xinerama" "on"
EndSection

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath  "/usr/X11R6/lib/modules"
        FontPath    "/usr/X11R6/lib/X11/fonts/misc/"
        FontPath    "/usr/X11R6/lib/X11/fonts/Speedo/"
        FontPath    "/usr/X11R6/lib/X11/fonts/Type1/"
        FontPath    "/usr/X11R6/lib/X11/fonts/CID/"
        FontPath    "/usr/X11R6/lib/X11/fonts/75dpi/"
        FontPath    "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
        Load  "record"
        Load  "extmod"
        Load  "dbe"
        Load  "dri"
        Load  "glx"
        Load  "xtrap"
        Load  "type1"
        Load  "speedo"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "IMPS/2"
        Option            "Device" "/dev/mouse"
        Option      "Buttons" "5"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
        #DisplaySize          300  230        # mm
        Identifier  "Monitor0"
        VendorName  "HWP"
        ModelName    "b18"
        HorizSync 31-92
        VertRefresh 60-150
        Option            "DPMS"
EndSection

Section "Monitor"
        Identifier  "Monitor1"
        VendorName  "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync 30-70
        VertRefresh 50-120
        Option      "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                    # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "Dac6Bit"                    # [<bool>]
        #Option    "Dac8Bit"                    # [<bool>]
        #Option    "ForcePCIMode"              # [<bool>]
        #Option    "CPPIOMode"                  # [<bool>]
        #Option    "CPusecTimeout"              # <i>
        #Option    "AGPMode"                    # <i>
        #Option    "AGPFastWrite"              # [<bool>]
        #Option    "AGPSize"                    # <i>
        #Option    "RingSize"                  # <i>
        #Option    "BufferSize"                # <i>
        #Option    "EnableDepthMoves"          # [<bool>]
        #Option    "EnablePageFlip"            # [<bool>]
        #Option    "NoBackBuffer"              # [<bool>]
        #Option    "PanelOff"                  # [<bool>]
        #Option    "DDCMode"                    # [<bool>]
        #Option    "CloneDisplay"              # <i>
        #Option    "CloneMode"                  # [<str>]
        #Option    "CloneHSync"                # [<str>]
        #Option    "CloneVRefresh"              # [<str>]
        #Option    "UseFBDev"                  # [<bool>]
        #Option    "VideoKey"                  # <i>
        Identifier  "Card0"
        Driver      "radeon"
        VendorName  "ATI Technologies Inc"
        BoardName  "Radeon RV100 QY [Radeon 7000/VE]"
        BusID      "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option    "NoAccel"                    # [<bool>]
        #Option    "SWcursor"                  # [<bool>]
        #Option    "UsePIO"                    # [<bool>]
        #Option    "ShowCache"                  # [<bool>]
        #Option    "VideoKey"                  # <i>
        #Option    "NoSLI"                      # [<bool>]
        #Option    "TexturedVideo"              # [<bool>]
        #Option    "DRI"                        # [<bool>]
        Identifier  "Card1"
        Driver      "tdfx"
        VendorName  "3Dfx Interactive, Inc."
        BoardName  "Voodoo 3"
        BusID      "PCI:0:9:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device    "Card0"
        Monitor    "Monitor0"
        DefaultDepth 16
        SubSection "Display"
                Depth    1
        EndSubSection
        SubSection "Display"
                Depth    4
        EndSubSection
        SubSection "Display"
                Depth    8
        EndSubSection
        SubSection "Display"
                Depth    15
        EndSubSection
        SubSection "Display"
                Depth    16
                Modes "1280x1024"
        EndSubSection
        SubSection "Display"
                Depth    24
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen1"
        Device    "Card1"
        Monitor    "Monitor1"
        DefaultDepth 16
        SubSection "Display"
                Depth    1
        EndSubSection
        SubSection "Display"
                Depth    4
        EndSubSection
        SubSection "Display"
                Depth    8
        EndSubSection
        SubSection "Display"
                Depth    15
        EndSubSection
        SubSection "Display"
                Depth    16
                Modes "1280x1024"
        EndSubSection
        SubSection "Display"
                Depth    24
        EndSubSection
EndSection

Section "DRI"
        Group 0
        Mode 0666
EndSection


LinuxLala 06-02-2004 03:59 AM

Erik Plaggenmar, you reallyu should take care where you are posting your threads. This is the WQnS forum, which after 25 posts on the site you should have realized is for questions related to this website and not to linux.

Your thread has been reported and will soon be moved to an appropriate forum to get you the best answer, so no need to recreate the same thread in some other forum.

Please take care as to where you post your threads next time.

Regards.

Erik Plaggenmar 06-02-2004 05:05 AM

Yeah, my excuse!!! I also couldn't find it anywhere :S
Really stupid of me.... usually I always post in software, but i guess i was just browsing the forums, en then I started this thread... in the wrong forum :S

Well, (if the mods can) maybe you can move it??

LinuxLala 06-02-2004 06:27 AM

Never mind. I have reported this thread and so, Jeremy, whenever he finds time, will move it to an appropriate forum.

jeremy 06-02-2004 08:15 AM

//moved to a more appropriate forum.

--jeremy

drbeka 06-03-2004 04:25 PM

Xinerama and 7000
 
hi,

I have following section in my XF86Config-4 and it leads to one desktop over two screens.

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"
Option "Xinerama" "true"
EndSection

perhaps this helps.


All times are GMT -5. The time now is 11:51 AM.