LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-06-2003, 05:46 PM   #1
darazman
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9.1
Posts: 29

Rep: Reputation: 15
cant connect to glftpd even locally


I ran the install script for glftpd successfully, no errors, I did some minor changes to the glftpd.conf file (though didnt work before i did changes) and I cant get connected to the ftp from a PC on the network or even from the linux box that is running the ftp... well i do get connected technically but nothing of use.
I've tried a couple different ports too.

Looking up 192.168.0.1
Trying 192.168.0.1:15000
Connected to 192.168.0.1:15000
Disconnecting from site 192.168.0.1
Waiting 30 seconds until trying to connect again

Arg

I know its a well used FTP program and i'm surprised how much troulbe i've had finding someone with a similar problem and it posted somewhere on the net.
theres nothing showing up in /var/log/messages about this, not sure where else i can look for problem logs

I'm running glftpd 1.29 on redhat 9.1
If i go to Services, i see glftpd there as one but i cant restart it, it says
Description: You must enable xinetd to use this service.
Status: xinetd service

I know the glftpd file in xinetd is being included cuz in the logs before install glftpd theres 2 services running within xinetd, after i install glftpd, there are 3.

Any help or direction where to look for this?
thx people!
 
Old 09-06-2003, 09:27 PM   #2
darazman
LQ Newbie
 
Registered: Aug 2003
Distribution: Redhat 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
Smile solved own problem

the default allowed ip mask to login is i think it was *@127.0.0.1 and even though the local machine to the ftp was trying to connect to itself the ftp only saw its 192.* addy, just had to edit the /ftp-data/users/glftpd file to a *@192.168.0.* mask and it werks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd server: can connect locally, not remotely propz Linux - Networking 2 10-24-2005 01:59 AM
Unable to connect to internet with SIS900 but able to ping locally kevinevans Linux - Networking 4 08-10-2004 02:16 PM
Outsiders can't connect to my FTP server? (using glFTPd) Erik Plaggenmar Linux - Software 4 06-02-2004 04:02 PM
Can't connect to Apche with https - locally it's OK abapdr Linux - Software 2 05-26-2004 04:37 AM
ProFTPd - can connect locally but...Could it be that Verizon DSL does not allow port cevjr Linux - Networking 5 02-22-2004 05:42 PM


All times are GMT -5. The time now is 06:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration