LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-17-2003, 11:01 PM   #1
antihuman
LQ Newbie
 
Registered: Dec 2003
Distribution: Suse Linux 9.0 Professional
Posts: 6

Rep: Reputation: 0
Question cannot properly install ATI radion 9600 SE in Suse 9 pro


Just wanted to let anyone reading this that I'm pretty well still a newbie at linux. I'm having problems with getting my ATI Radion 9600SE video card installed correctly. I install the RPM following the instructions given by ATI and I get a error message while the package is doing its work. The error message is as follows:

*** Trying to install a precompiled kernel module.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
*** Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.4.21-144-athlon/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
*** WARNING ***
Tailored kernel module for fglrx not present in your system.
You must go to /lib/modules/fglrx/build_mod subdir
and execute './make.sh' to build a fully customed kernel module.
Afterwards go to /lib/modules/fglrx and run './make_install.sh'
in order to install the module into your kernel's module repository.
(see readme.txt for more details.)

As of now you can still run your XServer in 2D, but hardware acclerated
OpenGL will not work and 2D graphics will lack performance.

failed.
/sbin/ldconfig: File /usr/X11R6/lib/FGL.renamed.libGL.so.1.2 is too small, not checked.
Installed: qt3 (gcc 3.2) based control panel application
===
ATI display drivers successfully installed
please run 'fglrxconfig' now
===

I followed the first instructions to go to the directory /lib/modules/fglrx/build_mod and running './make.sh'. I then get the error message:

ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.4.21-144-athlon/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.

I found out that I have a kernal that is supposed to be optimized for AMD. How can I get around this problem or make a new kernal and put it in grub? Any help would be very appreciated in this situation I have.

Last edited by antihuman; 12-18-2003 at 01:04 AM.
 
Old 12-18-2003, 03:52 AM   #2
rootboy
Member
 
Registered: Oct 2001
Distribution: Mint 15
Posts: 770

Rep: Reputation: 51
Hmmm,

You apparently have version "2.4.21-144-athlon", if not, then that would be a problem (check in Yast to see if it is installed).

Building a kernel is way too involved for me to list each step (besides, that's what the HowTo's are for), so read it here:

http://www.icewalkers.com/Linux/Howto/Kernel-HOWTO.html


Well, well, well, it looks like this guy got it going (you??)

http://www.linuxforum.com/forums/ind...showtopic=6560


The upshot is to get these files and follow the readme

ftp://ftp.gwdg.de/pub/linux/suse/ftp...0/fglrx/3.2.8/


John
 
Old 12-18-2003, 10:24 AM   #3
antihuman
LQ Newbie
 
Registered: Dec 2003
Distribution: Suse Linux 9.0 Professional
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the help, I'll give it a shot tonight and give a post on hew it worked. I can't now because I'm at work. Again,thanks for the help!
 
Old 12-18-2003, 10:36 AM   #4
sirra462
Member
 
Registered: Nov 2003
Posts: 58

Rep: Reputation: 15
See my posthere and follow the directions. Should work for you.
 
Old 12-24-2003, 02:38 AM   #5
rootboy
Member
 
Registered: Oct 2001
Distribution: Mint 15
Posts: 770

Rep: Reputation: 51
Very nice, very detailed instructions sirra462


John


antihuman, did you get it going?

Last edited by rootboy; 12-24-2003 at 02:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATi install guide for SuSE 9.2 pro Jason711 Suse/Novell 19 08-24-2005 04:50 AM
SUSE 9.1 Pro: Preparing to Install ATI AIW 9800 Flat_Bloke Suse/Novell 2 05-29-2005 11:57 PM
ATI All in Wonder Rage Pro not working (properly) in FC2 dietrichmd Linux - Hardware 0 10-21-2004 04:11 PM
ATI 9600se running slower than older ATI card w/ DRI on euth665667 Linux - Hardware 0 07-03-2004 06:10 AM
trying to get my radion 9700 pro a-i-w to work jjtrogdon Linux - Hardware 0 05-01-2004 09:02 AM


All times are GMT -5. The time now is 09:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration