LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-08-2007, 12:07 AM   #1
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Rep: Reputation: 15
Cannot Login to Console - Ctrl+Alt+F1 gives me black screen


Please keep in mind that I am a noob, try to be specific in all your steps..

My problem:

When entering password for user at the main login screen, there is an option to choose Login to Console if I choose that, all I get is a black screen. It seems that the commands do work, it is just that all I get is a black screen. By memory I tried to enter user name, password and sudo start x and it started, so comamnds work, but all I see is a Black Screen.

If during my X session I press Ctrl+Alt+F1 or Ctrl+Alt+F2 or whatever up to 6, all I get is a black screen. Ctrl+Alt+F7 does bring me back to the X session.

This is a problem as there are certain things which require no X running and console and I cannot do that.

Possible causes:

I have latest Nvidia 9xxx driver
I also isntalled Beryl and the uninstalled it, not sure if that console problem started after Beryl instillation.

Some people mentioned that it has something to do with Nvidia and framebuffer or Composite being enabled. Other said soemthign to do with grub, no idea what these things mean.

I do know that the console worked some time ago.

I have Kubuntu Edgy 6.10 Nvidia Go 6600 128 Mg video with 9xxx driver isntalled via envy nvidia script

I think that is all I know. Here is my xorg.conf http://pastebin.ca/345050

Please help.

Last edited by robertpolson; 02-08-2007 at 12:09 AM.
 
Old 02-08-2007, 01:05 AM   #2
stan.distortion
Member
 
Registered: Sep 2005
Location: ireland
Distribution: debian with bits of everything stuck on it
Posts: 114

Rep: Reputation: 15
Im fairly sure that it is a combination of the kernel comands passed by grub at boot ( in "/boot/grub/menu.1st") and the nvidia driver. Passing a different graphics setting to the kernel at boot (eg, the "VGA=?" section in menu.1st) will probably get it working.
A simpler option to test if this is the the cause:
In /etc/X11 there should be another xorg.conf file, probably something like xorg.conf.old which will be a backup from before you installed the nvidia driver. Rename your xorg.conf (ie, something like xorg.conf.nvidia) then rename the backup file to xorg.conf, them cntl+alt+backspace to restart the xserver and check if it works with your origional driver.

cheers
stan
 
Old 02-08-2007, 07:27 AM   #3
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Already tried it, does not work.

Any more ideas or suggestions?
 
Old 02-08-2007, 08:13 AM   #4
stan.distortion
Member
 
Registered: Sep 2005
Location: ireland
Distribution: debian with bits of everything stuck on it
Posts: 114

Rep: Reputation: 15
You are sure it is loading the original drivers and not the nvidia ones? It will say in 'section "Device"' in /etc/X11/xorg.conf. When the system boots can you drop out of the boot splash and see the boot messages? To get rid of the splash (and speed up the boot a bit) remove 'splash' from the kernel you use in /boot/grub/menu.1st ie:
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet splash
to
kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet

To drop out of X use ctrl+alt+backspace (not ctrl+alt+del, that restarts). Depending on what display manager you use, you can stop it with:
/etc/init.d/kdm stop
for KDE
/etc/init.d/gdm stop
for gnome. Replacing 'stop' with 'start' or 'restart' does the obvious.
Try a few things and see either where in the boot process you loose the display or if dropping out of X completely does anything

Cheers,
Stan
 
Old 02-08-2007, 09:02 AM   #5
robertpolson
Member
 
Registered: Feb 2006
Posts: 48

Original Poster
Rep: Reputation: 15
Actually all of the backups of xorg.conf that I have, already have Nvidia in them from the envy script with 9xxx driver version.

I also did try to $ sudo dpkg-reconfigure xserver-xorg

and after reconfiguration, still I get no Console working. But I still have the Nvidia Logo for some reason

Setting kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet without splash also did not help

Setting it to: Setting kernel /boot/vmlinuz-2.6.15-26-386 root=/dev/hda1 ro quiet nosplash vga=normal

and andvga=897 ro whatever it was also did not help.

Here is my /boot/grub/menu.lst http://pastebin.ca/345549

What should I do now ?

Last edited by robertpolson; 02-08-2007 at 04:59 PM.
 
Old 02-10-2007, 05:18 AM   #6
stan.distortion
Member
 
Registered: Sep 2005
Location: ireland
Distribution: debian with bits of everything stuck on it
Posts: 114

Rep: Reputation: 15
comment out the nvidia driver:
from
Driver "nvidia"
to
# Driver "nvidia"
and add the open source 2D driver:
# Driver "nvidia"
Driver "nv"
You can just change it but commenting will make it easier to fix if you are stuck in the terminal

With splash removed from menu.1st , do you get messages scrolling by as the system boots?

Cheers,
Stan

Last edited by stan.distortion; 02-10-2007 at 05:30 AM.
 
Old 05-15-2007, 04:31 PM   #7
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 114Reputation: 114
There is a known bug in beryl when using the Nvidia rendering platform that will cause these symptoms.

I have experimented with it and determined that the problem goes away when you stop using the Nvidia rendering platform and start using AIGLX. I have not managed to get XGL running here so I don't know what happens when you use it.

Unfortunately (on my system at least) AIGLX is noticeably slower than Nvidia for rendering. I have taken to using Nvidia most of the time and switching to AIGLX (or else stopping beryl) when I find it necessary to go to a tty console.

Beryl is still immature. This is part of what you get when you use immature software.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl-Alt-F1 = Black,blank screen? timkarwoski Linux - General 16 02-03-2012 06:46 PM
Gnome crashes to black screen after boot up (though ctrl-alt-F2 gives a terminal) Gossamer Linux - Newbie 0 10-06-2005 01:32 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM
ctrl+alt+F6 does NOT restore console kadaver Slackware 1 03-10-2004 11:10 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration