LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   cannot install grub (grub-probe says 'unknown fs' with ext4 and md raid) (http://www.linuxquestions.org/questions/linux-software-2/cannot-install-grub-grub-probe-says-unknown-fs-with-ext4-and-md-raid-868314/)

cusco 03-13-2011 12:05 PM

cannot install grub (grub-probe says 'unknown fs' with ext4 and md raid)
 
Hi.

I'm sorry if Im not posting in the right section, I was not sure between here and 'Debian' section.

I installed Debian squeeze (when it was still testing) the same way. Partitioned two disks with raid, and them md raid partitions with ext4.

Now Im trying the same, but each disk is 1TB (dunno if size can make a difference).

-

Basically grub-install always fails with the grub-probe command:

Code:

root@e-mail:~# /usr/sbin/grub-probe --device-map=/boot/grub/device.map --target=fs -v /boot/grub
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd0 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: the size of hd1 is 1953525168.
/usr/sbin/grub-probe: info: changing current directory to /dev.
/usr/sbin/grub-probe: info: changing current directory to mapper.
/usr/sbin/grub-probe: info: opening md/0.
/usr/sbin/grub-probe: error: unknown filesystem.


What should I do?


Thanks in advance

pljvaldez 03-14-2011 10:56 AM

I think grub2 can sometimes have problems with ext4. My solution was to create a 100MB partition formated ext3 and put /boot there.

cusco 03-14-2011 12:52 PM

Hi.

I just fixed my issue. Aparently I needed a /boot in a partition smaller than 1TB

I made a md raid partition 1G for /boot (yes I know 100M was enough) and I can boot now

Thanks

JZL240I-U 03-15-2011 01:58 AM

Glad you could solve it yourself. Please mark this thread as [SOLVED] with the thread tools in the top so others may see easier that this thread has a solution. Cheers.


All times are GMT -5. The time now is 11:28 AM.