LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-27-2009, 11:55 AM   #1
Arancaytar
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Rep: Reputation: 1
Cannot execute files on ext4 partition


I just migrated my /home to a separate partition for easier upgrades/backups. Unfortunately, now my ~/bin scripts (and desktop launchers) can no longer be executed.

The ls command reveals that the files are still owned by me, and the permission masks still makes them executable:

Code:
-rwxr-xr-x 1 arancaytar arancaytar    75 2009-04-19 23:36 fortune
The fstab entry shows that the partition is mounted with the exec flag:

Code:
/dev/sda9	/home	ext4	exec,user,relatime,errors=remount-ro	0	0
And yet, files aren't executable:

Code:
bash: /home/arancaytar/bin/fortune: Permission denied
In fact, the only thing that's changed is that the file-system is ext4. But I didn't find anything on Google ext4 not supporting binary execution...
 
Old 05-27-2009, 12:07 PM   #2
Arancaytar
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 1
Addendum: fstab shows hat the partition SHOULD have been mounted with exec.

mount shows that (as could be guessed) it wasn't:

Code:
/dev/sda9 on /home type ext4 (rw,noexec,nosuid,nodev,relatime,errors=remount-ro)
So I guess my real question is: Why won't Ubuntu 9.04 let me mount a partition of type ext4 with the exec flag?
 
Old 11-06-2010, 02:58 PM   #3
glacionaut
LQ Newbie
 
Registered: Nov 2010
Posts: 3

Rep: Reputation: Disabled
Hello!

I have the same problem, have you solved it? How can i mount the ext4 partition with exec option set?

Thanks,
Anton
 
Old 11-07-2010, 03:06 AM   #4
Arancaytar
LQ Newbie
 
Registered: Feb 2009
Posts: 13

Original Poster
Rep: Reputation: 1
I'm afraid I haven't. It might be solvable, but personally I've sworn off ext4 for the time being; I'm back to ext3 exclusively.
 
Old 11-08-2010, 12:56 AM   #5
glacionaut
LQ Newbie
 
Registered: Nov 2010
Posts: 3

Rep: Reputation: Disabled
oh, not good to hear. but thanks for the reply.
so i will also switch back to ext3!

greetings from vienna,
Anton
 
Old 11-08-2010, 12:59 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Strange. Perhaps try looking at Ubuntu's forums, or their bug reporting pages, to see if it's known (and if not, add it).
 
Old 11-08-2010, 03:32 AM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,867

Rep: Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530Reputation: 530
Is your kernel atleast a 2.6.32 kernel.
I only ask ,because I have Debian 506 & Ubuntu 10.10
For Debian the only the 2.6.32 kernel was able to read into my Ubuntu files.
Ubuntu 10.10 is ext4
Debian is ext2

My only option was to change Debian kernel to 2.6.32.

Last edited by EDDY1; 11-08-2010 at 03:43 AM.
 
Old 11-08-2010, 08:31 AM   #8
cantab
Member
 
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by man mount
user
Allow an ordinary user to mount the file system. The name of the mounting user is written to mtab so that he can unmount the file system again. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line user,exec,dev,suid).
So there's your problem. I have no idea why you need the "user" option at all - that's normally employed for removable drives. But if you must use it, put exec after user.

(It should be noted than in general, when trying to figure out options and stuff for /etc/fstab, the mount manpage is a lot more informative than the fstab manpage.)

Last edited by cantab; 11-08-2010 at 08:32 AM.
 
Old 11-09-2010, 01:08 AM   #9
glacionaut
LQ Newbie
 
Registered: Nov 2010
Posts: 3

Rep: Reputation: Disabled
hi cantab!

that was also my first thought when i read the mount manpage.

my fstab is like this:
Code:
/dev/sda1	/media/Data	ext4	auto,user,exec,rw,async	0	0
and when i mount the disk (i am on an thinkpad t60 and the disk is in the ultrabay, so it sort of an external device) this is what i get:

Code:
$ mount
/dev/sda1 on /media/Data type ext4 (rw,nosuid,nodev)
i also tried to remove the auto and user flags in /etc/fstab:
Code:
/dev/sda1   /media/Data ext4    exec,rw,async   0   0
after mounting the disk i get this:
Code:
$ mount
/dev/sda1 on /media/Data type ext4 (rw)
i have tried many options in fstab, but nothing brings the disk to mount with the exec flag on. very strange...

has anyone else seen this behaviour?

thanks,
Anton
 
Old 11-09-2010, 01:42 AM   #10
ariels
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Thumbs up

Quote:
Originally Posted by glacionaut View Post
hi cantab!

that was also my first thought when i read the mount manpage.

my fstab is like this:
Code:
/dev/sda1	/media/Data	ext4	auto,user,exec,rw,async	0	0
and when i mount the disk (i am on an thinkpad t60 and the disk is in the ultrabay, so it sort of an external device) this is what i get:

Code:
$ mount
/dev/sda1 on /media/Data type ext4 (rw,nosuid,nodev)
There is no displayed "exec" flag when running "mount", only "noexec". If it's not there, you should be able to execute from it.
 
Old 11-09-2010, 03:19 AM   #11
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
I don't know what debian/*buntu do with their kernels, however if you really really want to go the ext4 route you should be using the latest stable kernel. ext4 is a newly born animal, and there's quite a lot of difference and a lot less bugs on newer kernels. Pick 2.6.36 from kernel.org and use that instead. If you still have problems then it will be time to look deeper.
 
Old 03-11-2013, 10:46 AM   #12
prplmnky
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 1
Quote:
So there's your problem. I have no idea why you need the "user" option at all - that's normally employed for removable drives. But if you must use it, put exec after user.
Thanks, cantab. I had a similar problem with executing on an external ext4 drive, and your solution worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ext4 partition corrupted by resized NTFS Vista C:\ partition? graviton-boson Linux - Newbie 2 03-16-2009 01:26 PM
Resize ext4 partition with LUKS encryption wsduvall Linux - Software 1 03-09-2009 10:14 AM
[SOS] a partition on backup drive can't be mounted , detected as ext4 gary4gar Linux - Newbie 9 10-20-2008 07:24 AM
Why the './' to execute files? SlowCoder Linux - Newbie 8 03-09-2007 01:09 AM
I cannot execute programs from Fat32 partition lamiczka Linux - Software 7 02-13-2005 01:06 PM


All times are GMT -5. The time now is 11:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration