LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2003, 04:12 AM   #1
White R4bbit
Member
 
Registered: Aug 2003
Location: Italy
Distribution: Debian sid 2.6.1
Posts: 54

Rep: Reputation: 15
Cannot connect


Hi, I just installed debian sid but I have a big problem: I configured my connection and if I run KPPP from root, everything is ok... but if I run KPPP from user, I first get this error:

Code:
You don't have sufficient permission to run
/usr/sbin/pppd
Please make sure that kppp is owned by root and has the SUID bit set.
And then I can't connect; before trying fixing by myself , I didn't get that error but still couldn't connect:
Code:
The pppd daemon died unexpectedly!
Exit status: 0
What should I do to fix the first problem and to connect to the Internet without loggin in as root?

Now I am on mandrake and with chroot I upgraded debian to sid and downloaded some packages, but since this morning it seems I can't connect neither in this way! Mandrake is correctly on-line but the chroot console with debian tells me this:
Code:
Err http://ftp2.it.debian.org sid/non-US/main Packages
  Temporary failure resolving 'ftp2.it.debian.org'
Help please
 
Old 09-28-2003, 12:51 PM   #2
lyle_s
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 389

Rep: Reputation: 52
kppp has the set user id (suid) bit turned on on my machine. Check yours like this:

lyle@bowman:~$ ls -l $(which kppp)
-rwsr-xr-x 1 root root 547532 Jan 27 2003 /opt/kde/bin/kppp*

See the "s" highlighted in red? It means that it runs with its owners (in this case, root's) id no matter who is actually running it.

It's good that it's not set up like this by default; having executables owned by root with the SUID bit turned on is a security risk. It's okay for you, because you need to have it set up that way.

As root, run:

chmod u+s $(which kppp)

to turn on the suid bit for kppp.

Lyle
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help to connect a squid proxy to connect to another squid proxy server bellerophon Linux - Newbie 1 02-07-2006 07:52 AM
can't connect wifi at home, but can connect everywhere else Javi2 SUSE / openSUSE 1 08-25-2005 07:49 PM
Samba: can't connect to my local linux machine but can connect to windows. Royle Linux - Networking 3 01-18-2005 06:32 PM
Problem withInternet, DHCP, connect with eth0 down work, connect with eth0 up not zowey Linux - Networking 1 03-12-2004 11:05 AM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 08:58 PM


All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration