LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 08-10-2005, 07:25 AM   #1
fannymites
Member
 
Registered: Nov 2004
Posts: 242

Rep: Reputation: 30
Cannot boot into Slax with grub...


I'm trying out a few distros at the moment but I'm having problems booting up Slax.

My partitions are laid out like this so far-
hda1 - Ubuntu
hda5 - PCLinuxOS
hda6 - Slax

hdb1 - Windows XP
hdb5 - Arch

All other OS's are booting fine but I've just installed Slax to hard drive from the live cd. It booted fine from it's own lilo booter after install but I re-installed grub from ubuntu which is my main, permanant distro.
In Slax's boot directory it just has the files map, vmlinuz and a bitmap image and nothing I have tried in grub will even get it starting booting, I get various errors such as invalid format, file not found etc.
If I can get lilo in Slax to install to the hda6 partition, which I did with PCLinuxOS at first, I reckon it will work but I can't do that either.
 
Old 08-10-2005, 07:46 AM   #2
J_K9
Member
 
Registered: Nov 2004
Distribution: Slackware 11, Ubuntu 6.06 LTS
Posts: 700

Rep: Reputation: 30
Hi,

Could you please post your grub.conf file? /boot/grub/grub.conf, because that way we can analize the options/parameters...

J_K9
 
Old 08-10-2005, 08:46 AM   #3
fannymites
Member
 
Registered: Nov 2004
Posts: 242

Original Poster
Rep: Reputation: 30
I don't have a grub.conf but this is my menu.lst if it helps.

Code:
default		0
timeout		10

splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title		Ubuntu Linux
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.10-5-386 root=/dev/hda1 ro quiet splash vga=792 
initrd		/boot/initrd.img-2.6.10-5-386
savedefault
boot

title		PCLOS Linux
root		(hd0,4)
kernel		/boot/vmlinuz-2.6.11-oci12.mdk-i586-up-1GB root=/dev/hda5 vga=792
initrd		/boot/initrd-2.6.11-oci12.mdk-i586-up-1GB.img
savedefault
boot

title           Windows XP
root            (hd1,0)
savedefault
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader     +1


title 		Slax 1
rootnoverify 	(hd0,5)
chainloader +1


title        	Slax 2
root        	(hd0,5)
kernel		/vmlinuz root=/dev/hda6 vga=792
savedefault
boot
When I went to check my menu.lst I realised I had already deleted some of the slax related entries that didn't work and unfortunately, I can't remember what they were since all were copied from various forum searches. The 2 still listed don't work either.
I'm still very much in learning mode so please don't be too hard on me if I've missed something simple.

Last edited by fannymites; 08-10-2005 at 08:47 AM.
 
Old 08-10-2005, 01:31 PM   #4
J_K9
Member
 
Registered: Nov 2004
Distribution: Slackware 11, Ubuntu 6.06 LTS
Posts: 700

Rep: Reputation: 30
OK, in Ubuntu, type (in terminal):

# sudo mkdir /media/slax
# sudo mount /dev/hda5 /media/slax

OK, once there, navigate to your /media/slax/boot directory. In there, you said there was a vmlinuz file - take the version number of that. In fact, copy the whole name. If there is an initrd, then copy that too. Then, in your menu.lst, put in the following entry:
Code:
title		Slax
root		(hd0,5)
kernel		/boot/vmlinuz-version root=/dev/hda5 vga=792
initrd		/boot/initrd-blahblah.img #There should be one
savedefault

boot
Does that work? Hope it does!

J_K9
 
Old 08-10-2005, 03:50 PM   #5
fannymites
Member
 
Registered: Nov 2004
Posts: 242

Original Poster
Rep: Reputation: 30
I thought the lack of an imitrd.img file may be a cause for problems booting.
The vmlinuz has no version number, it's just called vmlinuz and there is no imitrd.img file, I've been trying to make one but I'm not having much luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo : grub: The file /boot/boot/grub/stage1 not read correctly Boudewijn Linux - Software 3 05-21-2008 03:13 AM
how can boot slax from fat/mp3 player jabka General 9 10-14-2005 11:11 AM
need to access /boot/grub/menu.lst and /boot/grub/device.map neouto Linux - Newbie 8 09-04-2005 11:45 AM
slax stops in the middle of boot-up aquilolumen Slackware 13 08-15-2005 12:09 AM
Trying to boot SLAX from usb: cannot find IMG files. dr_zayus69 Linux - Hardware 2 04-04-2005 11:32 AM


All times are GMT -5. The time now is 01:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration