LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 02-02-2005, 06:53 PM   #1
cbj4074
LQ Newbie
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Ubuntu 6.10
Posts: 24

Rep: Reputation: 15
Cannot adjust 'apache2' service when starting Apache


Hello,

I am using SuSE 9.2 and am having trouble starting the Apache2 Web server. Whenever I attempt to start the service, I receive the message:

Cannot adjust 'apache2' service

which happens when I attempt to start Apache from within YaST. The error appears when the arrow is pointing to the "Run SuSEconfig" stage of the startup process.

Has anyone seen this before or know why it occurs?

Thank you!
 
Old 02-03-2005, 07:58 AM   #2
cbj4074
LQ Newbie
 
Registered: Jan 2005
Location: Dallas, TX
Distribution: Ubuntu 6.10
Posts: 24

Original Poster
Rep: Reputation: 15
I'm an idiot. If anyone else runs into this message, it's safe to say you probably have a syntactical error in your httpd.conf file. Oddly enough, I never edited mine and there was a missing </Directory> tag.
 
Old 06-07-2005, 12:53 AM   #3
desmondo
LQ Newbie
 
Registered: Mar 2003
Location: New Zealand
Posts: 3

Rep: Reputation: 0
Cannot adjust 'apache2' service when starting Apache

Hi,

I am running SuSE Linux 9.0 Open Enterprise Server with Novell OES and also received the message:

Cannot adjust 'apache2' service.

Thanks to you I've been able to rectify the problem.

It was a syntax error in my httpd.conf file. I never edited mine either but mine wasn't missing the </Directory> tag, it started with <Directory/>, so I removed the slash and BINGO.

Thanx again

 
Old 06-21-2005, 01:08 AM   #4
ebelcher
LQ Newbie
 
Registered: Jun 2005
Posts: 1

Rep: Reputation: 0
There can be any number of reasons for the 'cannot adjust apache2 service', none of your own making. Novell's scipts seem a bit flaky. I had never touched any of the config files when I started getting the error. I was only using the Yast Tool.

Located in /var/log/YaST2 is a log file that will give detailed descriptions of the error stopping apache being configured and started.

file:/var/log/YaST2/y2log

Hope this help some other poor soul trapped with this message.
Regards
Eric.
 
Old 07-27-2005, 03:10 PM   #5
linuxdragon
LQ Newbie
 
Registered: Jul 2005
Posts: 4

Rep: Reputation: 0
Cannot adjust 'apache2' service when starting Apache

Hello.
im getting the same error and i check't the httpd.conf changed it and nothing manually or not
and even deleted the apache2and put it back still the same error
p.s im running suse 9.3
so to make a long story short can anyone help??
thanx in advanced
when i try to start the service from command i get:


Starting httpd2 (prefork) Syntax error on line 6 of /etc/apache2/default-server.conf:
Alias takes two arguments, a fakename and a realname

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

failed

Last edited by linuxdragon; 07-27-2005 at 04:38 PM.
 
Old 08-14-2005, 03:13 AM   #6
mattl
Member
 
Registered: Mar 2004
Location: MA, USA
Distribution: OpenSuse 10, FC4/5, Mepis
Posts: 95

Rep: Reputation: 15
i just got this as well after upgrading suse 9.2 to 9.3

I copied my backup contents of etc/apache2 and all subdirs over the files that were in there after the upgrade and it fixed it. so i can't say which files were affected.
 
Old 11-09-2005, 03:45 AM   #7
farrenyoung
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
I don't know if the creator of this thread found their problem, but I ran across it because I too had the same problem. After some time of thinking I realized that the problem was probably due to the fact that I changed the default setting of "/srv/www/htdocs/" of the document root in the http host configuration to "/srv/www/htdocs/html/". With this being a new installation of linux, I hadn't yet created the html directory in the /srv/www/htdocs/ directory. So I simply created the directory, chmod 775, and chgrp www for it and tried to restart the http server and it worked fine. So hopefully this will help someone else.
 
Old 11-18-2005, 02:48 PM   #8
cascosailor
LQ Newbie
 
Registered: Nov 2005
Posts: 3

Rep: Reputation: 0
suse 9.3 apache2 https startup error

After installing a new suse 9.3 onto a Dell Celeron, I was getting "Cannot adjust apache2 service" error when starting Apache2 with HTTPS. HTTP alone worked fine. I did not have this problem when installing suse 9.2 on different system. I compared the major apache config files between my 9.2 and 9.3, and found that /etc/apache2/default-server.conf on my 9.3 system had an "SSLEngine on" statement (surrounded with IfDefines) at the end of the file. Deleted off this statement and it fixed the problem.

Thanks to the poster above who said he copied back his old 9.2 files on top of his 9.3 to fix the problem. That made the point that there must be a difference causing the problem. I compared most the config files, and they are generally the same between 9.2. and 9.3.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't Boot - Starting Printer Service - Starting CUPS jeansond Linux - Newbie 0 10-11-2004 06:39 PM
Starting Apache2 using Service Command liaaam Linux - Software 2 06-14-2004 05:06 AM
Starting and Restarting the Apache service. johann519 Fedora 6 02-05-2004 11:00 PM
apache2 not starting :( jd121 Linux - Software 7 08-20-2003 12:37 AM
Starting apache and mysql as service on boot :: buddy Linux - General 2 12-30-2002 02:51 PM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration