LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-05-2007, 04:52 PM   #1
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Rep: Reputation: 15
Cannot access Windows 2003 shares from Samba/smb4k


Hi,

I am running KDE 3.5.7 on Gentoo 2007.0 and I am having issues accessing my shares on a Windows 2003 SP2 machine. I can see the shares if I manually type in the address in konqueror with the IP, such as:

smb://192.168.1.1/share

However, if I try to browse Remote Places in Konqueror, I get an error when I click on the workgroup name that says Timeout on server WORKGROUP.

I have Lisa installed and running properly, but I'm not sure how to use that.

I'm trying to use Smb4k, which does see my Windows 2003 machine on the network. However, when I click on it I get an Access Denied message and then it asks me for a password. After typing my password, nothing happens. If I click the plus icon next to the 2003 machine in Smb4k, nothing happens. The computer entry is also highlighted blue for some reason in Smb4k.

Any Ideas? Thanks.

Matt
 
Old 09-05-2007, 06:01 PM   #2
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Original Poster
Rep: Reputation: 15
Here's some output from trying to mount my backup share in konsole:

localhost mstanisz # smbmount //23.69.22.51/Matt_Backup /mnt/backup username=mstanisz
Password:
7697: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed


Also, here's a screenshot of the blue highlighting in Smb4k (JENNA is my Windows 2003 machine):


http://www.gpzone.com/misc/snapshot1.png


Matt
 
Old 09-05-2007, 07:52 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
In your first message, the "Timeout on server WORKGROUP" message doesn't make sense unless I am misreading it. If "WORKGROUP" is the name of a server that doesn't sound right. Make sure that your smb.conf file has "workgroup = SLO" in the global part.

The first post indicates a possible name service switch problem (with winbind or wins) while the second indicates a permission problem. You didn't indicate what kind of password backend that your samba server is using. It probably is smbpasswd, so use the smbpasswd program to add the same username and password that the Win2000 host uses. Every windows user needs to be mapped to Linux. The "Samba 3 Howto & Reference" and "Samba 3 by Example" books will provide more detailed information. These books will be supplied by either the samba package or a samba-doc package. Look in /usr/share/doc/samba-<version>/ or /usr/share/doc/packages/samba/ for these books. You can also download them from the samba.org website.


Also check your firewall. The normal ports used are 127-129 tcp/udp. Windows 95/98 used broadcasts to resolve hostnames. Windows2000 & XP might be using port 445 instead. Make sure these ports are open in your firewall (on the samba host). The netbios over tcp setting in the win2000 host may determine which ports are used.

You might want to check if you have the libnss_winbind.so library installed. It should be installed along with samba. Also check your /etc/nsswitch.conf file. On the "hosts: ..." line add "winbind" after "files". See the manpages for winbind, nsswitch.conf and libns_winbind.

If you have the "wins support = yes" setting on your samba server, then install libns_wins and use "wins" in /etc/nsswitch.conf instead of "winbind". The winbind daemon will provide a wins service. With samba you can only have one wins server. You would supply the wins address to the DHCP server (or dhcp router setup) or manually add the wins address in each host's network configuration. You would do this if you have a large LAN and wished to reduce network traffic due by using wins instead of broadcasts, or if you needed to locate shares across a subnet.

Good Luck!

Last edited by jschiwal; 09-05-2007 at 07:55 PM.
 
Old 09-05-2007, 08:11 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I forgot to mention to try entering "smb:/" in the konqueror file manager. I don't know if Lisa works with networking for win2000 or XP. You may need to configure lisa if you plan on using it but I've never had luck with Lisa & XPs. Using smb:/ in konqueror is very convenient. You can have an smb://... share on a left panel and a local directory in a right hand pane and transfer files that way.
 
Old 09-05-2007, 08:23 PM   #5
CPUguy387
Member
 
Registered: Jul 2003
Location: San Luis Obispo, CA
Distribution: Gentoo 2007.0
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
In your first message, the "Timeout on server WORKGROUP" message doesn't make sense unless I am misreading it. If "WORKGROUP" is the name of a server that doesn't sound right. Make sure that your smb.conf file has "workgroup = SLO" in the global part.
Sorry about that, I do have "workgroup = SLO" set, I used the generic WORKGROUP by accident as an example.

Quote:
use the smbpasswd program to add the same username and password that the Win2000 host uses.
I have already set this for the username.

Quote:
Also check your firewall. The normal ports used are 127-129 tcp/udp. Windows 95/98 used broadcasts to resolve hostnames. Windows2000 & XP might be using port 445 instead. Make sure these ports are open in your firewall (on the samba host). The netbios over tcp setting in the win2000 host may determine which ports are used.
Where are the firewall settings on my Samba host? I really wasn't planning on using shares from my Gentoo box (i.e. a server), I just want to view the workgroup and access the windows shares.

Quote:
You might want to check if you have the libnss_winbind.so library installed. It should be installed along with samba. Also check your /etc/nsswitch.conf file. On the "hosts: ..." line add "winbind" after "files". See the manpages for winbind, nsswitch.conf and libns_winbind.
I set this and I had no difference. I will restart to be sure.

One new development, if I type the following as root:

smbmount //23.69.22.51/Matt_Backup /mnt/backup -o username=mstanisz

I can mount the share and rwx anything. However, as a the user (mstanisz), which is both on my linux box and the windows 2003 machine, I can mount it, but then I have no permissions.

Thanks.

Matt
 
Old 09-07-2007, 12:10 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Quote:
I really wasn't planning on using shares from my Gentoo box (i.e. a server), I just want to view the workgroup and access the windows shares.
Quote:
From smbd manpage:
The default ports are 139 (used for SMB over NetBIOS over TCP) and port 445 (used for plain SMB over TCP).
From nmbd manpage:
-p <UDP port number>
UDP port number is a positive integer value. This option changes the default UDP port number (normally 137) that nmbd responds to name queries on.

From /etc/services:
netbios-ns 137/tcp # NETBIOS Name Service
netbios-ns 137/udp # NETBIOS Name Service
netbios-dgm 138/tcp # NETBIOS Datagram Service
netbios-dgm 138/udp # NETBIOS Datagram Service
netbios-ssn 139/tcp # NETBIOS Session Service
netbios-ssn 139/udp # NETBIOS Session Service
Samba needs to be able to receive announcements from other hosts on the network, so the ports need to be open. Often a distro's samba config program will open the ports for you.

For samba shares, you need to consider the permissions of the directory begin shared. Does the user have full access to the directory. Is the share offered with full access to the user or only read-only.

For mounting smb shares, I would put an entry in /etc/fstab with the "user" option, and use a credentials file ( cred= option) and use the cifs filesystem type instead of smb. The smbfs is depreciated and may not be supported by your kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with smb4k samba shares lunoob Linux - Software 2 03-28-2007 06:15 PM
Smb4k not showing Windows shares Latem Linux - Software 2 03-09-2005 09:32 AM
Samba 3.0.6 - How to mount Samba Shares from Windows 2003? kp1 Linux - Software 2 09-10-2004 06:03 PM
Cant Access Windows 2003 Server Shares Thru Samba tobias_r33per Linux - Software 4 05-22-2004 10:54 PM
Can't access samba shares from windows nuzzy Linux - Software 2 07-17-2002 05:44 AM


All times are GMT -5. The time now is 01:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration