LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 09-03-2012, 09:40 AM   #1
Doknik
LQ Newbie
 
Registered: Jun 2010
Posts: 26

Rep: Reputation: 1
Cannot Access Nagios Web Interface


After successfully installing Nagios core 3.4.1 (i also installed plug-in1.4.11) on our linux rhel 5.3 server i cannot login to the nagios web interface.I am running apache 2.2.3

I am using internet explorer 8 and also firefox 3.6.3

When i try to enter the url http//localhost/nagios/ on a desktop (on the same network as the Nagios server)it does seem to like

it but if i try

http//x.x.x.x/nagios/ (where x.x.x.x is the IP address of my nagios server) it likes it but then the authentication popup appears

after entering the password and username it throws the erors below


The server x.x.x.x at Nagios access requires a username and password

Warning this server is requesting that your username and password be sent in an insecure
manner(basic authentication without a secure connection)


After a few attempts i get error 401 authentication required error from internet explorer ;this server could not verify that you are authorized to access the document requested.
Either you supplied the wrong credentials or your browser doesnt understand how to supply the credentials required.

Help Please anyone..seems like an authentication issue
 
Old 09-03-2012, 09:45 AM   #2
Doknik
LQ Newbie
 
Registered: Jun 2010
Posts: 26

Original Poster
Rep: Reputation: 1
Sorry i fixed my own problem just 3 mins after i post this thread ...i changed the permissions on htpasswd.users file it was owned by root.I changed it to be readable by nagios user..depends on your preference you can keep it owned by root and chmod it to make it readable by ALL or chown it such that its owned by nagios ..i just "chmodded" mine to make it readable and Bingo it worked
 
1 members found this post helpful.
Old 09-03-2012, 07:55 PM   #3
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Thank you for that.

Quote:
..i just "chmodded" mine to make it readable and Bingo it worked
Fixed my source-install.

Cheers, Glenn
 
  


Reply

Tags
nagios, redhat, web


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nagios Web Interface does not notify when nagios service is killed! learnerAlways Linux - Newbie 1 11-04-2011 12:23 AM
nagios web interface problem LMW Linux - Server 2 05-09-2011 11:30 PM
cannot find Nagios web interface (Nagios 3.2.0) and O/S = Fedora 10 gutiojj Linux - Newbie 7 02-04-2010 08:55 AM
Nagios Web Interface JPawlak Linux - Software 1 08-22-2003 03:49 PM
Nagios Web Interface sanfran49 Linux - Software 6 07-15-2003 10:36 AM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration