Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 08-01-2004, 12:04 PM   #1
Registered: Jul 2004
Distribution: Slackware 10
Posts: 120

Rep: Reputation: 15
can you help me with install a front end "dc_qt"

hi ...

im trying to install a front end for dctc program ..
now my problem i that i dont know so good at english
and in the readme they toled me to do thets ...
can you explain me in your words and make it to the very simle way ?
if you can so here what that i need to do .. its part 2 of the installation

Set some environment variables in the file .profile (or .login,
    depending on your shell) in your home directory. Create the
    file if it is not there already.

	QTDIR		   - the directory in which you're building Qt
	PATH		   - to locate the moc program and other Qt tools
	MANPATH 	   - to access the Qt man pages
	LD_LIBRARY_PATH	   - for the shared Qt library

    Note that under IRIX the additional LD_LIBRARYN32_PATH and
    LD_LIBRARY64_PATH variables are used for specifying library
    search paths. Set the variable that matches your configuration, or
    see the rld(5) man page for more information.

    This is done like this:

    In .profile (if your shell is bash, ksh, zsh or sh), add the
    following lines:



    In .login (in case your shell is csh or tcsh), add the following lines:

	setenv QTDIR /usr/local/qt
	setenv PATH $QTDIR/bin:$PATH
	setenv MANPATH $QTDIR/doc/man:$MANPATH

    After you have done this, you will need to login again, or
    re-source the profile before continuing, so that at least $QTDIR
    and $PATH are set. Without these the installation will halt with an error

    On AIX set LIBPATH and on HP-UX set SHLIB_PATH instead of LD_LIBRARY_PATH.

    Note that the SGI MIPSpro o32 and Sun WorkShop 5.0 targets are no
    longer supported as of Qt 3.3.
thanks for yours time ...
Old 08-01-2004, 12:25 PM   #2
Senior Member
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Are you installing Qt from source and are you root? If you are root then you don't need to do that, but instead just run:
./configure -thread

(that might be --thread, I'm not sure). The -thread bit is to enable multi-threading.
Then just run make and make install.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 12:49 PM
Is there a "working" GUI Front End for LVM +? tuxfriend2 Linux - Software 2 06-17-2005 09:29 AM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 02:32 PM
what is mean by "~/" in front of a command line? Niceman2005 Linux - Newbie 4 12-20-2004 07:59 AM
does failed using urpmi messed up my "Install Software" / "mandrake update" ??? sirpelidor Mandriva 1 11-02-2003 09:00 PM

All times are GMT -5. The time now is 01:05 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration