LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can not open Remote Graphical Display on Linux WS (http://www.linuxquestions.org/questions/linux-software-2/can-not-open-remote-graphical-display-on-linux-ws-400090/)

ppanyam 01-06-2006 12:57 AM

Can not open Remote Graphical Display on Linux WS
 
We have 2 PCs running Red Hat Linux and several SGI workstations. When we try to open the Graphical Display of SGI workstations on Linux machines, we get a error message "Cannot open Display <machine>:0".

we run "xhost +" command first.
run "setenv DISPLAY <machine>:0.0"

Even then we are unable to display remote machines' graphics on linux machines.

puffinman 01-06-2006 02:01 AM

Be sure that you have properly configured the X server on your Linux machines. In many cases the network functionality of X is disabled by default. For instance, the following is at the top of my /usr/bin/startx:
Code:

userclientrc=$HOME/.xinitrc
userserverrc=$HOME/.xserverrc
sysclientrc=/etc/X11/xinit/xinitrc
sysserverrc=/etc/X11/xinit/xserverrc
defaultclientargs=""
defaultserverargs="-nolisten tcp -br"
clientargs=""
serverargs=""

The -nolisten option prevents remote connections.

ppanyam 01-06-2006 07:17 AM

This is what is present in my /usr/X11R6/bin/startx file.

userclientrc=$HOME/.xinitrc
userserverrc=$HOME/.xserverrc
sysclientrc=/etc/X11/xinit/xinitrc
sysserverrc=/etc/X11/xinit/xserverrc
defaultclient=/usr/X11R6/bin/xterm
defaultserver=/usr/X11R6/bin/X
defaultclientargs=""
defaultserverargs=""
clientargs=""
serverargs=""

The -nolisten option is not used in defaultserverargs. Even then we are unable to open the Graphics of remote machine.

puffinman 01-06-2006 03:16 PM

Well it could be a lot of things. Make sure you have the relevant ports open on any firewalls between the machines, and have proper domain names for the machines. Also check out http://www.faqs.org/docs/Linux-mini/Remote-X-Apps.html

Good luck.


All times are GMT -5. The time now is 06:51 PM.