LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Can I Hibernate? (http://www.linuxquestions.org/questions/linux-software-2/can-i-hibernate-268518/)

ernesto_cgf 12-20-2004 04:18 PM

Can I Hibernate?
 
I miss a lot the ability to hibernate that I had in Windows. I searched in this site on how to do this, and found this thread, among other ones.

According to what I read in that thread (and some of the others), I have some questions: Why is not normally possible to hibernate in linux desktop boxes and it seems to be a posibility for laptops? Is there any alternative, like the one decribed in that thread? Are they always so risky and so difficult to set up? Does somebody know if this is being worked out by kernel/linux developers? I would be happy to know Linux will hibernate sometime in the (not so far) future, with the option being listed along with the logout/shutdown/restart options in the graphical desktops and login managers.
I suppose it should be a runlevel, so that I can even hibernate with telinit. Are there plans for any of this to be?

iZvi 12-20-2004 04:30 PM

I have a normal desktop system and I usually use hibernate to shut down when I 'm not on the PC. To make this work without the need of power management utils you need software suspend. It also requires kernel recompilation. Visit this link:
http://softwaresuspend.berlios.de/

i don't find it hard to be done, but if you find some difficulties i'd be glad to help, if I can.

ernesto_cgf 12-20-2004 10:52 PM

Quote:

Originally posted by iZvi
I have a normal desktop system and I usually use hibernate to shut down when I 'm not on the PC. To make this work without the need of power management utils you need software suspend. It also requires kernel recompilation. Visit this link:
http://softwaresuspend.berlios.de/

i don't find it hard to be done, but if you find some difficulties i'd be glad to help, if I can.

I can see you are using kernel 2.6.9 and I am using kernel 2.6.3 which came precompiled in my mandrake distribution. I didn't find any version of this softwaresuspend software for kernel 2.6.3 in their web site, just 2.4.x and 2.6.7 and over. I know I have to recompile my kernel, but it can be the 2.6.3 source I already have with my distribution, or it must be 2.6.9 ?? Or is there a version specific for 2.6.3 ?? or perhaps the version for kernel 2.6.9 is ok with kernel 2.6.3 ?? (I don't think so)

thanks anyway. I'll try to find out how to get this done and I will give it a try.

iZvi 12-23-2004 03:22 AM

I think it should work for older versions of the 2.6 kernel too. You can try to aplly the patch, and the patch command doesn't output errors it should work. Otherwise, reverse the patch, and either find a different version of the patch or copmile 2.6.9 kernel.


All times are GMT -5. The time now is 11:17 PM.