LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-18-2003, 03:16 PM   #1
Rosco8255
LQ Newbie
 
Registered: Oct 2003
Location: Denver, CO
Distribution: SuSE 8.2
Posts: 4

Rep: Reputation: 0
Can't start vsftpd -- OOPS: socket


My distribution is SuSE 8.2, the firewall is disabled.

Everytime I try to start vsftpd as root from the command line I get a kernel OOPS: socket message. I have edited /etd/vsftpd.conf to try various control and data ports, but always get the same message. I have no other instance of vsftpd or other ftp server running.

Does anyone have an idea on this one???
 
Old 10-20-2003, 10:36 AM   #2
Coldmiser
Member
 
Registered: Sep 2003
Location: Chicago
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
Can you post your vsftpd.conf file?
Also, is your FTP server running in standalone mode or is it being run from xinetd?

You said you are starting it from the command line (so it sounds like you are running in stand alone mode) if so.... you might want to make sure that "listen=YES" is in your vsftpd.conf file.
 
Old 10-20-2003, 12:13 PM   #3
Rosco8255
LQ Newbie
 
Registered: Oct 2003
Location: Denver, CO
Distribution: SuSE 8.2
Posts: 4

Original Poster
Rep: Reputation: 0
I am trying (unsuccessfully) to run vsftpd in standalone mode. If (when) I get it to run this way, I will probably set it up to start via xinetd.

Output from "netstat -natu"
--------------------------

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:631 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp 1 0 10.0.0.2:32858 68.54.159.145:80 CLOSE_WAIT
udp 0 0 0.0.0.0:68 0.0.0.0:*
udp 0 0 0.0.0.0:111 0.0.0.0:*
udp 0 0 0.0.0.0:631 0.0.0.0:*


/etc/vsftpd.conf
----------------

dirmessage_enable=YES
anonymous_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
ftp_data_port=20
pam_service_name=vsftpd
listen=YES
listen_port=21
 
Old 10-21-2003, 02:32 PM   #4
rickenbacherus
Member
 
Registered: Mar 2003
Location: colorado springs. colorado
Distribution: Debian-Sid 2.6.24-rt1
Posts: 290

Rep: Reputation: 30
I was under the impression that you could not run vsftpd from cli. It has to be run from inetd or xinetd. Here's the line from /etc/inetd on my Debian system:

ftp stream tcp nowait root /usr/sbin/vsftpd
 
Old 10-21-2003, 07:15 PM   #5
Rosco8255
LQ Newbie
 
Registered: Oct 2003
Location: Denver, CO
Distribution: SuSE 8.2
Posts: 4

Original Poster
Rep: Reputation: 0
It is my understanding that vsftpd indeed can be run in stand alone mode (not via an inetd). I quote from the man page for vsftpd.conf:

listen If enabled, vsftpd will run in standalone mode.
This means that vsftpd must not be run from an
inetd of some kind. Instead, the vsftpd executable
is run once directly. vsftpd itself will then take
care of listening for and handling incoming connec_
tions.

Default: NO

You will note the LISTEN=YES line in vsftpd.conf posted previously.
 
Old 10-22-2003, 12:30 PM   #6
Coldmiser
Member
 
Registered: Sep 2003
Location: Chicago
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
Yes, you can run VSFTPD in stand-alone mode.

Your conf file looks good. Are you certian you do not have a vsftpd in your /etc/xinetd.d directory?

I would simplify your conf file at least until you get it running properly. Try this...

connect_from_port_20=YES
pam_service_name=vsftpd
listen=YES
listen_port=21
 
Old 10-22-2003, 12:53 PM   #7
Rosco8255
LQ Newbie
 
Registered: Oct 2003
Location: Denver, CO
Distribution: SuSE 8.2
Posts: 4

Original Poster
Rep: Reputation: 0
I have discovered some additional info about this problem -- it has nothing to do with vsftpd configuration.

If I boot with the kernel originally shipped by SuSE, vsftpd starts and runs perfedtlllly. When I use the kernel that I compiled, the problem occurs.

It is my preference to build a kernel with all modules builtin that are required to get the system up and running (i.e. support for ext3, vfat, cdrom, SOCKETS, etc.). SuSE uses the initrd mechanism to load modules at boot time. Obviously, I have screwed up somewhere. Does anyone have any idea which modules might be involved with this OOPS: socket problem?
 
Old 10-22-2003, 02:51 PM   #8
Coldmiser
Member
 
Registered: Sep 2003
Location: Chicago
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
I couldn't begin to answer your question, but I would suggest you start a new post for it because no one is going to look at this one for a kernel question.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
500 OOPS: vsftpd: must be started as root userbr Linux - Networking 3 06-27-2011 01:44 AM
500 OOpS error w/ vsftpd 5amYan *BSD 5 11-08-2006 06:59 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 02:05 AM
how to start and configure VSFTPD QiEr Linux - Newbie 2 02-02-2005 10:10 PM
vsftpd - Why is it trying to start at boot? SForsgren Linux - General 2 04-28-2003 11:44 PM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration