LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-21-2005, 06:54 AM   #1
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,009

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Can't play audio cd's with amarok.


Hi all, I'm on FC4, and I just installed amarok 1.3.5. Everything works fine, except, I can't hear audio cd's. I go to 'Actions > Play audio cd's' and it shows me the song it's supposed to be playing, but doesn't play anything at all. When I start amarok from the command line I get the following:

Code:
[vicente@localhost ~]$ amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
amaroK: [Loader] amaroK is taking a long time to load! Perhaps something has gone wrong?
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: MPEG::Header::parse() -- Invalid sample rate.
QObject::connect: Cannot connect QSignal::signal(const QVariant&) to (null)::(null)
QObject::connect: Cannot connect QSignal::signal(const QVariant&) to (null)::(null)
QObject::connect: Cannot connect QSignal::signal(const QVariant&) to (null)::(null)
Is anyone having the same issue?? How to solve it?? Thanks in advance.
 
Old 11-21-2005, 08:19 AM   #2
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Shoot, that happened to me, and I figured amarok just couldn't or wasn't supposed to. So I used xmms because KsCD sucks so terribly, but I do like amarok, especially the little minimized to the tray controls, which work across all my desktops. So knowing it wasn't just me, I would like CD functionality in amarok too.

SuSE 10.0, KDE, with amarok 1.3.6(Guru)...
 
Old 11-21-2005, 09:36 AM   #3
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,009

Original Poster
Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
I just upgraded to 1.3.6 and still having the same issue. Well, I use xmms to listen audio cd's too. Thanks for your reply.
 
Old 11-23-2005, 09:38 AM   #4
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Just happened to figure this one out, possibly. I use the xine engine by default, I like it. It does not have the option to play audio CDs in amarok.
I switched to the arts engine, which allowed it to work as you describe, it opens the cd, acts like it will play, then nada.
I switched to gstreamer, and immediately recieved CD audio working just fine.

Let me know if you get the same results.
 
Old 11-23-2005, 10:45 AM   #5
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,009

Original Poster
Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Yes, with the gstreamer engine I can play audio cd's, but then, the programs I've setup to use artsplay as sound output, doesn't play sounds (i'm on KDE and I'm using the amarok arts engine). I tried to solve it by selecting the gstreamer engine and artsdsink as output extension, but then, for some strange reason, amarok goes through the playlist very fast and doesn't play anything at all. I'll try to find a solution for it. Thanks for your help.
 
Old 11-23-2005, 01:05 PM   #6
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Yeah, gstreamer won't play mp3s either, which means for me, it isn't only good for playing CDs. That isn't terrible, at least I can use it again. But at least this is a step in the right direction.
 
Old 11-23-2005, 07:48 PM   #7
odiseo77
Senior Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 1,009

Original Poster
Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
I can play mp3's with the gstreamer engine on FC4. I think you need the gstreamer-plugins-mp3 package. (downloaded via yum). Maybe there's a similar package for SuSE too?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't play audio cd's odiseo77 Fedora 9 03-09-2005 04:54 PM
can't play audio CD's Lord Zoltar Linux - Hardware 16 07-05-2004 06:09 PM
Can't play Audio CD's bugsbunny Slackware 7 05-07-2004 09:07 AM
Audio CD's won't play on laptop Tino27 Slackware 5 11-16-2003 09:24 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM


All times are GMT -5. The time now is 03:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration