LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-03-2009, 05:06 PM   #1
jlebar
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Rep: Reputation: 0
Can't mount CD: "unknown filesystem type 'iso9660'"


I just upgraded to Ubuntu 9.10 Server (the VM distribution), and now I can't mount my VM's CD drive.

Code:
$ sudo mount /dev/cdrom /media/cdrom
mount: unknown filesystem type 'iso9660'
iso9660 is not listed as a filesystem in /proc/filesystems -- I dunno if it ever was.

I'm not sure how to get this to work again, and my Googling has been remarkably unhelpful.

Anyone know what I need to do? Any tips would be greatly appreciated.
 
Old 11-03-2009, 10:52 PM   #2
eth1
Member
 
Registered: May 2008
Posts: 97

Rep: Reputation: 20
If I get this correctly, you're trying to mount the CD in your virtual machine. If this is right then check by ejecting/unmounting the CD from the host machine. This happens a lot in Parallels where in after ejecting the CD from the host operating system, it would be accessible for the guest operating system(VM).
 
Old 11-03-2009, 10:54 PM   #3
jlebar
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Original Poster
Rep: Reputation: 0
I'm actually just trying to mount an ISO which I've mounted through VirtualBox. I've of course tried "virtually-ejecting" it in VirtualBox; that didn't help.
 
Old 11-03-2009, 11:04 PM   #4
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657
Does your VM's kernel have an iso9660 kernel module you can modprobe?
If you don't have this filesytem in the kernel, you won't be able to mount it, even if you have access to the device in your VM.
 
Old 11-03-2009, 11:09 PM   #5
jlebar
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Original Poster
Rep: Reputation: 0
Code:
$ sudo modprobe iso9660
FATAL: Module iso9660 not found.
I'll take that as a no?

I guess I'll go file a bug with Ubuntu. I'm pretty surprised that they took this out of their VM kernel, if that's what's indeed going on.
 
Old 11-03-2009, 11:24 PM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657
I'm not home right now and can't double check the name. Check if you can modprobe isofs. It might be an alias set in /etc/modprobe.conf or a file in /etc/modprobe.d/. Sometimes a kernel module may change names between kernel versions as well. For example, tcp_conntrack was renamed nf_conntrack in recent kernels. Also check the /boot/config-<version> file for what kernel options were used. Some kernels have a /proc/config.gz file (if this feature is enabled) you can use as well.

Last edited by jschiwal; 11-03-2009 at 11:26 PM.
 
Old 11-04-2009, 01:15 AM   #7
jlebar
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Original Poster
Rep: Reputation: 0
Can't modprobe isofs.

There's this in my /boot/config-2.6.31-14-generic-pae:
Code:
#
# CD-ROM/DVD Filesystems
#
CONFIG_ISO9660_FS=m
CONFIG_JOLIET=y
CONFIG_ZISOFS=y
CONFIG_UDF_FS=m
CONFIG_UDF_NLS=y
 
Old 11-05-2009, 11:45 PM   #8
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657
I have a similar "CONFIG_ISO9660_FS=y" config entry for my kernel, but it is built-in so I don't see an iso9660 kernel module. However, I don't have an iso9660.ko entry in modules.builtin. Looking for iso9660.ko might be a fools errand.

Double check your config settings for your running kernel:
zcat /proc/config.gz | grep ISO9660
zcat /proc/config.gz | grep ISOFS

Look at your boot up messages for your VM. Is the cdrom/dvd device itself detected?
 
Old 11-07-2009, 04:06 PM   #9
jlebar
LQ Newbie
 
Registered: Jan 2009
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
I have a similar "CONFIG_ISO9660_FS=y" config entry for my kernel
Mine is CONFIG_ISO9660_FS=m, not 'y'. Perhaps 'm' stands for 'manual'?

Quote:
Double check your config settings for your running kernel:
zcat /proc/config.gz | grep ISO9660
zcat /proc/config.gz | grep ISOFS
I don't have a /proc/config.gz Maybe this file is somewhere else?

Quote:
Look at your boot up messages for your VM. Is the cdrom/dvd device itself detected?
From dmesg | grep -i cd:
Code:
[    0.973415] ata2.00: ATAPI: VBOX CD-ROM, 1.0, max UDMA/133
[    0.975142] scsi 1:0:0:0: CD-ROM            VBOX     CD-ROM           1.0  PQ: 0 ANSI: 5
[    0.976872] Uniform CD-ROM driver Revision: 3.20
[    0.976986] sr 1:0:0:0: Attached scsi CD-ROM sr0
 
Old 02-19-2015, 02:42 PM   #10
ppl
LQ Newbie
 
Registered: Feb 2015
Posts: 1

Rep: Reputation: Disabled
On this SuSE system the module isofs.ko needed to be loaded into the kernel, but is was dependent on nls_base.ko that had to be loaded first. So the short answer is:

Code:
# insmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/nls/nls_base.ko
# insmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko
I figured it out in the following way which might be useful for similar problems:

Code:
# mount -o loop SLES-11-SP2-DVD-i586-GM-DVD1.iso sles11sp3-32
mount: unknown filesystem type 'iso9660'
so filesystem is unknown
Code:
# modprobe iso9660
FATAL: Could not load /lib/modules/3.0.82-0.7-ec2/modules.dep: No such file or directory
whoah
Code:
# cat /boot/config-3.0.101-0.46-ec2 |grep 9660
CONFIG_ISO9660_FS=m
apparently, it's not in the kernel, but it is some loadable kernel module (m) that can be loaded on request
Code:
# find / -name isofs.ko
/lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko
so there it is
Code:
# insmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko
insmod: error inserting '/lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko': -1 Unknown symbol in module
but I cannot insert it in the kernel. It turns out it's dependent on some other kernel module
the way to find out is depmod, apparently
Code:
# depmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko
FATAL: Could not open /lib/modules/3.0.82-0.7-ec2/modules.dep.temp for writing: No such file or directory
mmm. well we can solve that, no?
Code:
# mkdir /lib/modules/3.0.82-0.7-ec2
# depmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/*/*.ko
# grep isofs /lib/modules/3.0.82-0.7-ec2/modules.dep
/lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko: /lib/modules/3.0.101-0.46-ec2/kernel/fs/nls/nls_base.ko
so there's the dependency
Code:
# insmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/nls/nls_base.ko
# insmod /lib/modules/3.0.101-0.46-ec2/kernel/fs/isofs/isofs.ko
looks promising...
Code:
# mount SLES-11-SP2-DVD-i586-GM-DVD1.iso sles11sp3-32 -o loop
mount: block device [...]/SLES-11-SP2-DVD-i586-GM-DVD1.iso is write-protected, mounting read-only
and jackpot!

Last edited by ppl; 02-19-2015 at 02:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get the "data type" of an "unknown variable" in "C Language" ? Affair Programming 8 06-20-2009 12:30 PM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
can't mount DVD (unknown filesystem 'iso9660' baghdadi13 Debian 10 09-05-2007 04:39 AM
mount: unknown filesystem type 'devfs' kfir_w Linux - Software 2 06-15-2007 06:44 AM
mount: unknown filesystem type 'ntfs' lowrida Linux - Newbie 3 08-01-2005 04:02 PM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration