LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-20-2009, 08:23 AM   #16
emilioaxp
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0

Ok so I'm stuck on login failed.

I already did the /sbin fix on tuncfg.c for ifconfig

Do I need to put the path somewhere else in tuncfg.c?

Last edited by emilioaxp; 02-20-2009 at 08:30 AM.
 
Old 12-17-2009, 04:54 PM   #17
chenxiaolong
LQ Newbie
 
Registered: Jun 2009
Location: /home/chenxiaolong and /root and /Users/chenxiaolong and C:\Users\chenxiaolong
Distribution: Fedora 12, Debian 5, Ubuntu 10.04
Posts: 17

Rep: Reputation: 0
I know this thread is very old, but I'll still post a solution because it's still a problem in Fedora. There's actually a very easy fix:

1. Stop the tuncfg process: su -c 'killall tuncfg' OR sudo killall tuncfg

2. Log on to the root terminal: su -

3. Start tuncfg: tuncfg

4. Create the Hamachi config for the ROOT user: hamachi-init

5. Exit out of the root terminal: exit

6. Create the Hamachi config for the CURRENT user if you haven't already: hamachi-init

7. Use Hamachi!!

If you want to make tuncfg run automatically as root on boot up, then add it to /etc/rc.local: echo "tuncfg" | su -c 'tee -a /etc/rc.local' OR echo "tuncfg" | sudo tee -a /etc/rc.local.
 
Old 12-18-2009, 06:42 AM   #18
chlawren
LQ Newbie
 
Registered: Nov 2005
Posts: 21

Rep: Reputation: 0
nice

I also had the same problem so thanks for the great post that has allowed me to use hamachi

chris
 
Old 12-18-2009, 03:17 PM   #19
chenxiaolong
LQ Newbie
 
Registered: Jun 2009
Location: /home/chenxiaolong and /root and /Users/chenxiaolong and C:\Users\chenxiaolong
Distribution: Fedora 12, Debian 5, Ubuntu 10.04
Posts: 17

Rep: Reputation: 0
You're welcome
 
Old 12-21-2009, 06:20 AM   #20
emilioaxp
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
Still nothing
 
Old 08-28-2010, 10:16 PM   #21
RRT
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Rep: Reputation: 0
Exclamation Can't find hamachi-init

Everything was going fine with the install until I got to the part where I run hamachi-init. It is nowhere to be find on my computer after running the installation process.

Any ideas what to try next???
 
Old 10-28-2010, 06:40 AM   #22
Boeta87
LQ Newbie
 
Registered: Oct 2010
Posts: 6

Rep: Reputation: 2
try to re-install hamachi, but copy or save the tuncfg.c file which you edited. (or just remember to make the changes again)
 
Old 10-28-2010, 06:55 AM   #23
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Fedora 17 amd64 / Fedora 17 i686 LXDE (w e17)
Posts: 229

Rep: Reputation: 41
just to be clear: it's a very old thread...
 
Old 02-09-2011, 08:58 AM   #24
Luke771
Member
 
Registered: Dec 2005
Location: Sol III, Milky Way
Distribution: Ubuntu
Posts: 43

Rep: Reputation: 15
Got it!
This is indeed a very old thread but it's still the first hit when you try to google hamachi login failed (i.e. the terminal output)

So, I was trying all I could think of, tap/tun was enabled, tuncfg was running, and Hamachi worked perfectly until last reboot, yet login kept failing

Had a look into /home/<user>/.hamachi and found a .lock file
renamed to .lock.back, tried again, and guess what?
login succeeded.

This may or may not be the problem that the first poster had, but as the thread is still 'alive' and never solved, I thoughht it was a good idea to add what fixed it for me:

if Hamachi suddenly starts failing to login for no apparent reason even tho it did work before, remove or rename the file /home/<user>/.hamachi/.lock
 
Old 02-10-2011, 10:09 AM   #25
Luke771
Member
 
Registered: Dec 2005
Location: Sol III, Milky Way
Distribution: Ubuntu
Posts: 43

Rep: Reputation: 15
well...
Turns out that simply removing the .lock file doesnt really do the trick. To make it work I have to use hamachi-init -f (force using the directory ~/.hamachi even tho it already exists).
Doing that and then removing the lock usually gets me back on line, but with 2 small problems:

- a new Hamachi IP every time. Kind of a PITA (I have to change a number of scripts)
- all this dang thing has to be done every time I reboot my Linux server. It doesnt happen all that often but still...

Im trying to find out why this happens so I can try to really fix it. None of the hints in this thread helped so far, except from my dirty workaround (with new IP at every use )
 
  


Reply

Tags
cant, login, logon, tuntap, vpn


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hamachi AnRkey Linux - Networking 3 01-17-2006 11:36 AM
Deleted /var/log/messages, can't log any files-iptables chingyenccy Linux - Newbie 7 02-27-2005 04:03 PM
Strange results in /var/log/apache/access.log subt13 Linux - Security 2 08-03-2004 01:21 PM
pppd logging to /var/log/ppp.log problem mrtwice Linux - Software 1 01-10-2004 05:38 PM
iptables, changing log file from /var/log/messages acid2000 Linux - Networking 3 03-11-2003 08:38 PM


All times are GMT -5. The time now is 11:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration