LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-06-2005, 06:44 PM   #1
didi86
Member
 
Registered: Jun 2004
Distribution: SuSE 10.0
Posts: 37

Rep: Reputation: 15
Can't get Audacity to compile


Hi,
I'm trying to get Audacity to compile, but I keep getting the following error message:

Code:
effects/ToneGen.cpp: In function �wxSizer* CreateToneGenDialog(wxWindow*, bool, bool)�:
effects/ToneGen.cpp:283: error: ISO C++ says that these are ambiguous, even though the worst conversion for the first is better than the worst conversion for the second:
/usr/local/include/wx-2.6/wx/gtk/choice.h:34: note: candidate 1: wxChoice::wxChoice(wxWindow*, wxWindowID, const wxPoint&, const wxSize&, int, const wxString*, long int, const wxValidator&, const wxString&)
/usr/local/include/wx-2.6/wx/gtk/choice.h:46: note: candidate 2: wxChoice::wxChoice(wxWindow*, wxWindowID, const wxPoint&, const wxSize&, const wxArrayString&, long int, const wxValidator&, const wxString&)
make[1]: *** [obj/effects/ToneGen.o] Error 1
make[1]: Leaving directory `/sources/Audio/audacity-src-1.2.3/src'
make: *** [audacity] Error 2
Does anybody have any idea what this means, or how to resolve the problem? (I'm using SuSE 10.0 with an i386_64 architecture)

I have wxGTK 2.6.1.0-4 installed (I think wxGTK is part of my problem)
 
Old 11-06-2005, 08:43 PM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
The wxWidgets library is required. Audacity 1.2 needs wxGTK 2.4, compiled without the gtk2 or unicode options. (Future versions of Audacity will support newer wxWidgets and GTK libraries.)
The way it's worded, i would fathom a guess that your version of wxGTK is too high, which is screwed if you have other programs that require the version of wxGTK you have already...
 
Old 11-06-2005, 08:44 PM   #3
sabre307
LQ Newbie
 
Registered: Oct 2005
Location: Atlanta, GA
Distribution: Fedora 14
Posts: 12

Rep: Reputation: 0
Sounds like there are issues with the code. Maybe you got a bad download. You can try download it again and checking the MD5 checksum. Also, if your using SuSE you should have yum. If that's the case, try typing this: "sudo yum install audacity" it will download and install a version of audacity pre-compiled for your version of SuSE. Alternatively, find RPMs. Unless you are just insistent on having the latest version, my opinion is to do things the easiest way possible, and that means using automatic package managers first, RPMs second, tarballs third, and source last.
 
Old 11-06-2005, 09:10 PM   #4
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
I doubt a redownload would work. wxGTK packages provide only specific version libraries. They don't provide older libraries like some other packages do. So where wxGTK-X.X.X would provide a libwx_gtk-X.X.so a newer version, wxGTK-Y.Y.Y would only provide libwx_gtk-Y.Y.so and not include wxGTK-X.X.so. In other words, newer version of wxGTK are not backwards compatible with older versions.

and judging by the compile errors, you couldn't try to symlink a link with the name of the old library version to the new library as there looks to be incompatibilities between the headers of different versions of wxGTK.

To make a long story short, it looks like to me that a choice will have to be made, if you want to get audacity to compile, to install the correct version of wxGTK or not.
 
Old 11-06-2005, 10:15 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
If you're using SuSE, Audacity should already be installed (assuming you did a full install). It should be under SuSE > Multimedia > Media Editing
 
Old 11-06-2005, 10:54 PM   #6
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
my guess is that he/she wants the newest version which may not be the version installed by suse.
 
Old 11-07-2005, 09:01 AM   #7
didi86
Member
 
Registered: Jun 2004
Distribution: SuSE 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
Hi,
first of all thanks for your replies. I really appreciate it.

@megaspaz: I think you might be right. My problem is: If I downgrade wxGTK I get some unresolved dependencies with other Software. Is it somehow possible to install both versions at the same time?

@J.W.&megaspaz: I'm not trying to compile the latest version of audacity. My problem ist that until SuSE 9.3 audacity was included in the distro. Since SuSE 10.0 it is not included anymore.

Last edited by didi86; 11-08-2005 at 12:15 AM.
 
Old 11-07-2005, 08:34 PM   #8
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
I don't know how you could make 2 different versions of wxGTK coexist peacefully. You may want to try the wxGTK mailing list.
 
Old 11-12-2005, 05:32 PM   #9
Nunana
LQ Newbie
 
Registered: Sep 2005
Posts: 17

Rep: Reputation: 0
I know the problem. I like to work with audacity but al the time things are missing when compiling.
Isn't there anybody who knows which libraray's in what order has to be installed. Some i cant even find. I tried several version.
I think I really messed up my Linux with it and seriously considdering to start all over again.
Two versions of wxGTK isn't working!
 
Old 11-13-2005, 03:57 AM   #10
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
What distro and what is the version of the distro you're using?

http://audacity.sourceforge.net/download/source

Quote:
How to Build Audacity
Dependencies

The wxWidgets library is required. Audacity 1.2 needs wxGTK 2.4, compiled without the gtk2 or unicode options. (Future versions of Audacity will support newer wxWidgets and GTK libraries.)

You may also choose to install the following optional libraries, or get them by checking out Audacity from CVS.
libmad
libsndfile
Ogg Vorbis

If you install libraries using a package management system like Apt or RPM, make sure to install the "dev" (development) packages for each library.
Compilation

To build Audacity, run the following command in the Audacity source directory:

./configure && make

You can type ./configure --help to see a list of compilation options. After Audacity is compiled, run make install as root to install it.
Along with the optional packages to install, i'd suggest getting the lame package as well.

If you're using an RPM based distro, you can try searching for packages here:
http://rpm.pbone.net/

Now to let you know, you need more than just the packages. You need to get their devel packages also. Without the devel packages, compiling audacity from source will not work. You do not need to get devel packages if you compile the required/optional packages from source though, only if you use RPMS.

You need to have required/optional packages installed first before you can compile audacity (or any program for that matter).

Last edited by megaspaz; 11-13-2005 at 04:02 AM.
 
Old 11-14-2005, 11:05 AM   #11
didi86
Member
 
Registered: Jun 2004
Distribution: SuSE 10.0
Posts: 37

Original Poster
Rep: Reputation: 15
A few minutes ago, I got tired of trying to get audacity to run on my SuSE 10.0, so I decided to try to install the windows-version with wine 0.9.1. I was quite surprised to find that audacity seems to run fine with wine, while I can't get the linux-version to run. I think I'm going to use the windows-version, until I find a solution to my problem.

Chris
 
Old 01-21-2006, 05:59 PM   #12
Nunana
LQ Newbie
 
Registered: Sep 2005
Posts: 17

Rep: Reputation: 0
There is an Audacity in Mandriva 2006. It is not the latest version. I don't know which one.
I'm running edubuntu 5.1 at the moment. If i want to install Audacity it says:
"Cannot install 'Audacity' Installing this application would mean that something else needs to be removed. Please use "Advanced" mode to install 'audacity'.
When I do so I get 2 Depends (libd3tag0 and libmad0) which are not installable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot run Audacity : "Audacity is already running" tuanito Linux - Software 7 06-11-2009 06:02 PM
Finally got audacity to compile akudewan LinuxQuestions.org Member Success Stories 11 11-02-2005 03:12 PM
Why do I get compile errors while compiling audacity? pujolasdf Linux - Software 9 06-27-2005 01:02 PM
audacity compile error spoto Linux - Software 0 12-21-2003 09:39 AM
audacity compile error vance Linux - Software 0 10-26-2003 10:50 PM


All times are GMT -5. The time now is 07:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration