LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-20-2004, 09:48 PM   #1
LitlJay
Newbie
 
Registered: Apr 2004
Posts: 28

Rep: Reputation: 15
Can't change permissions


I'm sure this has been asked but I'll be derned to heck if I can find it.

If any of you remember me, I got tired of juggling distros whose kernel wouldn't work with my Promise card without hours of heartache and finally resigned myself to Fedora Core 1. At least Fedora includes a tool that makes it pretty easy for me to "roll my own" kernel when I'm ready to streamline it a little bit (a lot).

For the search engine: In case anyone needs to know, Fedora is the only distro that I could find whose boot disk would allow you to install from a USB CD-ROM drive. Mandrake used to include a .img file to make a boot disk for just that purpose, but it is mysteriously absent in 10.0. I needed that for my laptop, whose CD-ROM died and who can't boot from a USB device.

Back on task. Now that you know what distro I am using...

hdg1 and hdi1 are fat32 partitions that I use to store my data on, such as files I download and my treasure trove of thousands of MP3's. They are drive d: and e: in WinXP and mounted as /data and /mp3 under Linux. The problem is that, when in Linux, root is the only user who can access the partitions! All users can read, but not write or execute.

chmod a+rwe /data ]or[ chmod a+rwe /mp3 both net the same result:

chmod: changing permissions of `/data' (requested: 0777, actual: 0755): Operation not permitted

]OR[

chmod: changing permissions of `/mp3' (requested: 0777, actual: 0755): Operation not permitted

chown litljay /data (or /mp3) nets:

chown: changing ownership of `/data' (or `/mp3'): Operation not permitted

So what am I missing?

TIA

J

 
Old 05-20-2004, 10:14 PM   #2
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 45
hey, this might be stupid, but are you chmod'ing as root, or not? (i didnt see you mention it...)
 
Old 05-20-2004, 10:34 PM   #3
LitlJay
Newbie
 
Registered: Apr 2004
Posts: 28

Original Poster
Rep: Reputation: 15
Yes, I'm working as root. I have to log in and do everything as root until I can give my usual login the right permissions.

BTW - I'm from Houston. Live near Conroe now, about a mile from the lake.
 
Old 05-20-2004, 11:08 PM   #4
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
What is the line for the Windows partition in /etc/fstab
 
Old 05-20-2004, 11:13 PM   #5
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 45
hmm,
i dont really see how you can change the permissions on a file on vfat/ntfs.
i know i can set my kernel up to enable writing to those partitions (which i believe is what changing permissions is all about over here), but once they are mounted without that support ...

also, if you notice, the write supports do come with a warning encouraging you not to (loss of data/unpredictability). myself, i've been mounting, making transfers as root, and umounting, and then logging back to regular user. in a way, it ensures that i dont forget to unmount, which could cause problems.

one alternative might be to enter these drives in ur filesystem table - /etc/fstab - and make the <options> have a 'user' option in it. again, because of what i wrote about kernel suppot for writes, im a bit skeptical about this.

maybe someone else can be of more use now ...

and hey, i just moved to houston a coupla months back; from new york. and i might be goin back, i think. somewhere on richmond avenue.

good luck - have fun.
 
Old 05-21-2004, 07:36 AM   #6
LitlJay
Newbie
 
Registered: Apr 2004
Posts: 28

Original Poster
Rep: Reputation: 15
Darthtux:

/dev/hdg1 /data vfat defaults 0 0
and
/dev/hdi1 /mp3 vfat defaults 0 0

H/W:

I knew that was an issue with NTFS; its one reason that I don't use it (among others). I thought mounting and writing to fat partitions was long since stable and safe. Maybe I'm wrong. Richmind avenue. Ick. Too urban for me. I do drive down there to go dancing at Wild West sometimes, though. I'll bet you can appreciate the courtesy of Houston drivers. The only rude ones are the ones from up north

J
 
Old 05-21-2004, 07:41 AM   #7
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Try
Code:
/dev/hdg1    /data      vfat      defaults,umask=000     0 0
/dev/hdi1     /mp3      vfat      defaults,umask=000     0 0
And to make it even better move the mount points to /mnt/data and /mnt/mp3, don't forget to create the directories data and mp3 in /mnt before you edit your fstab, then just unmount the partitions and remount them to have them in the proper place with read/write permissions for users.

Last edited by Aussie; 05-21-2004 at 07:44 AM.
 
Old 05-21-2004, 08:38 AM   #8
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 45
Quote:
Originally posted by LitlJay
Richmind avenue. Ick. Too urban for me. I do drive down there to go dancing at Wild West sometimes, though. I'll bet you can appreciate the courtesy of Houston drivers. The only rude ones are the ones from up north

J [/B]
i just got my drivers license too .. so, i haven't brought any northerness with me.
and i can even ask - 'what you talkin bout?they're all such nice people.' @ courtesy of houston drivers.

btw, i feel the opposite bout richmond ave - not urban enough!

did the fstab entries work for ya now?
 
Old 05-21-2004, 09:07 AM   #9
LitlJay
Newbie
 
Registered: Apr 2004
Posts: 28

Original Poster
Rep: Reputation: 15
That did it!



That did it. Thanks again, Aussie! You have this habit of coming to my rescue.

Next Q.

I can't share resources on my LAN.

If I click on the Local Net Sharing tab of a directory's properties dialog, it says:

"Error running 'filesharelist'. Check if installed and in $PATH or /usr/sbin."

right in the middle of the dialog box.

I WOULD like to be able to share stuff...

any ideas, anyone?


(now I'm confused, is it the weeds in the cracks in the sidewalk along richmond that makes it rural or something? )

J
 
Old 05-21-2004, 01:41 PM   #10
JJX
Member
 
Registered: Mar 2004
Location: Greece
Distribution: Debian
Posts: 339

Rep: Reputation: 31
To share stuff use "samba"
www.samba.org
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot chown or change permissions Fear Fedora 3 10-26-2005 07:07 PM
How to change permissions? SonoranFun Linux - Newbie 4 11-02-2004 10:10 AM
How do you change a files permissions Charlie Chan Linux - Security 8 10-20-2004 10:19 PM
Change permissions for devices? LizardMan Linux - Hardware 3 07-03-2003 01:32 PM
How Can I Change Permissions monkeymartin Linux - General 1 03-25-2003 12:47 PM


All times are GMT -5. The time now is 01:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration