LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-12-2003, 12:06 PM   #1
dvanaken
LQ Newbie
 
Registered: May 2003
Posts: 8

Rep: Reputation: 0
can't write to VFAT samba share from WIndows


Hey all-

I recently built RH8.0 Linux to serve as my kids' school file server. I mounted the existing VFAT drive to a mountpoint and I can get to it no problem from Windows - BUT I can't write to it unless I'm logged in as root (bad idea in a school).

I haved chmod'd the mount point to 777 and chgrp'd etc but when I remount, the ownership is root and the mode is 0755.

Seems logical that I cannot write to it with that mode setting, but I can;t for the life of me figure out how to open it up for writing.

Oh yes, I have other samba shares with the same smb.conf parms - no difference other than they are ext3 not vfat - they work fine - I need to keep the partition vfat for compatibility with a dual boot system.

Ideas? Thanks

Dale
 
Old 05-12-2003, 12:08 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
not a samba issue i wouldn't think, just mount the share with umask=000 in /etc/fstab, as opposed the the defaults umask=022 (which realtes to 755 rights)
 
Old 05-12-2003, 12:51 PM   #3
dvanaken
LQ Newbie
 
Registered: May 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Chris-

Thanks for the help - I've been over the fstab docs and can't find a way to mount and specify umask (?) Any tips? Thanks

Dale
 
Old 05-13-2003, 06:14 AM   #4
Sutekh
Member
 
Registered: Apr 2002
Location: Melbourne, Australia
Distribution: Gentoo
Posts: 273

Rep: Reputation: 30
I had realy problems with vfat mounts until I used the -o uid=xx option in fstab to change the effective uid of all the files in the mount to be owned by user wuth uid xx

You can use the group id as well which may be more useful (although I export this particular fs with NFS so the gid option did not work for me, uid works perfectly however)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't mount samba share and then write to the share calbazon Linux - Software 8 10-10-2010 02:35 AM
SAMBA - VFAT local mount for all user write access... dolvmin Linux - Software 13 12-21-2006 04:50 PM
Can't write to Samba share from Windows Needlotsahelp Linux - Newbie 3 07-30-2005 09:32 PM
How to share the same folder under VFAT using Fedora and Windows? lnthai2002 Linux - Newbie 2 01-30-2005 12:00 AM
Samba Vfat share problem BjBlaster Linux - General 0 08-02-2001 11:49 AM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration