LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-06-2003, 05:11 PM   #1
jules_fraser
Member
 
Registered: Nov 2003
Location: London, UK
Distribution: Gentoo, RH (and, yes: M$2k)
Posts: 77

Rep: Reputation: 15
Unhappy CLOSED] can't start postfix ./postfix status error


Sorry to bombared you guyz and galz with this ever maddening postfix issue but when I gp to /sbin and do a ./postfix status, I get this error:

[root@frodo sbin]# ./postfix status
./postfix: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

I can't start postfix, pls help

Last edited by jules_fraser; 04-08-2004 at 04:54 PM.
 
Old 12-06-2003, 05:44 PM   #2
jules_fraser
Member
 
Registered: Nov 2003
Location: London, UK
Distribution: Gentoo, RH (and, yes: M$2k)
Posts: 77

Original Poster
Rep: Reputation: 15
I get this error when trying to start:

[root@frodo pub]# postfix start
postfix: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
[root@frodo pub]#
 
Old 12-06-2003, 05:53 PM   #3
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Have you removed some software recently or force installed the Postfix package?
Usually package managers will install all the necessary required components.

There is a quick fix, but it may lead to more problems...
/lib/libssl.so.4 is just a softlink to /lib/libssl.so.0.9.7a
The fix is to make a softlink to /lib/libssl.so.0.9.6b called /lib/libssl.so.4
do cd /lib then ln -s libssl.so.0.9.6b libssl.so.4
This missing link indicates that the newer version of Postfix was installed without using a package manager or was force installed. It is expecting to find a newer 7a version of ssl libraries than the 6b ones installed.
You may still have many more missing files in that case...
 
Old 12-06-2003, 06:33 PM   #4
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Last time I checked your SMTP server was working more or less correctly (only the DNS problem prevented you from getting mail). What have you changed in the last week that is related to OpenSSL or Postfix?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix send mail problem(In RH9, kernal 2.4.20, postfix 2.1.5) minor Linux - General 4 07-11-2005 09:12 PM
postfix won't start mikeghet Linux - Networking 2 05-13-2005 06:07 AM
how to start postfix ? strongzzj Linux - Networking 20 04-29-2005 09:59 PM
can't start/stop Postfix/External mail JM_Fraser Linux - Newbie 5 11-26-2003 02:47 PM
can't start/stop postfix/external mail JM_Fraser Linux - Networking 0 11-25-2003 03:01 PM


All times are GMT -5. The time now is 06:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration