LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-24-2004, 10:26 PM   #1
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Rep: Reputation: 15
Question Can't mount Samba share dir in Windows XP


I just installed Fedora 2 and tried to use Samba to create shared drive between Linux and PC. Below is part of my smb.conf. I have no problem to mount it in linux. Seems everything works in Linux. But when I try to mount it from PC. I put in my password and username in XP but looks to me the password authentification doesn't work. I can find Samba server in the explorer in Microsoft Windows Network. But when I try to access it, it gives me message that

"
\\localhost is not accessible. You might have no permissions to use this network resource. Please contact .......

You were not connected because a duplicate name exists on the network. Please go to System in control panelto change the computer name and try again.

"

I double checked my computer name and didn't find any duplicate name.

Could somebody help me out here? I appreciate it.

David


[file1]
comment = Linux Share Disk
path = /file1
valid users = yw yj
public = no
writable = yes
printable = no
create mask = 0765
 
Old 09-24-2004, 10:29 PM   #2
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
what are the host names of your computers? it looks like you left them as default/localhost and so they're conflicting.
 
Old 09-25-2004, 01:37 AM   #3
Kahless
Member
 
Registered: Jul 2003
Location: Pennsylvainia
Distribution: Slackware / Debian / *Ubuntu / Opensuse / Solaris uname: Brian Cooney
Posts: 503

Rep: Reputation: 30
look threw your admin tools and find the one that lets you re-set up your network


change the name of the linux box to somthing other than localhost.


localhost, or 127.0.0.1, will NEVER work for what your trying to do, because to the computer localhost means "look on this very machine" Just give it a real name and restart the network services (or reboot)
 
Old 09-25-2004, 11:43 PM   #4
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks a lot for your patience to read through my long email. My another dumb question is:

how can I change my local host name? Thanks.

David
 
Old 09-26-2004, 08:29 PM   #5
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
I changed the hostname by editing /etc/sysconf/network and /etc/hosts files. In the hosts file, I put additional line as

192.168.2.3 xxx.david.com xxx

after 127.0.0.1 localhost.localdomain.com localhost

but I still can't connect to samba driver from my PC.

I can see Samba Server (xxx) in my microsoft network but I can't access it. Very confused. By the way, the way I connect all the computer is cable model->router-> all the computer, in which linux box is one of them.

thanks.

David
 
Old 09-26-2004, 09:33 PM   #6
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
add your hostname to the localhost line, e.g.:
Code:
127.0.0.1     <hostname>  localhost.localdomain.com  localhost
 
Old 09-29-2004, 11:37 PM   #7
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
Do you mean don't need to add the line this:

192.168.2.3 xxx.david.com xxx

I tried your config with my additional line config and it doesn't work.

Plus I don't setup any DNS. It is in the same subnet as the other PC, i.e. 192.168.2.*

Can u help me out? Thanks.

David

Quote:
Originally posted by synaptical
add your hostname to the localhost line, e.g.:
Code:
127.0.0.1     <hostname>  localhost.localdomain.com  localhost
 
Old 09-30-2004, 12:13 AM   #8
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
the name can go on the localhost line, and you can also add it with the machine IP, also. example:

#start of file
127.0.0.1 localhost linuxbox linuxbox.mydomain.com

192.168.0.10 linuxbox
192.168.0.11 windozbox

#end of file

i think you should post:

1. your smb.conf
2. the name/IP of the linux computer
3. the name/IP of the windows computer.

from there, maybe we can sort it out.

Last edited by synaptical; 09-30-2004 at 12:14 AM.
 
Old 10-07-2004, 04:22 PM   #9
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
sorry for my late reponse. I was out for a week.

My network is setup using a wireless router. Since I keep my linux on all the time, the linux box IP doesn't change but the PC machines' IPs change every time. It makes hard to config the smb like you said. Just wonder if it's the DNS problem. Should I set up the DNS using Linux box to solve this problem? Thanks.

David
 
Old 10-08-2004, 06:41 AM   #10
nordickiwi
Member
 
Registered: Oct 2004
Location: Stockholm Sweden
Distribution: Fedora 1-8,Familiar v0,7.2, Redhat 9.0, Knoppix, CentOS, Windows 2003,2000,XP,98,95, Exc
Posts: 39

Rep: Reputation: 15
Have you solved your samba probs?
 
Old 10-08-2004, 10:33 PM   #11
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
no. I am still debugging it. confused ... any hints? thanks.
 
Old 10-08-2004, 10:47 PM   #12
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
here is my smb.conf and hosts file.

hosts:

127.0.0.1 localhost linuxbox localhost.localdomain
192.168.2.4 linuxbox

smb.conf


[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = workgroup

# server string is the equivalent of the NT Description field
server string = Samba Server

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
hosts allow = 192.168.1. 192.168.2. 127.

# if you want to automatically load your printer list rather
# than setting them up individually then you'll need this
printcap name = /etc/printcap
load printers = yes
# this tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/%m.log
# all log information in one file
# log file = /var/log/samba/smbd.log

# Put a capping on the size of the log files (in Kb).
max log size = 50

# Security mode. Most people will want user level security. See
# security_level.txt for details.
# Use password server option only with security = server
; password server = <NT-Server-Name>

# Password Level allows matching of _n_ characters of the password for
# all combinations of upper and lower case.
; password level = 8
; username level = 8
# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
; encrypt passwords = yes
; smb passwd file = /etc/samba/smbpasswd

# The following are needed to allow password changing from Windows to
# update the Linux system password also.
# NOTE: Use these with 'encrypt passwords' and 'smb passwd file' above.
# NOTE2: You do NOT need these to allow workstations to change only
# the encrypted SMB passwords. They allow the Unix password
# to be kept in sync with the SMB password.
; unix password sync = Yes
; passwd program = /usr/bin/passwd %u
; passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

# Unix users can map to different SMB User names
; username map = /etc/samba/smbusers
# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
; include = /etc/samba/smb.conf.%m

# Most people will find that this option gives better performance.
# See speed.txt and the manual pages for details
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
; interfaces = 192.168.12.2/24 192.168.13.2/24

# Configure remote browse list synchronisation here
# request announcement to, or browse list sync from:
# a specific host or from / to a whole subnet (see below)
; remote browse sync = 192.168.3.25 192.168.5.255
# Cause this host to announce itself to local subnets here
; remote announce = 192.168.1.255 192.168.2.44
# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
; local master = no

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
; os level = 33

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
; domain master = yes

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
; preferred master = yes

# Enable this if you want Samba to be a domain logon server for
# Windows95 workstations.
; domain logons = yes
# if you enable domain logons then you may want a per-machine or
# per user logon script
# run a specific logon batch file per workstation (machine)
; logon script = %m.bat
# run a specific logon batch file per username
; logon script = %U.bat

# Where to store roving profiles (only for Win95 and WinNT)
# %L substitutes for this servers netbios name, %U is username
# You must uncomment the [Profiles] share below
; logon path = \\%L\Profiles\%U

# All NetBIOS names must be resolved to IP Addresses
# 'Name Resolve Order' allows the named resolution mechanism to be specified
# the default order is "host lmhosts wins bcast". "host" means use the unix
# system gethostbyname() function call that will use either /etc/hosts OR
# DNS or NIS depending on the settings of /etc/host.config, /etc/nsswitch.conf
# and the /etc/resolv.conf file. "host" therefore is system configuration
# dependant. This parameter is most often of use to prevent DNS lookups
# in order to resolve NetBIOS names to IP Addresses. Use with care!
# The example below excludes use of name resolution for machines that are NOT
# on the local network segment
# - OR - are not deliberately to be known via lmhosts or via WINS.
; name resolve order = wins lmhosts bcast

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
; wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
; wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one WINS Server on the network. The default is NO.
; wins proxy = yes

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
dns proxy = no
#============================ Share Definitions ==============================
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /bin/false
username map = /etc/samba/smbusers
password server = None
winbind use default domain = no
[homes]
comment = Home Directories
browseable = no
writeable = yes
[file1]
comment = Linux Share Disk
path = /file1
valid users = user1
public = no
writable = yes
printable = no
create mask = 0765
 
Old 10-08-2004, 11:03 PM   #13
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 46
you need to uncomment the "encrypt passwords = yes" line. not sure at this point what else might or might not be needed, but you first need to do at least that.

for more security, you can also add an invalid users line. a typical one might look something like this:
invalid users = root bin daemon adm sync shutdown halt mail news operator

(p.s. don't forget to restart samba after you change the .conf file. )
 
Old 10-09-2004, 12:23 AM   #14
wycolorado
LQ Newbie
 
Registered: Aug 2003
Posts: 29

Original Poster
Rep: Reputation: 15
thanks a lot for your help. I just tried and it still doesn't work. Does it matter I don't have any DNS service?
I added the users through GUI interface. Should I manually add users instead of through GUI?
thanks a bunch.

David
 
Old 10-09-2004, 12:53 AM   #15
scottman
Member
 
Registered: Jul 2004
Location: USA
Distribution: Slackware, FreeBSD, LFS
Posts: 72

Rep: Reputation: 15
Hey guys,
I looked through that smb.conf, and didn't notice a netbios name entry. It may be that it's working fine through your localhost because it can resolve that to 127.0.0.1 through /etc/hosts, but the other computer is not able to resolve a netbios name to connect to and use your Samba shares. I think server string = <whatever> is just something that will come up like in the "description" field of a share. The netbios name = <whatever> is what comes up as the computer name supporting the shares, and also is needed in order for windows PC's to resolve each other by name, sort of like DNS, but it a much more ineficient way. Try the following to see if that fixes it.

Add this to your smb.conf, you can substitute SAMBASERVER for any computer name you want to use.
Code:
netbios name = SAMBASERVER
From the command line check your smb.conf file for errors.

# testparm

Restart samba. This is the path to the file in slackware, you need to find where it is located on your computer if you dont use slack.

# /etc/rc.d/rc.samba restart

See if that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't mount samba share and then write to the share calbazon Linux - Software 8 10-10-2010 01:35 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 11:34 AM
samba mount to windows share folder lewkh Red Hat 1 03-01-2005 03:31 PM
Cannot mount samba share from windows XP Astro Linux - Software 2 12-18-2004 11:26 AM
can't mount to windows share folder using samba yawhum80 Linux - Software 4 10-24-2003 11:52 PM


All times are GMT -5. The time now is 06:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration