LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-29-2003, 03:04 PM   #1
RandyHeise
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 4

Rep: Reputation: 0
Can't logon via FTP


Newbie with New Red Hat 9 install. During Install requested FTP server setup. Can see vsftpd and xinetd start in boot seq. Can't login remotely (Win2K machine). Do receive Login prompt ... respond with UN/PW that is valid on FTP machine ... not accepted... (local_enable=yes in vsftpd.conf). Anonymous not accepted even though ... anonymous_enable=yes in vsftpd.conf. Don't see various files like ftpaccess, ftphosts, etc. anywhere??? Where should vsftpd.conf be? Almost seems like vsftpd.conf is not being used? Very confused! Becoming irrational!! Misco$oft starting to look good! Please Heeeelp!
 
Old 08-29-2003, 03:09 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Welcom to LQ.

Make sure you are loggin in as a user and not root. Can you get a connection to the server from the server itself?:
ftp localhost

If you still have problems can you post your vsftpd.conf file.
 
Old 08-29-2003, 03:23 PM   #3
RandyHeise
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 4

Original Poster
Rep: Reputation: 0
Attempts to login from the server (not root!) return:

500 OOPS: str_getpwnam: ftpsecure

Result is the same in gFTP as well as a terminal window!
 
Old 08-29-2003, 03:31 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Can you post vsftpd.conf
 
Old 08-29-2003, 05:11 PM   #5
RandyHeise
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 4

Original Poster
Rep: Reputation: 0
File is located in etc/vsftpd/

# Example config file /etc/vsftpd.conf

anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=grandall
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner=Welcome to The High Desert Museum FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
ls_recurse_enable=YES

pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES
 
Old 08-29-2003, 07:34 PM   #6
nonamenobody
Member
 
Registered: Oct 2002
Posts: 138

Rep: Reputation: 22
In Red Hat 9, vsftpd should work 'out of the box' for both anonymous download and local users (i.e. Linux system users) download/upload (it did for me). It should work fine so long as you:
A. Are using a real Linux user id and password (or 'anonymous' and an email address), with the correct case.
B. Haven't edited any of the files which came with vsftpd ('rpm -ql vsftpd' will list the files).
C. Have the FTP server running ('/etc/rc.d/init.d/vsftpd status' as root will tell you).
D. Don't have a firewall running which is configured to block you FTP server.

You may want to check '/var/log/vsftpd.log' or you 'dmesg' to see if their are any errors.
 
Old 08-29-2003, 07:55 PM   #7
RandyHeise
LQ Newbie
 
Registered: Aug 2003
Distribution: Red Hat 9
Posts: 4

Original Poster
Rep: Reputation: 0
A. Yes
B. No edits
C. Here may be the problem ... response is

500: OOPS: vsftpd: Cannot open specified config file.

D. I have a Firewall between my Micro$oft Exchange/main file server and the Internet, but the machine I'm trying to access is a seperate (local IP Address) IntRAnet Apache Web server. My assumption (Yah, Yah, I know!!) was that the Firewall was blocking access from the internet to the main file server only. Am I wrong here?

E. Logs are empty
 
Old 08-30-2003, 02:00 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
What are the permissions on the config file? Have you tried restarting the service:
service vsftpd restart
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp logon lag astroboiii Linux - Software 3 12-02-2005 03:02 PM
New users can't logon to FTP server... drzigman Linux - General 4 06-13-2005 04:50 AM
I can not logon to my FTP. . . Spreegem Debian 1 06-04-2005 05:43 PM
Logon roban Linux - Newbie 7 07-26-2003 12:10 PM
logon stuck Linux - Newbie 2 11-20-2001 09:10 AM


All times are GMT -5. The time now is 06:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration