LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-26-2005, 07:59 PM   #1
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Rep: Reputation: 0
Can't log in pure-ftpd server with IE, but can with command prompt.


Hi,

I'm currently running a pure-ftpd server on my computer running Debian Linux. I did it according to an article titled: "Virtual Hosting With PureFTPd And MySQL (Incl. Quota And Bandwidth Management)", which I can't post because i don't have 5 posts yet =p. It described how to use a MySQL database for virtual accounts, and its running pure-ftpd as a standalone (for more information search the article name on google).

Well, I can log in with a command prompt FTP client just fine, and everything seems to work. When I try to login with clients such as FlashFXP, or Internet Explorer, I get the prompt to log into my account. After logging in, it waits for a long time "Getting contents of folder", and then I get an error message "An error occured opening that folder on the FTP server. Make sure you have permission to acccess that folder. Details: The operation timed out."

Is there any way to fix this?

Thanks in advance!
 
Old 11-26-2005, 08:40 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Are you using an actual account of anonymous account. What exactly are you typing into the address bar in IE? Is FTP enabled in your IE settings?

If you have an actual account your using to connect, try something like this in the address bar:

http://usernameassword@ftp.server.com
 
Old 11-26-2005, 08:58 PM   #3
ImpactDNI
Member
 
Registered: Jun 2004
Posts: 124

Rep: Reputation: 15
I run a server using PureFTPD, theres a commandline option you need to have set, IE is a broken FTP client, but theres a commandline option to accept these "broken" clients...
don't have my setup in front of me, but look through the docs... its in there...
 
Old 11-27-2005, 07:42 PM   #4
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Oh, ok. That's what I thought. I had trouble setting the command line option, though. I tried

/etc/init.d/pure-ftpd-mysql start -b -D

But that didn't seem to affect anything (I'm kind of new with linux). How would I enable these command line options?

Thanks!
 
Old 11-27-2005, 11:04 PM   #5
ImpactDNI
Member
 
Registered: Jun 2004
Posts: 124

Rep: Reputation: 15
Hmmm, the -b should do it.. what kind of errors are showing in your log?
 
Old 11-27-2005, 11:25 PM   #6
T.Hsu
Member
 
Registered: Jan 2005
Posts: 178

Rep: Reputation: 31
It may be caused by the different connection mode (passive vs active).

But I can't recall exactly which one using the passive mode by default.

Please refer to the following article:

http://slacksite.com/other/ftp.html
 
Old 11-27-2005, 11:42 PM   #7
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Well, when I try to start up pure-ftpd with the -b option, all I see is this:

Code:
~# /etc/init.d/pure-ftpd-mysql start -b
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -O clf:/var/log/pure-ftpd/transfer.log -B
Am I supposed to see the -b somewhere in there? Because the -B at the end is something different...
 
Old 11-27-2005, 11:47 PM   #8
T.Hsu
Member
 
Registered: Jan 2005
Posts: 178

Rep: Reputation: 31
pure-ftpd -b directly;

or modify the pure-ftpd-mysql script, add the -b switch.
 
Old 11-28-2005, 01:19 AM   #9
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Umm, when I try to run it directly, it tells me
Unable to start a standalone server: Address already in use
And I'm having some trouble editing the script. Can anybody help?

Thanks!
 
Old 11-28-2005, 01:41 AM   #10
T.Hsu
Member
 
Registered: Jan 2005
Posts: 178

Rep: Reputation: 31
Server is already running? Try stop it first.

Code:
/etc/init.d/pure-ftpd-mysql stop
Then,

Code:
/usr/sbin/pure-ftpd-mysql -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -E -O clf:/var/log/pure-ftpd/transfer.log -B -b
 
Old 11-28-2005, 01:54 AM   #11
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, I tried this, but after I entered the command you gave me, it excecuted it without any problems (but it didn't return anything either). But, when I tried to log in, same thing happened =(.
Also, when I tried to run the command you gave me twice, without stopping the server, it didn't give me any errors like the one it gave me before. When I stopped the server, then tried to run "Pure-ftpd-mysql -b" by itself, it stil gave me the "Unable to start standalone server" message.

Any ideas?
 
Old 11-28-2005, 02:12 AM   #12
T.Hsu
Member
 
Registered: Jan 2005
Posts: 178

Rep: Reputation: 31
Do you check the passive actvie thing.

I'm now under windows XP and check the IE setting, found it using passive mode by default, and the ftp command use port mode automatically. It's the difference.
 
Old 11-28-2005, 08:59 PM   #13
number9
Member
 
Registered: Dec 2003
Location: Fresno
Distribution: Gentoo Ricer
Posts: 85

Rep: Reputation: 15
Yeah, look into your Pure Config file, this sounds like a Passive/Active setting issue.
 
Old 11-28-2005, 09:23 PM   #14
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Umm, when I use FlashFXP, and turn Passive mode off, it still doesn't work ='(.
I think it's because of the -b. I'm new to linux, and I think the problem is that I can't get the -b option to turn on.

Has anybody used pure-ftpd-mysql before and fixed this problem?

Again, thanks for all the help.
 
Old 11-30-2005, 01:32 AM   #15
Yonderknight
LQ Newbie
 
Registered: Nov 2005
Posts: 10

Original Poster
Rep: Reputation: 0
Ok, I just realized, running any of the init.d scripts doesn't seem to be doing anything to pure-ftpd. Fore example, if I try typing

/etc/init.d/pure-ftpd-mysql stop

It says: "Stopping ftp server: pure-ftpd", but when I try to connect to it, I can still log into my ftp account! Like I said, I'm pretty new, but could this be because I'm running the server in standalone mode? How do I switch to the other mode (inetd I think)?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Forward to another ftp-server with pure-ftpd didi86 Linux - Software 0 12-20-2004 01:55 PM
pure-ftpd log analyzer dominant Linux - Software 2 10-05-2004 08:32 AM
pure ftpd log files Tinku Linux - Software 8 10-04-2004 02:07 AM
Set up ftp server with pure-ftpd aeruzcar Linux - Software 7 04-15-2004 08:43 AM
Problems using Pure-FTPd server... mike_hurley Linux - Networking 1 11-12-2003 01:58 PM


All times are GMT -5. The time now is 07:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration