LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-26-2005, 03:43 PM   #1
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Rep: Reputation: 0
Can't get server booted with raid, get "grub" error


Ok,

So I install fedora core 3, after the install i get "grub" error.

hmm chrooted the install to /mnt/sysimage and it stil says "GRUB"..

So if i got into the shell, and type grub, i go into grub!. But im 100% lost..

Iv looked at docs etc, cant make sence of it... tbh.


- S
 
Old 01-26-2005, 04:13 PM   #2
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Original Poster
Rep: Reputation: 0
i chrooted linux then loaded grub up in shell but i can load the kernel now because i dont have a folder called "vmlinuz".

When I boot now I get this:

"Grub Loading stage1.5.
"Grub loading, please wait....
"error 2"

The error means "selected disk does not exist"

So what?? I got to load kernel, but i can because I cant find vmlinuz!!!

- S
 
Old 01-26-2005, 04:18 PM   #3
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
post contents of the file /boot/grub/menu.conf.
and the file names of the files in /boot

seems your kernel's file nam is different to what is specified in the grub's config files.

also, what is the partiton number of your root partiton (and if you have one, boot partiton)
 
Old 01-26-2005, 04:25 PM   #4
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Original Poster
Rep: Reputation: 0
erk.

I cant find the boot folder... anywhere!!

- S
 
Old 01-26-2005, 10:06 PM   #5
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
cd /boot
did you delete it ?
is boot a seperate unmounted partiton ?
 
Old 01-27-2005, 04:11 AM   #6
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Original Poster
Rep: Reputation: 0
could be in another partition"" I thought of that ....


iv done cd boot. Not there..

:|


- S
 
Old 01-27-2005, 06:17 AM   #7
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
run cfdisk /dev/hda (and on any other hard disks)
tell us what it says about your partiton tables ?

also, post the contents of your /etc/fstab file.

try "mount /boot" then look in your boot foleer again.
 
Old 01-27-2005, 02:05 PM   #8
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Hey,


I ended up installing linux on normal ide.

But i still need raid card working. I got this RAID card .


But I have this mobo
EP-8kra2+


Which is the best to put/get raid on?. I guess the PCI card...

But its a img file and only for linux 9.0 I got fedora core 3, what should I do?

- S
 
Old 01-30-2005, 05:11 AM   #9
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Original Poster
Rep: Reputation: 0
bump?

- s
 
Old 02-09-2005, 06:53 PM   #10
Sc0rian
LQ Newbie
 
Registered: Sep 2004
Posts: 10

Original Poster
Rep: Reputation: 0
bleh im still suck on this error;(


- S
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4: "GRUB Loading Stage2... read error" at startup Kropotkin Fedora 2 12-01-2005 06:29 PM
Suse 9.2 "GRUB Hard Disk Error" Help! fxafelix Linux - Newbie 3 02-22-2005 06:37 AM
GRUB bootloader spits out "GRUB hard disk error" Crampedson Linux - Software 2 01-26-2005 07:34 PM
Error at boot after GRUB : last message "apm:BIOS version 1.2 flags 0x03" OmniXBro Mandriva 2 04-10-2004 01:34 AM
Swapon error: "device busy" during RAID install of 9.2 Seekadvice Mandriva 0 02-19-2004 07:07 PM


All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration