LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-09-2003, 03:58 PM   #1
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Rep: Reputation: 15
Can't get Internet Explorer 6 to run!


This is what happens:

[shadow@host shadow]$ cd fake_c/Program*/Internet*
[shadow@host Internet Explorer]$ wine IEXPLORE.EXE
err:shell:ReadCabinetState Initializing shell cabinet settings
err:rebar:REBAR_WindowProc unknown msg 200b wp=00000000 lp=71180f00
fixme:toolbar:TOOLBAR_CheckStyle [0x10029] TBSTYLE_REGISTERDROP not implemented
fixme:toolbar:TOOLBAR_CheckStyle [0x10029] TBSTYLE_REGISTERDROP not implemented
fixme:shell:NTSHChangeNotifyRegister (0x10029,0x00008003,0x00008000,0x0000c065,0x00000001,0x407a0f04):semi stub.
err:toolbar:ToolbarWindowProc unknown msg 045d wp=00000000 lp=407a0f60
fixme:toolbar:TOOLBAR_CheckStyle [0x10029] TBSTYLE_REGISTERDROP not implemented
fixme:toolbar:TOOLBAR_SetExtendedStyle Extended style not implemented TBSTYLE_EX_HIDECLIPPEDBUTTONS
err:toolbar:ToolbarWindowProc unknown msg 0464 wp=00000001 lp=00000000
fixme:win:GetProcessWindowStation (void): stub

( ^--- It shows tons of lines of this for a while... )


err:toolbar:ToolbarWindowProc unknown msg 045d wp=00000000 lp=407a0f7c
fixme:win:GetProcessWindowStation (void): stub

( ^--- Shows it a bit more times... )


fixme:shell:NTSHChangeNotifyRegister (0x10038,0x00008003,0x0c02b7ff,0x0000c065,0x00000001,0x407a0f44):semi stub.
fixme:win:GetProcessWindowStation (void): stub

( ^--- Then it shows tons of lines of this yet again... )


fixme:process:CreateProcessA (C:\windows\system\DW15.EXE,...): NORMAL_PRIORITY_CLASS ignored
fixme:process:CreateProcessA (C:\windows\system\DW15.EXE,...): CREATE_DEFAULT_ERROR_MODE ignored
wine: Unhandled exception (thread 0009), starting debugger...
WineDbg starting on pid 8
Loaded debug information from ELF 'wine' ((nil))
Breakpoint 1 at 0x4000af50 (_end+0x40097e4)
Loaded debug information from ELF '/usr/local/lib/libntdll.dll.so' (0x40024000)
Loaded debug information from ELF '/usr/local/lib/libwine.so.1' (0x400ed000)
Loaded debug information from ELF '/usr/local/lib/libwine_unicode.so.1' (0x40104000)
No debug information in ELF '/lib/i686/libc.so.6' (0x401f6000)
No debug information in ELF '/lib/i686/libm.so.6' (0x4032a000)
No debug information in ELF '/lib/libdl.so.2' (0x4034c000)
Loaded debug information from ELF '/lib/ld-linux.so.2' (0x40000000)
Loaded debug information from ELF '/usr/local/lib/wine/kernel32.dll.so' (0x4034f000)
No debug information in ELF '/lib/libnss_files.so.2' (0x40457000)
Loaded debug information from ELF '/usr/local/lib/wine/msvcrt.dll.so' (0x407a3000)
Loaded debug information from ELF '/usr/local/lib/wine/user32.dll.so' (0x407e9000)
Loaded debug information from ELF '/usr/local/lib/wine/gdi32.dll.so' (0x4091e000)
Loaded debug information from ELF '/usr/local/lib/wine/advapi32.dll.so' (0x40999000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x409c6000)
No debug information in ELF '/lib/libz.so.1' (0x40581000)
Loaded debug information from ELF '/usr/local/lib/wine/x11drv.dll.so' (0x40a14000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x40463000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40a81000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40a98000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40aa6000)
No debug information in ELF '/usr/lib/libGL.so.1' (0x40b85000)
No debug information in ELF '/usr/lib/libGLcore.so.1' (0x40bee000)
No debug information in ELF '/usr/X11R6/lib/libXcursor.so.1' (0x41163000)
No debug information in ELF '/usr/X11R6/lib/libXrender.so.1' (0x4116c000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2' (0x40014000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0x41174000)
No debug information in ELF '/usr/lib/gconv/ISO8859-1.so' (0x40018000)
Loaded debug information from ELF '/usr/local/lib/wine/comctl32.dll.so' (0x41192000)
Loaded debug information from ELF '/usr/local/lib/wine/shell32.dll.so' (0x41340000)
Loaded debug information from ELF '/usr/local/lib/wine/version.dll.so' (0x4144a000)
Loaded debug information from ELF '/usr/local/lib/wine/lz32.dll.so' (0x41464000)
Loaded debug information from ELF '/usr/local/lib/wine/wsock32.dll.so' (0x41fb1000)
Loaded debug information from ELF '/usr/local/lib/wine/ws2_32.dll.so' (0x41fce000)
Loaded debug information from ELF '/usr/local/lib/wine/iphlpapi.dll.so' (0x41ff5000)
No debug information in ELF '/lib/libnss_nisplus.so.2' (0x41481000)
No debug information in ELF '/lib/libnsl.so.1' (0x42040000)
No debug information in ELF '/lib/libnss_nis.so.2' (0x4001a000)
No debug information in ELF '/lib/libnss_dns.so.2' (0x4046c000)
No debug information in ELF '/lib/libresolv.so.2' (0x42054000)
No debug information in 32bit DLL 'C:\Program Files\Internet Explorer\IEXPLORE.EXE' (0x400000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NTDLL.DLL' (0x40050000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\KERNEL32.DLL' (0x40380000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSVCRT.DLL' (0x407c0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x409b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x40930000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40810000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHLWAPI.DLL' (0x70bd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCVW.DLL' (0x71000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x40a30000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x411a0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x65f00000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x41360000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSEUI.DLL' (0x71160000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSELC.DLL' (0x718e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCLC.DLL' (0x71840000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\RPCRT4.DLL' (0x70100000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\LZ32.DLL' (0x41470000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\VERSION.DLL' (0x41450000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\URLMON.DLL' (0x702b0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WININET.DLL' (0x63000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLEAUT32.DLL' (0x65340000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MLANG.DLL' (0x70440000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IPHLPAPI.DLL' (0x42000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WS2_32.DLL' (0x41fe0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WSOCK32.DLL' (0x41fc0000)
Unhandled exception: page fault on write access to 0x0000002c in 32-bit code (0x6300ca81).
In 32-bit mode.
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:008f GS:004f
EIP:6300ca81 ESP:4079bf0c EBP:4079bf30 EFLAGS:00210212( R- 00 I -A- 1 )
EAX:404ea594 EBX:0000017c ECX:4079bdb0 EDX:00000000
ESI:00000000 EDI:40506eb0
Stack dump:
0x4079bf0c (_end+0x3713ec): 00000002 40506eb0 00000000 404ea558
0x4079bf1c (_end+0x3713fc): 00000e5d 404ea594 00000000 405069d8
0x4079bf2c (_end+0x37140c): 00000000 4079bf5c 6300c9b8 0000ea60
0x4079bf3c (_end+0x37141c): 00000005 404ea558 4079bf54 40506b80
0x4079bf4c (_end+0x37142c): 405069d8 00000000 00000000 00000000
0x4079bf5c (_end+0x37143c): 40506eb0 6300c595 0000ea60 00000005
0x4079bf6c (_end+0x37144c):

0011: sel=008f base=400e39a0 limit=00000fff 32-bit rw-
Backtrace:
=>0 0x6300ca81 (WININET.DLL.UnlockUrlCacheEntryStream+0xbff in WININET.DLL) (ebp=4079bf30)
1 0x6300c9b8 (WININET.DLL.UnlockUrlCacheEntryStream+0xb36 in WININET.DLL) (ebp=4079bf5c)
2 0x6300c595 (WININET.DLL.UnlockUrlCacheEntryStream+0x713 in WININET.DLL) (ebp=40506eb0)
3 0x40470074 (_end+0x45554) (ebp=40470038)
4 0x45455246 (_end+0x34432c2) (ebp=00000001)

0x6300ca81 (WININET.DLL.UnlockUrlCacheEntryStream+0xbff in WININET.DLL): movl %ebx,0x2c(%edx)
Modules:
Address Module Name
0x00400000-00418800 (PE) C:\Program Files\Internet Explorer\IEXPLORE.EXE
0x40050000-40052000 (PE) C:\WINDOWS\SYSTEM\NTDLL.DLL
0x40380000-40382000 (PE) C:\WINDOWS\SYSTEM\KERNEL32.DLL
0x407c0000-407c2000 (PE) C:\WINDOWS\SYSTEM\MSVCRT.DLL
0x40810000-40812000 (PE) C:\WINDOWS\SYSTEM\USER32.DLL
0x40930000-40932000 (PE) C:\WINDOWS\SYSTEM\GDI32.DLL
0x409b0000-409b2000 (PE) C:\WINDOWS\SYSTEM\ADVAPI32.DLL
0x40a30000-40a32000 (PE) C:\WINDOWS\SYSTEM\X11DRV.DLL
0x411a0000-411a2000 (PE) C:\WINDOWS\SYSTEM\COMCTL32.DLL
0x41360000-41362000 (PE) C:\WINDOWS\SYSTEM\SHELL32.DLL
0x41450000-41452000 (PE) C:\WINDOWS\SYSTEM\VERSION.DLL
0x41470000-41472000 (PE) C:\WINDOWS\SYSTEM\LZ32.DLL
0x41fc0000-41fc2000 (PE) C:\WINDOWS\SYSTEM\WSOCK32.DLL
0x41fe0000-41fe2000 (PE) C:\WINDOWS\SYSTEM\WS2_32.DLL
0x42000000-42002000 (PE) C:\WINDOWS\SYSTEM\IPHLPAPI.DLL
0x63000000-6304bc00 (PE) C:\WINDOWS\SYSTEM\WININET.DLL
0x65340000-653d2000 (PE) C:\WINDOWS\SYSTEM\OLEAUT32.DLL
0x65f00000-65fc1800 (PE) C:\WINDOWS\SYSTEM\OLE32.DLL
0x70100000-70153000 (PE) C:\WINDOWS\SYSTEM\RPCRT4.DLL
0x702b0000-70329200 (PE) C:\WINDOWS\SYSTEM\URLMON.DLL
0x70440000-704cf000 (PE) C:\WINDOWS\SYSTEM\MLANG.DLL
0x70bd0000-70c34600 (PE) C:\WINDOWS\SYSTEM\SHLWAPI.DLL
0x71000000-71149000 (PE) C:\WINDOWS\SYSTEM\SHDOCVW.DLL
0x71160000-7125ce00 (PE) C:\WINDOWS\SYSTEM\BROWSEUI.DLL
0x71840000-718c3200 (PE) C:\WINDOWS\SYSTEM\SHDOCLC.DLL
0x718e0000-718f1200 (PE) C:\WINDOWS\SYSTEM\BROWSELC.DLL
Threads:
process tid prio
00000008 (D) C:\Program Files\Internet Explorer\IEXPLORE.EXE
0000000a 0
00000009 1 <==
WineDbg terminated on pid 8




It looks like it's having some window drawing problems or something, but I'm not too sure...

What's going on? And how can I fix this???

Last edited by SSJ-sHaDoW; 10-09-2003 at 03:59 PM.
 
Old 10-09-2003, 04:06 PM   #2
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
I am very confused as to why you would need to run Internet Explorer with Wine.

If I'm not getting something, please enlighten me....
 
Old 10-09-2003, 04:12 PM   #3
EyesOnly
Member
 
Registered: Aug 2003
Location: The Netherlands
Distribution: SlackWare
Posts: 202

Rep: Reputation: 30
I'm no expert on this, but I do use wine miself. First of all, but you probably already know that, wine is in development. It is defenitly not finished.

Internet explorer 6 is a pretty complex piece of software, and also pretty new. In fact it would suprise me if you would get it working.

The fixme messages in your output inidicate that the software is calling functions which aren't implemented yet. This could be the problem.

On an other matter, why are you trying to use IE on linux? there are far better browsers available for linux(and windows too..)
 
Old 10-09-2003, 04:13 PM   #4
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
I have to have Internet Explorer 6 for some other Windows programs to work (like Half-Life, Paint Shop Pro, etc.)... and ie6 should at least be openable (according to tutorials).

The problem might actually be an all-around wine problem... But I'm sure I configured it properly... and others have gotten ie6 to work, so...

*confused*

Last edited by SSJ-sHaDoW; 10-09-2003 at 04:15 PM.
 
Old 10-09-2003, 04:31 PM   #5
EyesOnly
Member
 
Registered: Aug 2003
Location: The Netherlands
Distribution: SlackWare
Posts: 202

Rep: Reputation: 30
Quote:
I have to have Internet Explorer 6 for some other Windows programs to work
why's that? what part of IE are these programs using what other browsers can't provide?
 
Old 10-09-2003, 04:44 PM   #6
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
Quote:
what part of IE are these programs using what other browsers can't provide?
I am wondering the same thing. I've not heard of anything like that.
 
Old 10-09-2003, 04:47 PM   #7
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
It's probably the DLLs that come with it that other programs use (I'm guessing).

Oh well, it's not that big of a deal if it doesn't work. Well, I don't think it is anyway... I HOPE that the other programs just need ie6 to at least be installed. Hopefully I can get Half-Life working now...

*goes to try*
 
Old 10-09-2003, 05:14 PM   #8
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
Ive never tried to install IE6 with wine, so I dont know if that would even work at all. But I do know that the crossover office emulator runs it perfectly. If you really want it in linux, then I would suggest looking into crossover.
 
Old 10-09-2003, 05:26 PM   #9
SSJ-sHaDoW
LQ Newbie
 
Registered: Oct 2003
Location: Canada
Distribution: Mandrake 9.1
Posts: 29

Original Poster
Rep: Reputation: 15
Well then... Half-Life starts installing up to about 35% complete, then crashes. Then it displays info similar to the stuff I posted earlier...

It's probably just something not set up right with wine... *sigh* but I don't feel like scouring through files right now...

Does anyone know what might be wrong?

Oh, about those functions not implemented... are they a part of Internet Explorer or wine?
 
Old 10-09-2003, 05:32 PM   #10
EyesOnly
Member
 
Registered: Aug 2003
Location: The Netherlands
Distribution: SlackWare
Posts: 202

Rep: Reputation: 30
If you want to run games, WineX is the way to go. You can run some games whit wine, but DirectX support is limited(most windows games use this).
StarCraft for example runs perfect whit wine, but Warcraft 3 doesn't even start.

and these unimplemented functions are part of wine. Wine doesn't support the function the windowz program was calling that moment.
 
Old 10-09-2003, 05:36 PM   #11
pesho_p
Member
 
Registered: Oct 2002
Location: 42 42' N, 23 19' E
Distribution: Slackware 8.1
Posts: 77

Rep: Reputation: 15
Probably the file listed in following thread will be helpful for you - http://www.dropline.net/forums/viewtopic.php?t=1464:
Quote:
If you want ie6sp1 on linux with the latest wine (20030911) you should download this package.

I've tested it and it works!
I can' t guarantee you nothing, however you can try at least. Sounds promising don't you think so?
 
Old 10-09-2003, 08:08 PM   #12
nrunge
Member
 
Registered: Oct 2003
Distribution: Debian Woody (2.4.22)
Posts: 182

Rep: Reputation: 30
I see the necessity here but I have to say that the day I see IE6 running in linux I might just have a coronary.
 
Old 10-10-2003, 12:44 AM   #13
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
you may want to have a look at this page, as there you can also read and ask questions regarding wine and other appz e.g. ie
wine hq internet explorer
 
Old 10-10-2003, 09:09 AM   #14
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 37
Quote:
I see the necessity here but I have to say that the day I see IE6 running in linux I might just have a coronary.
And the last thing you'll see before passing out see will be IE6 running better than it does on Windows, no doubt.
 
Old 10-10-2003, 09:46 AM   #15
tcaptain
LQ Addict
 
Registered: Jul 2002
Location: Montreal
Distribution: Gentoo 2004 from stage 1 baby!
Posts: 1,403

Rep: Reputation: 45
Another link you might want to see:

www.frankscorner.org

it has TONS of howtos for wine...and specifically, it has one for IE6.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can Internet Explorer run on Linux? mpyusko Linux - Software 16 09-22-2005 03:28 PM
can VBScript only run in Internet Explorer? servnov Programming 11 10-19-2004 03:29 PM
Internet Explorer vs. Other Browsers (Internet Standards) smaida Linux - General 6 10-11-2004 04:27 AM
Internet Explorer only internet page?? jimdaworm Linux - Software 9 08-08-2004 02:26 PM
How to get internet explorer 6 to run on wine on mandrake 9.2 dabump Linux - Software 5 05-02-2004 02:36 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration