LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-11-2002, 11:38 AM   #1
lhoff
Member
 
Registered: Jun 2001
Location: Chicago
Distribution: Mandrake 10.0 Official
Posts: 181

Rep: Reputation: 30
can't compile with qt3


I'm trying to build a program (kxmleditor) from src.rpm using rpm --rebuild. The process gets as far as "Checking for Qt..." then fails. Below is the relevant (I hope!) portion of my config.log.


Quote:
configure:19179: checking for Qt
configure: 19241: /usr/lib/qt3/lib/include/qstyle.h
configure: 19241: /usr/lib/qt3/lib/qstyle.h
configure: 19241: /usr/lib/qt3/include/qstyle.h
taking that
tried NO
tried /usr/lib/qt3/lib/lib
configure:19346: rm -rf SunWS_cache; g++ -o conftest -O2 -O2 -march=i686 -fno-exceptions -fno-check-new -I/usr/lib/qt3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT -D_REENTRANT -L/usr/lib/qt3/lib -L/usr/X11R6/lib conftest.cc -lqt-mt -lpng -lz -lm -ljpeg -ldl -lXext -lX11 -lSM -lICE -lresolv -lpthread 1>&5
/root/tmp/ccVUhtn4.o: In function `main':
/root/tmp/ccVUhtn4.o(.text+0x8): undefined reference to `QString::null'
/root/tmp/ccVUhtn4.o(.text+0xd): undefined reference to `QStyleFactory::create(QString const &)'
/root/tmp/ccVUhtn4.o(.text+0x1a): undefined reference to `QCursor::QCursor(int)'
/root/tmp/ccVUhtn4.o(.text+0x24): undefined reference to `QCursor::~QCursor(void)'
collect2: ld returned 1 exit status
configure:19349: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 302)
#error 1
#endif

int main() {
(void)QStyleFactory::create(QString::null);
QCursor c(Qt::WhatsThisCursor);
return 0;
}
configure:19388: error: Qt (>= Qt 3.0.2) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
I have /usr/lib/qt3/lib in my PATH, and also setup as $QTDIR. The configure process seems to find Qt (if I'm interpreting PID 19241 correctly...); I can't see why this is failing.

I'm using KDE 3.0.4 stable. Qt is 3.0.5. Please help! Thanks!

Last edited by lhoff; 11-11-2002 at 11:52 AM.
 
Old 01-07-2003, 07:51 AM   #2
vladkrack
Member
 
Registered: Oct 2002
Location: Curitiba - Brazil
Distribution: Conectiva
Posts: 334

Rep: Reputation: 30
The error is that the program can't find a function, because something change from, a version to another, try to compile with the exact same version of kde and qt.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Qt3 SpEcIeS Suse/Novell 3 04-22-2005 07:28 PM
Compile error--Qt3 not found David the H. Linux - General 4 09-29-2004 02:59 PM
KDE (QT3) apps compile!!! uniQ LinuxQuestions.org Member Success Stories 0 03-03-2004 12:41 PM
About qt3... LI-6Y LUCY Programming 3 08-28-2003 10:45 AM
Help Qt3 Zion Linux - General 15 07-22-2002 07:27 AM


All times are GMT -5. The time now is 09:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration