LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-27-2003, 04:12 PM   #1
guc
Member
 
Registered: Jul 2003
Posts: 34

Rep: Reputation: 15
building proftpd


hello there


i'm using slackware 9, recent installed


i untarred the proftpd-tarball and i did the


./configure --enable-shadow

wich went without errors

then i did a

make

next thing i needed to do what a check

so i loaded proftpd -c basic.conf

and did

ftp localhost

then i got "connection refused"



i don't know what i did wrong or what to change to get it accepted...


plz some help


thx in advance


( i'm following the guide LinuxQuestions.org > LinuxAnswers > From beginning to end: ProFTPD )
 
Old 07-27-2003, 08:00 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
did you try using the default config /etc/proftpd.conf .. or is the one you are using the same one?
 
Old 07-28-2003, 04:58 AM   #3
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
wel i haven't checked if its the same


but i did try it yes
 
Old 07-28-2003, 05:43 AM   #4
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
wel i checked my proftpd.log in /var/log/

it says


error opening scoreboard: No such file or directory



so its something with the scoreboard


only i dunno what to do about it
 
Old 07-28-2003, 05:49 AM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
http://proftpd.linux.co.uk/localsite...SCOREBOARDFILE



Looks like you should either set it in your conf file (if it's set change it's location to the correct one) OR create it at the specified location in the conf file.

Cool
 
Old 07-28-2003, 06:59 AM   #6
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
wel i already fixed the scoreboard issue before you replied

by making the dir it's supposed to be in, then on startup it gets created


next i erased my log and launched it again then it gave an error beceause the user "ftp" was still in /etc/ftpuser

so i tagged him with #


launched the server again, log gave no error, so i did ftp localhost

but connection still refused


so i checked log again

now out of nothing there was /etc/shutmsg
which i checked for its existance before, anyway i just removed it again


so i killed the server again cleaned my log once more, relaunched the server and tryied to ftp localhost again


still connection refused

all the log says now is


PorFTPD 1.2.9rc1 (dev$ (devel) (built blablabla...) standalone mode STARTUP



so now i'm back here asking what there is yet to be done
 
Old 07-28-2003, 07:13 AM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Have you given inetd mode a shot yet?

Also, have you made sure there are no other applications using FTP on your system
rpm -qa | grep ftp

Oh wait, I see slackware now...

pkgtool

And browse the files.

I don't know why you'd mysteriously get a /etc/shutmsg like that, that's why I'm suspecting another FTP program running?
netstat -a

Cool
 
Old 07-28-2003, 07:19 AM   #8
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
wel there are surely no other ftp programs running since its a new fresh install and i've been using ps aux | grep ftp constantly to kill my server and there were no other processes


i haven't tried inetd no


and the /etc/shutmsg


probably got there that late beceause the ftpserver made it when if finally ran without errors ....





so accept from trying with inetd ( but i want to run it standalon ) i don't know what else to try
 
Old 07-28-2003, 07:38 AM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Can you post up the contents of the conf file you are using? Have you given a shot at any of the others?

Cool
 
Old 07-28-2003, 07:48 AM   #10
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
i changed the the line in the proftpd.conf an inetd.conf and did a

kill -HUP inetdpid

then i relaunched my ftpserver or at least tried ....



i get afther typing ./proftpd -c /etc/proftpd.conf

fatal: Socket operation on non-socket
(Running form command line? Use 'ServerType standalone' in config file ! )


so inetd isn't working at all
 
Old 07-28-2003, 07:55 AM   #11
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
now that i'm running on inetd i thought of trying again with basic.conf just to try

if it would work, so i lauched the server with basic.conf, then after it i checked the basic.conf and i saw its standalone

but i tried ftp localhost anyway

now surprisingly i get

Connected to localhost
couple a seconds later it says
421 Service not abailable, remote server has closed connection



so i don't know what happend here, i set up inetd for ftpaccess but i load the server with a standalone config

and now it didn't refuse the connection ...
 
Old 07-28-2003, 08:22 AM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
If you launch proftpd from the command line:
proftpd -c /wherever/something.conf
Then that's standalone mode. If you launch it via inetd, you don't do anything but send a HUP to inetd. However you will also (if you haven't done a make install yet) have to edit the entry in inetd.conf to the path for the proftpd binary otherwise it won't have anything to launch.

The error message above you get has sometimes been a problem caused by an /etc/shutmsg so see if that reappeared and try again.

Cool
 
Old 07-28-2003, 08:24 AM   #13
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
here is the /etc/proftpd.conf


# This is a basic ProFTPD configuration file.
# It establishes a single server and a single anonymous login.
# It assumes that you have a user/group "nobody" and "ftp"
# for normal/anonymous operation.

ServerName "GUC ftpserver"
#ServerType standalone
ServerType inetd
DefaultServer on

# Port 21 is the standard FTP port.
Port 9876
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances 20

# Set the user and group that the server normally runs at.
User nobody
Group nogroup

# This next option is required for NIS or NIS+ to work properly:
#PersistentPasswd off

SystemLog /var/log/proftpd.log
TransferLog /var/log/xferlog

# Normally, we want files to be overwriteable.
<Directory /*>
AllowOverwrite on
</Directory>

# A basic anonymous FTP server configuration.
# To enable this, remove the user ftp from /etc/ftpusers.
#<Anonymous ~ftp>
# RequireValidShell off
# User ftp
# Group ftp
# # We want clients to be able to login with "anonymous" as well as "ftp"
# UserAlias anonymous ftp
#
# # Limit the maximum number of anonymous logins
# MaxClients 50
#
# # We want 'welcome.msg' displayed at login, and '.message' displayed
# # in each newly chdired directory.
# DisplayLogin welcome.msg
# DisplayFirstChdir .message
#
# # Limit WRITE everywhere in the anonymous chroot
# <Limit WRITE>
# DenyAll
# </Limit>
#
# An upload directory that allows storing files but not retrieving
# or creating directories.
# <Directory incoming/*>
# <Limit READ>
# DenyAll
# </Limit>
#
# <Limit STOR>
# AllowAll
# </Limit>
# </Directory>

#</Anonymous>


[COLOR=red]note that the anonymous section wasnt between # i changed that recently to see if it would help...[/COLOR

here is the basic.conf




# This is a basic ProFTPD configuration file (rename it to
# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "ProFTPD Default Installation"
ServerType standalone
DefaultServer on

# Port 21 is the standard FTP port.
Port 9876

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# To prevent DoS attacks, set the maximum number of child processes
# to 30. If you need to allow more than 30 concurrent connections
# at once, simply increase this value. Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd).
MaxInstances 30

# Set the user and group under which the server will run.
User nobody
Group nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.
#DefaultRoot ~

# Normally, we want files to be overwriteable.
<Directory />
AllowOverwrite on
</Directory>

# A basic anonymous configuration, no upload directories. If you do not
# want anonymous users, simply delete this entire <Anonymous> section.
<Anonymous ~ftp>
User ftp
Group ftp

# We want clients to be able to login with "anonymous" as well as "ftp"
UserAlias anonymous ftp

# Limit the maximum number of anonymous logins
MaxClients 10

# We want 'welcome.msg' displayed at login, and '.message' displayed
# in each newly chdired directory.
DisplayLogin welcome.msg
DisplayFirstChdir .message

# Limit WRITE everywhere in the anonymous chroot
<Limit WRITE>
DenyAll
</Limit>
</Anonymous>
 
Old 07-28-2003, 08:26 AM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Change that port to the standard ftp, send a HUP to inetd (if in inetd mode) or to proftpd (if in standalone) and ensure no /etc/shutmsg exists. Then:
ftp localhost

If you don't know, the standard FTP port is 21.

Cool
 
Old 07-28-2003, 08:35 AM   #15
guc
Member
 
Registered: Jul 2003
Posts: 34

Original Poster
Rep: Reputation: 15
i do know but i put it on another port beceause my isp blocks port 21 and i opend port 9876 on my router for the ftptraffic and since i'm testing locally i don't see what the port has to do with it, but i'll try it anyways beceause you never know



i'll kill all processes and reload it using

./proftpd -c /etc/proftpd.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd: proftpd startup failed tumana Linux - Newbie 14 06-17-2012 12:06 PM
[PROFTPD] Ldap and proftpd authentication wesleywest Linux - Software 1 02-22-2005 10:51 AM
Disabling the chroot in proftpd and enabling root logins on ssh/proftpd jon_k Linux - Software 1 06-16-2004 11:27 AM
Building a Pc j_w_ Linux - Hardware 2 06-14-2003 02:22 PM
proftpd --- need help? could someone post a working proftpd.conf i could look at ZooRoPa Linux - Networking 1 04-02-2003 07:56 PM


All times are GMT -5. The time now is 06:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration