LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Building gnome-session-3.4.2.1 (http://www.linuxquestions.org/questions/linux-software-2/building-gnome-session-3-4-2-1-a-4175419282/)

yelims 07-29-2012 11:17 PM

Building gnome-session-3.4.2.1
 
Hi all,
I'm trying to build gnome-session-3.4.2.1 on lfs 7.1 using Beyond Linux® From Scratch Version 2012-07-27
One of the Required Dependencies is giving me fits UPower-0.9.17, and its seems that this program is intended for a laptop. I'm building on a Dell 8300 desktop P-4 dual core 3.2 Ghz 2.5 gigs ram two 320 gig hd's multi-booting grub-097 windose-xp OpenSuse-11.3 which was my build host. I'm posting this from LFS 7.1 running IceWM-1.3.7 and SeaMonkey-2.10.1
I do not think I really need UPower-0.9.17. besides I cannot get it to configure due to fact it requires two progs that are not in the BLFS book.

upower config.log

:13348: $PKG_CONFIG --exists --print-errors "libimobiledevice-1.0 >= 0.9.7 libplist >= 0$
Package libimobiledevice-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libimobiledevice-1.0.pc'Try `
to the PKG_CONFIG_PATH environment variable
No package 'libimobiledevice-1.0' found
Package libplist was not found in the pkg-config search path.
Perhaps you should add the directory containing `libplist.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libplist' found

I searhed and found these two and attempted to install:
libplist installed without a hitch
libimobiledevice-1.0 (another prog I do not need it is for I Phones and pads that have been rooted)

libimobiledevice-1.0 config.log

configure:14790: $PKG_CONFIG --exists --print-errors "libusbmuxd >= 0.1.4"
Package libusbmuxd was not found in the pkg-config search path.
Perhaps you should add the directory containing `libusbmuxd.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libusbmuxd' found
configure:14793: $? = 1
configure:14806: $PKG_CONFIG --exists --print-errors "libusbmuxd >= 0.1.4"
Package libusbmuxd was not found in the pkg-config search path.
Perhaps you should add the directory containing `libusbmuxd.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libusbmuxd' found
configure:14809: $? = 1
configure:14822: result: no
No package 'libusbmuxd' found
configure:14838: error: Package requirements (libusbmuxd >= 0.1.4) were not met:

No package 'libusbmuxd' found

oops theres the third not in the book and one I do not need
which needs another dep that I cannot find (well, hav'nt really searched yet)

It did not create a config.log, but complained it needed a USB Library please install the (dev) version


I've tried to configure gnome-session --without -upower-glib to no avail ***

kevin [ /usr/src/GDM/gnome-session-3.4.2.1 ]$ ./configure --prefix=/usr \
> --without -upower-glib
configure: error: unrecognized option: `--without'
./configure --help' for more information
*******************************************************
"nano config.log"

Package upower-glib was not found in the pkg-config search path.
Perhaps you should add the directory containing `upower-glib.pc'
to the PKG_CONFIG_PATH environment variable
No package 'upower-glib' found
configure:12210: $? = 1
configure:12229: result: no
No package 'upower-glib' found
configure:12257: error: Package requirements (glib-2.0 >= 2.28.0
gio-2.0 >= 2.28.0
gtk+-3.0 >= 2.90.7
dbus-glib-1 >= 0.76
upower-glib >= 0.9.0
json-glib-1.0 >= 0.10
) were not met:

No package 'upower-glib' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.libimobiledevice-1.0

Alternatively, you may set the environment variables GNOME_SESSION_CFLAGS
and GNOME_SESSION_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

any sugestions or encouragement would be gladly accepted, Thanks


All times are GMT -5. The time now is 08:46 AM.