LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-12-2003, 10:47 AM   #1
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Rep: Reputation: 30
Building evolution 1.2.1: make error


I just installed dropline gnome yersterday and wanted to use evolution 1.2.1. I downloaded the source and want to build it.

I had to update some libraries but now when I do ./configure it all goes well. Until I try make that is. Make ends with these errors:


gcc: /usr/lib/libgal.so: No such file or directory
gcc: /usr/lib/libgnomecanvaspixbuf.so: No such file or directory
gcc: /usr/lib/libgdk_pixbuf.so: No such file or directory
make[3]: *** [libeutil.la] Error 1
make[3]: Leaving directory `/home/arjan/evolution-1.2.1/e-util'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/arjan/evolution-1.2.1/e-util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/arjan/evolution-1.2.1/e-util'
make: *** [all-recursive-am] Error 2


I have installed both of these packages, the devel versions too.
Any ideas?

HC
 
Old 02-12-2003, 11:08 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
If you have those lib's in your /usr/lib directory, try running ldconfig if you just installed them. This should update any lib's you've moved or installed so they are recognized. But first make sure they are actually located there, if you installed as a regular user it could have placed them in /usr/local/lib. If that's the case you can either move them or make symlinks to them from /usr/lib
 
Old 02-12-2003, 01:34 PM   #3
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Original Poster
Rep: Reputation: 30
Thanks for the fast reply!
That was excellent advice. I made symlinks as you suggested and now that works.

Problem is, now a lil later during make I get:

/home/arjan/evolution-1.2.1/mail/mail-signature-editor.c:c:171: undefined reference to `GNOME_GtkHTML_Editor_Engine_hasUndo'

I get this for the e-msg-composer file too and then it it stops with errors.

I guess I messed up the install of those libraries huh?

Btw, I'm sorry, I would like to solve this on my own but I can't find anything on this on google nor does it help when I check out the files make returns. So thanks for your time.

HC
 
Old 02-12-2003, 02:36 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Not totally for sure about that error. Have you installed the gtkhtml package with no errors ?
 
Old 02-12-2003, 03:18 PM   #5
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Original Poster
Rep: Reputation: 30
yeah it does although I do have to copy a file.

When I do ldconfig -v it says it cannot stat gtkhtml-1.1.so in usr/lib but there is a link called gtkhtml-1.1.so which links to gtkhtml-1.1.so.3.0.2. This last file is in usr/local/lib.

I figured I'd copy it to usr/lib. Then ldconfig -v finds everything but still I get the error I described.

Geez...I must really like my evolution eh LOL

HC
 
Old 02-16-2003, 07:02 AM   #6
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Original Poster
Rep: Reputation: 30
k, I got evolution 1.2.0 installed now. Using the tgz from dropline-sourceforge.

For those having problems with this:

from a fresh slack 8.1 installaltion upgrade to or install:

- gal 0.21
- gdk-pixbuf 0.19.0
- gtkhtml 1.1.6
- soup 0.7.4
(get them from linuxpackages.net)

Then I installed the latest dropline gnome but I'm not entirely sure this has to be done. As long as yer installing though, dropline gnome is nice enough so go ahead and do that

Then install evolution 1.2.0.

And voila, you're good to go.

HC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
make filter in evolution mohtasham1983 Linux - General 2 11-11-2005 10:39 AM
make evolution launch mozilla irvken Linux - Software 7 09-11-2005 09:48 PM
Building evolution-data-server-1.0.2-7.src.rpm louisb Linux - Enterprise 1 07-02-2005 05:45 PM
Building evolution-data-server-1.0.2-7.src.rpm louisb Linux - General 1 06-22-2005 09:21 AM
How can I make Thunderbord mailboxes .. like evolution ? CRego3D Linux - Software 2 09-27-2004 08:40 AM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration