LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Build of wxwindows ubuntu 6.10 (http://www.linuxquestions.org/questions/linux-software-2/build-of-wxwindows-ubuntu-6-10-a-519472/)

windsurfer 01-15-2007 10:38 AM

Build of wxwindows ubuntu 6.10
 
Hi

I have been having problems building wxwindows (libwxgtk2.4-python) getting "dependency is not satisfiable: python2.3"

Having installed the latest python 2.5 does this mean that I need a earlier version of python? In which case do I have to un-install 2.5 ? I would appreciate some clarification on this, does anyone know? I am using this to build pyBKM.

Adrian

win32sux 01-16-2007 09:49 AM

yeah, you can have multiple versions of python installed - no problem...

just curious: have you considered installing this with a:
Code:

sudo apt-get install python-wxgtk2.4
if you have the "universe" repositories enabled, the above command should download and install everything you need AFAICT...

windsurfer 01-17-2007 04:14 AM

The answer is no I hadnt tried installing it, silly me, now it is installed. Am trying to get Mondrian to work and I now get the error

./SessionManager.rb:10: uninitialized constant Fox (NameError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'

I have now installed fox so what does this mean? Sorry am quite new to this so I dont no what to do next.

win32sux 01-17-2007 07:17 AM

Quote:

Originally Posted by windsurfer
The answer is no I hadnt tried installing it, silly me, now it is installed. Am trying to get Mondrian to work and I now get the error

./SessionManager.rb:10: uninitialized constant Fox (NameError)
from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'

I have now installed fox so what does this mean? Sorry am quite new to this so I dont no what to do next.

well, i'd say check that your fxruby version is compatible...

i quote from the mondrian download page:
Quote:

Note: Mondrian 1.0 beta8 requires FXRuby 1.2.4 or FXRuby 1.2.6! Other versions don't work yet. Sorry for the inconvenience. I suck.
not sure what else to tell you... =/


All times are GMT -5. The time now is 04:52 PM.