LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-08-2010, 09:41 AM   #1
philwynk
Member
 
Registered: Sep 2007
Posts: 84

Rep: Reputation: 15
Browser video stuck on fast-forward


Ok, I'm stumped.

Starting sometime last night, without any intervention that I recall, suddenly any video being played by my browser ate 100% of the cpu (npviewer was taking 85% when I viewed using "top") and would not play properly.

I uninstalled firefox, vlc, xine, mplayer, flash-plugin, pulseaudio... really, everything I could imagine was involved. I reinstalled firefox, pulseaudio, and flash-plugin.

So, now it's not eating 100% of the cpu when I run a video. Instead, it's stuck on fast-forward -- it skips huge hunks of the video, blows through it at double- or triple-speed, and of course the audio comes in jerky little bursts that are incomprehensible because I've lost frames.

Apparently there's some configuration detail that I have to feed it to slow it down to standard speed. Only, I've been running Fedora here since 2007 and have never had to do this before. WTF?

Configuration details:

- Fedora core 13 64-bit version
- Running on an Athlon 64 @about 2.2 ghz (pretty fast -- can't imagine that I'm really overpowering the cpu)
- Firefox Mozilla/5.0 (X11; U; Linux x86_64; )
- Shockwave Flash 10.1 r82
- Currently have NO audio or video package installed outside of firefox (no Xine, no Totem, no Mplayer, no VLC)

What the heck is going on here? And how best should I restore just, plain ordinary playback capabilities to my machine?

Last edited by philwynk; 09-08-2010 at 11:05 AM.
 
Old 09-08-2010, 03:07 PM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 248Reputation: 248Reputation: 248
Were there any updates last night before this started ? Have a look at yum history and see if you might reverse the changes.
 
Old 09-08-2010, 06:55 PM   #3
philwynk
Member
 
Registered: Sep 2007
Posts: 84

Original Poster
Rep: Reputation: 15
I don't think that's it.

The following updates took place automatically, by way of a cron script that I execute in the middle of the night:

Sep 08 04:40:30 Updated: 1:NetworkManager-glib-0.8.1-6.git20100831.fc13.x86_64
Sep 08 04:40:35 Updated: 1:NetworkManager-0.8.1-6.git20100831.fc13.x86_64
Sep 08 04:40:36 Updated: usb_modeswitch-1.1.4-1.fc13.x86_64
Sep 08 04:40:38 Updated: usb_modeswitch-data-20100817-1.fc13.noarch
Sep 08 04:40:50 Updated: 1:NetworkManager-gnome-0.8.1-6.git20100831.fc13.x86_64


I can't see any of those causing the problem I've described.

Phil W.
 
Old 09-08-2010, 09:05 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 13,238

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
this was only for no line videos in firefox ? right
And not for ALL videos playing in totem, or mplayer/gmplayer/SMplayer-qt4 or vlc

just the online .

if so as i recall there was and is a bug in the 64bit flash

seeing as this" Currently have NO audio or video package installed outside of firefox (no Xine, no Totem, no Mplayer, no VLC)"
there is NO way to check if vlc,mplayer and the installed by default totem work fine

how then ARE you watching videos online without the
totem ff plugin( i do not use it),
or the mplayer ff plugin(mplayerplug-in.so,mplayerplug-in-wmp.so,mplayerplug-in-rm.so,mplayerplug-in-qt.so,mplayerplug-in-gmp.so,mplayerplug-in-dvx.so)
or the gstreammer - xine ff plugin(gxineplugin.so)
or the vlc ff plugin (libvlcplugin.so)

can you please post the firefox output of
Code:
about:plugins
so we can see just how you are watching videos on line
 
Old 09-08-2010, 11:05 PM   #5
philwynk
Member
 
Registered: Sep 2007
Posts: 84

Original Poster
Rep: Reputation: 15
Okay. Weird.

It affected both firefox and Opera, although it was not nearly as bad in Opera.

John VV makes a good point, so I went ahead and installed mplayer to test it from the command line. The result was that not only did mplayer handle the video just fine and dandy, but after I installed mplayer firefox ALSO handled the audio and video properly... and so did Opera.

I'm sure I should be learning something about the operation of these multimedia programs from this incident. I'm guessing that firefox gives preference to mplayer over the shockwave plugin, and mplayer contains controls for the audio/video components of my machine that do a better job of buffering than does shockwave.

Anyhow, it appears that I can now play multimedia files again, so... thanks for your help, all.

Just FYI, since you asked, though:

about : plugins

SHOCKWAVE FLASH
File: nswrapper_32_64.libflashplayer.so
Version:
Shockwave Flash 10.1 r82
application/x-shockwave-flash Shockwave Flash swf Yes
application/futuresplash FutureSplash Player spl Yes

NPAPI Plugins Wrapper 1.3.0

File: npwrapper.so
Version:

IcedTea NPR Web Browser Plugin (using IcedTea6 1.8.1 (fedora-42.b18.fc13-x86_64))

File: IcedTeaPlugin.so

followed by a mime type for every java version...
 
Old 09-09-2010, 02:24 AM   #6
John VV
Guru
 
Registered: Aug 2005
Posts: 13,238

Rep: Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774Reputation: 1774
for fedora this is a very very good help/guide page
it is short and right to the point
http://www.mjmwired.net/resources/mjm-fedora-f13.html
and very useful
 
Old 09-09-2010, 07:30 AM   #7
philwynk
Member
 
Registered: Sep 2007
Posts: 84

Original Poster
Rep: Reputation: 15
John VV, I think you misread...

John, thanks for the link. I'm already pretty familiar with that page, and I think you missed the part of the post that started this thread in which I said that I had, just the previous night, REMOVED pulseaudio, mplayer, vlc, and xine in an attempt to find out what was eating my cpu. That means I had all of them installed until about 2 nights ago. I was using one or more of the above to view videos, and they were working just fine until the other night. It was the sudden influx of "Oh, s**t, that isn't working for some reason" that started the current mess.

Thanks again for your help.
 
Old 09-09-2010, 07:42 AM   #8
MTK358
LQ 5k Club
 
Registered: Sep 2009
Posts: 6,443
Blog Entries: 3

Rep: Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714Reputation: 714
If this is solved, mark the thread as solved.
 
Old 06-21-2012, 11:44 AM   #9
wytcld
LQ Newbie
 
Registered: Oct 2003
Location: VT
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
In my case Flash videos were racing ahead because of a sound setting. They'd started racing ahead at download speed after upgrading Ubuntu to 12.04.

Found the problem. It's an odd one. Looking in the Volume Control app (not sure if it's a Gnome or Xfce thing - desktop is Xfce), it showed that it has been defaulting to trying to play the audio stream through "Redwood HMDI Audio" on account of seeing a Radeon video card in the system. Turning that off under the Configuration tab and having Built-in Audio set to the appropriate (in my case) Analog Stereo Audio not only restores sound, but it fixes the Flash-video-racing-ahead problem.

What's insane is that video should race ahead because of a non-functioning audio output. How could Adobe have ever programmed Flash with that dependency?

In any case it appears that in the upgrade cycle Ubuntu insisted on bringing HDMI audio back into play. That had been set correctly - off - before the upgrade. I do have HDMI to my monitor, but its speakers are analog.

So if Flash videos race ahead, see if adjusting your sound settings fixes it.
 
Old 08-11-2012, 03:09 AM   #10
Idiosyncra3y
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Rep: Reputation: 0
Thank you wytcld. Exactly the same problem here, and exactly the same fix.

Fedora 17 here.
 
  


Reply

Tags
audio, fedora, firefox, flash, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Youtube/flash player stuck in fast forward vex390 Linux - Software 12 08-11-2012 07:38 PM
LXer: Fast forward with a Kazehakase web browser LXer Syndicated Linux News 0 03-28-2007 04:46 PM
Opera Fast Forward mjolnir LQ Suggestions & Feedback 4 05-26-2003 12:14 AM


All times are GMT -5. The time now is 07:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration