LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-16-2010, 12:14 AM   #1
nikunjbadjatya
Member
 
Registered: Sep 2009
Location: Bangalore
Posts: 33

Rep: Reputation: 0
Broken YUM and Possibly Python


Hi,
http://pastebin.centos.org/33380
shows system related information.

* Python versions 2.4 and 2.6 both are installed.
* /usr/bin/python directs to python 2.6.5
* Also, /opt contains python3.1
* The ADD/REMOVE software GUI also has gone.

Q. Is my system beyond repair?
Q. How do I completely remove all available python versions and yum, then reinstall them again.?

Kindly Help.!

Thanks,
Nikunj
Bangalore, INDIA
 
Old 06-16-2010, 12:42 AM   #2
subho.d
Member
 
Registered: Jun 2010
Location: INDIA
Distribution: All Linux & Unix
Posts: 86

Rep: Reputation: 19
remove the package by
Quote:
rpm -qa |grep python
rpm -e ***
then install
rpm -ivh <new rpm >
 
Old 06-16-2010, 04:28 AM   #3
nikunjbadjatya
Member
 
Registered: Sep 2009
Location: Bangalore
Posts: 33

Original Poster
Rep: Reputation: 0
I reinstalled python. Now I want to install YUM.The links are from centos "http://mirror.centos.org/centos-5/5/os/i386/CentOS/"
I have followed these steps.


$ rpm -Uvh yum-3.2.22-26.el5.centos.noarch.rpm yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm yum-metadata-parser-1.1.2-3.el5.centos.i386.rpm
Preparing... ########################################### [100%]
1:yum-metadata-parser ########################################### [ 33%]
2:yum-fastestmirror ########################################### [ 67%]
3:yum ########################################### [100%]
error: unpacking of archive failed on file /usr/share/yum-cli/yumcommands.pyo;4c18976f: cpio: read failed - Bad file descriptor


$ yum
Traceback (most recent call last):
File "/usr/bin/yum", line 28, in ?
import yummain
File "/usr/share/yum-cli/yummain.py", line 34, in ?
from utils import suppress_keyboard_interrupt_message, show_lock_owner
ImportError: cannot import name suppress_keyboard_interrupt_message


$ rpm -q *yum*
package yum-3.2.22-26.el5.centos.noarch.rpm is not installed
package yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm is not installed
package yum-metadata-parser-1.1.2-3.el5.centos.i386.rpm is not installed


What to do next?
 
Old 06-17-2010, 12:55 AM   #4
nikunjbadjatya
Member
 
Registered: Sep 2009
Location: Bangalore
Posts: 33

Original Poster
Rep: Reputation: 0
Hi All,

I rectified the error finally.

With yum rpm, additional dependency rpm's also needs to be installed. Which I was missing.
There are 5 rpm's in total including yum rpm.
Downloaded from "http://mirror.centos.org/centos-5/5/os/i386/CentOS/", these are :
yum-3.2.22-26.el5.centos.noarch.rpm
yum-fastestmirror-1.1.16-14.el5.centos.1.noarch.rpm
yum-metadata-parser-1.1.2-3.el5.centos.i386.rpm
yum-utils-1.1.16-14.el5.centos.1.noarch.rpm
yum-priorities-1.1.16-14.el5.centos.1.noarch.rpm

Install all these ( as root )together with
Code:
$ rpm -ivh yum*
To check for installation run,
Code:
$rpm -qa yum-\*
The above five rpm's should come.

Thats it.!

Last edited by nikunjbadjatya; 06-17-2010 at 01:00 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum broken Incorrect python version FC6 zeromaster Fedora 7 11-24-2007 08:54 AM
possibly broken USB hub newbiesforever General 1 05-14-2007 03:31 PM
broken yum - "No module named yum" shihab-alain Linux - Software 2 05-10-2006 05:09 AM
Possibly broken Motherboard madsporkmurderer Linux - Hardware 2 05-06-2006 03:34 PM
vector problems (possibly a broken install) laydros VectorLinux 1 11-28-2003 09:57 PM


All times are GMT -5. The time now is 09:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration