LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-26-2012, 09:44 PM   #1
cheltz
Member
 
Registered: Apr 2010
Posts: 62

Rep: Reputation: 2
broken yum and add/remove software


Here is one of those situation where I shot myself in the foot. Unfortunetly , I do not know how to fix this.
When I try to ues yum it says the following:

[root@localhost ~]# yum -y install java-1/6/0
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: mirror.symnds.com
* c6-media:
* extras: mirror.lug.udel.edu
* updates: mirror.ash.fastserv.com
file:///media/CentOS/repodata/repomd.xml: [Errno 14] Could not open/read file:///media/CentOS/repodata/repomd.xml
Trying other mirror.
file:///media/cdrecorder/repodata/repomd.xml: [Errno 14] Could not open/read file:///media/cdrecorder/repodata/repomd.xml
Trying other mirror.
file:///media/cdrom/repodata/repomd.xml: [Errno 14] Could not open/read file:///media/cdrom/repodata/repomd.xml
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: c6-media. Please verify its path and try again

No clue what that is .. same with the add /remove software thing.

I was earlier playing with the system/software sources pull down in add/remove.

How can I fix this?

I have ben trying for a few hours without luck.

Thanks for your help
 
Old 02-26-2012, 10:06 PM   #2
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
looks like it's trying to read a cdrom for repo data, and failing. check /etc/yum.repos.d/ for a cdrom-based repo, and disable it.
 
Old 02-26-2012, 10:16 PM   #3
cheltz
Member
 
Registered: Apr 2010
Posts: 62

Original Poster
Rep: Reputation: 2
yes your right i just had to change
enabled=0
in the file you referred to

thank you !!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Software update or Add/Remove Software does not work in LXDE debiantu Fedora 2 07-05-2011 05:12 PM
Problem ADD / REMOVE PROGRAM and YUM kumbhalkar_sachin Programming 1 06-08-2009 03:00 AM
add/remove - yum hDUQUE Fedora 1 12-23-2008 08:49 AM
Error in accessing add/remove software and YUM rohit83.ken Linux - Software 1 03-20-2008 08:40 AM
Add/Remove Software - Unable to retrieve software information oohyeah Linux - Newbie 7 02-17-2008 06:30 AM


All times are GMT -5. The time now is 03:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration